[Pulseaudio/Alsa] Brak dźwięku [Solved]

Ogólne dyskusje o Sabayon Linux

Moderator: Moderators

Post Reply
Draqun
Baby Hen
Posts: 9
Joined: Mon Aug 09, 2010 11:50

[Pulseaudio/Alsa] Brak dźwięku [Solved]

Post by Draqun » Thu Sep 02, 2010 6:54

Na mój desktop wrócił Sabayon. Wersja 5.3 z GNOME. Wszystko ok tylko tak jak w temacie. Nie działa mi dźwięki ani na alsie ani na PA. Nie mam bladego pojęcia co jest grane. Wszystkie updaty porobione, Wywaliłem PA i Alse po czym zainstlowałem je ponownie. Dalej nic.

Lspci

Code: Select all

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
Nie działa często proponowane

Code: Select all

sudo alsa force-reload

cat /etc/modprobe.d/alsa.conf

Code: Select all

# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
Próbowałem wszelkich dziwnych ustawień w graficznych cudeńkach od dźwięku. Pavucontrol pokazuje mi, że z dźwiękiem wszystko ok a jednak coś dalej nie gra.

A teraz lecę szukać tu po forum. Prosze o rychłą odpowiedź :) (Ps. na Win7 dziala wszystko ok ;))
Last edited by Draqun on Fri Sep 03, 2010 8:24, edited 1 time in total.
Image

benyo76
Baby Hen
Posts: 1
Joined: Tue Jun 08, 2010 17:47

Re: [Pulseaudio/Alsa] Brak dźwięku

Post by benyo76 » Thu Sep 02, 2010 20:59


Draqun
Baby Hen
Posts: 9
Joined: Mon Aug 09, 2010 11:50

Re: [Pulseaudio/Alsa] Brak dźwięku

Post by Draqun » Fri Sep 03, 2010 8:24

Dla karty ALC268 przy sterownikach

Code: Select all

Advanced Linux Sound Architecture Driver Version 1.0.22.1.
zadziałało dopiero

Code: Select all

options snd-pcsp index=-2
options snd-hda-intel model=toshiba
Image

Post Reply