Page 1 of 1

Some daily iso's fail to start X on specific GPUs

Posted: Tue Mar 27, 2012 23:01
by aquarius
I'm not shure if it is actually a bug.
I've tried to run Sabayon_Linux_DAILY_amd64_E17.iso from USB stick. I used Unetbootin for this purpose. Sabayon failed to get to runlevel 5 (no GUI in LIVE mode, no anaconda screen in GUI INSTALLATION mode). I've checked 2 versions: from March 25 and the previous one. I did it on 2 different machines.

Yes, I saw following doc on the wiki: HOWTO: Booting Sabayon LiveDVD Image from a USB Device with Grub. But:
1) the doc is almost 2 years old (it refers to grub (not grub2) and SL 5.2), so it is probably outdated
2) the same approach (unetbootin) works for Sabayon_Linux_8_amd64_Xfce.iso (which I was able to run in live mode and install on hard drive).

Maybe this is not a bug. But there should be some way to install SL via USB stick :D

Re: amd64_E17 fails to boot from USB stick

Posted: Wed Mar 28, 2012 5:55
by wolfden
if you can't get to a gui than you need to check the logs to see why or try some cheatcodes. The wiki article should still be valid, just point to ISO file and USB drive. Make sure the md5sum is good also

Re: amd64_E17 fails to boot from USB stick

Posted: Fri Mar 30, 2012 20:05
by aquarius
Thanks for hints, wolfden!

Checksum is fine.
I looks like SL + my GPUs are causing problem.
On laptop with geforce 560m there is following erron in Xorg.0.log:

Code: Select all

[    32.188] (WW) NV: Ignoring unsupported device 0x10de1251 at [email protected]:00:0
[    32.188] (EE) No devices detected.
[    32.188] 
Fatal server error:
[    32.188] no screens found
On netbook with radeon x1250 the error in Xorg.0.log is:

Code: Select all

[    35.575] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.12.0.[dri] Make sure your module is loaded prior to starting X, and
[dri] that this driver was built with support for KMS.
[dri] Aborting.
[    35.575] (II) UnloadModule: "radeon"
[    35.575] (II) Unloading radeon
[    35.575] (II) UnloadModule: "int10"
[    35.575] (II) Unloading int10
[    35.575] (II) UnloadModule: "vgahw"
[    35.575] (II) Unloading vgahw
[    35.575] (EE) Screen(s) found, but none have a usable configuration.
[    35.575] 
Fatal server error:
[    35.575] no screens found
Both errors are for Sabayon_Linux_DAILY_amd64_E17.iso from March 25.

I'm going to try the following:
1) Use newer E17 iso.
2) Use another iso (probably xfce). As I've written before, Sabayon_Linux_8_amd64_Xfce.iso works fine.

Re: amd64_E17 fails to boot from USB stick

Posted: Sat Mar 31, 2012 14:17
by aquarius
OK. I've tried newest E17 iso (from March 28). And the result is the same on both machines.
However the situation is different with latest XFCE iso. It also fails on laptop with geforce 560m, but it perfectly works on netbook with radeon x1250.

Here is the situation overview
Laptop's GPUSL 8 XFCESL daily XFCESL daily E17
geforce 560mworksfailsfails
radeon x1250unknownworksfails
Obviously I might be wrong. But it seams to me that each iso should be able to boot and start X (GUI). In this case each fail in the table above is a bug.
Please, confirm or reject my assumption :)

P.S. Also, now I believe the problem are related with GPUs and not with USB-stick boot method. So, I'm renaming the thread accordingly.