Page 4 of 4

Re: General audio issues (pulseaudio)

Posted: Mon Oct 05, 2020 16:54
by krznv

Code: Select all

ls -l /home
total 8
drwxrwxrwx 1 root root 8192 okt  5 19:03 krznv

Code: Select all

ls -la /home/krznv/.config/pulse
total 9
drwxrwxrwx 1 root root    0 sep 29 07:24 .
drwxrwxrwx 1 root root 8192 okt  5 18:14 ..
-rwxrwxrwx 1 root root  256 sep 29 07:24 cookie
Thank you for your efforts so far.

Re: General audio issues (pulseaudio)

Posted: Mon Oct 05, 2020 17:02
by Stupot
Ok, whoa. I think we've probably hit the root cause.

Your user directory should NOT be owned by root (nor the files underneath it).

Was this user account created during the initial install?

Given that this was a fresh install, I'm hoping you haven't put too much effort into customization at this point. We might want to blow your entire user directory away.

Re: General audio issues (pulseaudio)

Posted: Mon Oct 05, 2020 17:41
by sabayonino
change your home owner from root to "krznv" (your user):

Code: Select all

sudo chown krznv:kzrnv -R /home/krznv 


Change home permissions

Code: Select all

sudo chmod -R a+rwX,o-w /home/krznv

Re: General audio issues (pulseaudio)

Posted: Mon Oct 05, 2020 17:54
by krznv
Stupot wrote:
Mon Oct 05, 2020 17:02
Ok, whoa. I think we've probably hit the root cause.

Your user directory should NOT be owned by root (nor the files underneath it).

Was this user account created during the initial install?

Given that this was a fresh install, I'm hoping you haven't put too much effort into customization at this point. We might want to blow your entire user directory away.
Yes the user was created normally during fresh install from USB.
sabayonino wrote:
Mon Oct 05, 2020 17:41
change your home owner from root to "krznv" (your user):

Code: Select all

sudo chown krznv:kzrnv -R /home/krznv 


Change home permissions

Code: Select all

sudo chmod -R a+rwX,o-w /home/krznv
This makes the sound work in the login manager but not the OS. Running pulseaudio after the commands still gives the same output.

Re: General audio issues (pulseaudio)

Posted: Mon Oct 05, 2020 20:58
by Stupot
Assuming you've done a full reboot since making those changes, what is the output of these commands now?

Code: Select all

 ps aux | grep pulseaudio

Code: Select all

 lsof /dev/snd/*

Code: Select all

 systemctl --user status pulseaudio

Re: General audio issues (pulseaudio)

Posted: Tue Oct 06, 2020 6:06
by krznv

Code: Select all

 ps aux | grep pulseaudio

Code: Select all

ps aux | grep pulseaudio 
gdm        878  0.3  0.3 1390928 24208 ?       Sl   08:14   0:00 /usr/bin/pulseaudio --start --log-target=syslog
krznv     2191  0.0  0.0 211128   872 pts/0    S+   08:15   0:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn --exclude-dir=.idea --exclude-dir=.tox pulseaudio

Code: Select all

 lsof /dev/snd/*
No output

Code: Select all

 systemctl --user status pulseaudio

Code: Select all

● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-10-06 08:14:53 CEST; 1min 42s ago
  Process: 1419 ExecStart=/usr/bin/pulseaudio --daemonize=no (code=exited, status=1/FAILURE)
 Main PID: 1419 (code=exited, status=1/FAILURE)

okt 06 08:14:53 ThinkPad-T460 systemd[1058]: pulseaudio.service: Service RestartSec=100ms expired, scheduling restart.
okt 06 08:14:53 ThinkPad-T460 systemd[1058]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
okt 06 08:14:53 ThinkPad-T460 systemd[1058]: Stopped Sound Service.
okt 06 08:14:53 ThinkPad-T460 systemd[1058]: pulseaudio.service: Start request repeated too quickly.
okt 06 08:14:53 ThinkPad-T460 systemd[1058]: pulseaudio.service: Failed with result 'exit-code'.
okt 06 08:14:53 ThinkPad-T460 systemd[1058]: Failed to start Sound Service.

Re: General audio issues (pulseaudio)

Posted: Tue Oct 06, 2020 11:53
by sabayonino
I suspect your user hasn't the right groups in the system if your user was not properly configured

please , as USER , type and report:

Code: Select all

$ groups

Re: General audio issues (pulseaudio)

Posted: Tue Oct 06, 2020 13:43
by krznv
sabayonino wrote:
Tue Oct 06, 2020 11:53
I suspect your user hasn't the right groups in the system if your user was not properly configured

please , as USER , type and report:

Code: Select all

$ groups

Code: Select all

lp wheel audio cdrom video cdrw usb users entropy plugdev lpadmin messagebus portage vboxsf vboxguest scanner games network storage vboxusers polkituser bumblebee autologin krznv

Re: General audio issues (pulseaudio)

Posted: Wed Oct 14, 2020 18:32
by krznv
krznv wrote:
Mon Oct 05, 2020 16:54

Code: Select all

ls -l /home
total 8
drwxrwxrwx 1 root root 8192 okt  5 19:03 krznv

Code: Select all

ls -la /home/krznv/.config/pulse
total 9
drwxrwxrwx 1 root root    0 sep 29 07:24 .
drwxrwxrwx 1 root root 8192 okt  5 18:14 ..
-rwxrwxrwx 1 root root  256 sep 29 07:24 cookie
Thank you for your efforts so far.
Even after taking ownership of /home with the commands stupot provided the output is still the same as in this post.

https://wiki.gentoo.org/wiki/PulseAudio#Permissions
I'm trying to apply this fix, but when I try to configure the kernel, I get the following error
Running

Code: Select all

make menuconfig
in usr/src/linux
Gives me

Code: Select all

Makefile:560: arch//Makefile: No such file or directory
make: *** No rule to make target 'arch//Makefile'.  Stop.
Also, it says
For consoleKit/systemd logind managed permissions to be respected, no one may be part of the audio group (not even even the user pulse). Remove any and all users from the audio group:
There is another fix here
https://wiki.archlinux.org/index.php/Ge ... ermissions
My output of

Code: Select all

$ loginctl show-session $XDG_SESSION_ID
Doesn't contain
Remote=no
and
Active=yes
But I don't know how to make sure that X runs on the same tty where the login occurred