Page 1 of 1

Problems with Chromium Post-Upgrade [Solved]

Posted: Tue Jun 04, 2019 4:36
by VolvoBirkenstock
Hello, Sabayon Gurus.

This issue has me a bit flummoxed.

I upgrade my systems religiously/weekly. This past weekend I upgraded my desktop, but subsequent to the upgrade, Chromium was unusable with an unreadable blocky pseudo-random graphical appearance whenever any manipulation was made inside the browser. I have not upgraded the kernel in a long time, and am running a 4.9 kernel. I have also masked

Code: Select all

=sys-apps/systemd-239-r2
=sys-apps/systemd-239-r3
=sys-apps/systemd-239-r4
due to unstable behavior with this older kernel.
My desktop uses AMD cpus and gpus (Radeon).
"eselect opengl list;eselect opencl list;" returns

Code: Select all

Available OpenGL implementations:
  [1]   xorg-x11 *
Available OpenCL implementations:
  [1]   nvidia *
  [2]   ocl-icd
Do you believe a kernel upgrade is necessary? If not, please tell me what information you need in order to discern what the problem is in order to determine how I can correct it.

Thank you very much in advance.

Re: Problems with Chromium Post-Upgrade

Posted: Sat Jun 08, 2019 12:37
by Alexander88207
Hello VolvoBirkenstock,

this is a bug of Mesa 19.0.5 and is already fixed in 19.1.0-rc4, but dont worry an update to the 19.0 stable branch is coming :).

In the meantime, you can disable the hardware acceleration in Chromium.

Source: https://bugs.freedesktop.org/show_bug.cgi?id=110721

Re: Problems with Chromium Post-Upgrade

Posted: Tue Jun 11, 2019 5:33
by VolvoBirkenstock
Hi, Alexander88207.

I read over the bug thread and didn't see explicit command-line arguments that defeat the problem. The explicit command-line arguments appear to force the problem. Also, I can't open and run Chromium and then internally turn-off hardware acceleration because the appearance is illegible.

Do you have any explicit instructions of how I can stop the problem? Otherwise I will workaround by using Firefox until the fix is promoted to Sabayon/Gentoo.

By the way, I have performed an LFC and upgraded to the 5.0 kernel.

Thank you very much!

Re: Problems with Chromium Post-Upgrade

Posted: Tue Jun 11, 2019 14:31
by andreios

Code: Select all

chromium-browser --disable-gpu
does the trick. Or just update with daily repo right now and you get mesa 19.0.6 which fixed it for me.

Re: Problems with Chromium Post-Upgrade

Posted: Wed Jun 12, 2019 2:41
by VolvoBirkenstock
Thank you very much, andreios.
I will use the "--disable-gpu" argument for now, and wait for the weekly repo this weekend. :-)
Marking this thread "Solved". :-)