A few issues with apps in a fresh install of 19.03

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 14
Joined: Sat Jul 02, 2016 7:52

A few issues with apps in a fresh install of 19.03

Post by swejuggalo » Fri May 03, 2019 8:17

I'm back with Sabayon again :)

The first issue was with creating the bootable iso file from Ubuntu. That was solved with Etcher since some other solutions does not seem to make it right... It booted halfway with errors. Solution was found here by the way :)

I might add more app issues here later. I'll continue to search for solutions.

1. Teamviewer. I tried the most up to date version from Rigo. It can't connect (issue with the deamon?). The official tar.xz connects (just ectrated and run without anything else done) and works but will probably need additional steps to make it work as a deamon or assign to account (./tv-setup solves that). Either solution would be fine, but a bonus would be to make Rigo version work (most beginner friendly).

2. Boinc. Once again it seems to be some kind of connection issue. Options are grayed out and after some time the manager says that boinc has crashed. I havn't tried versions outside of Rigo yet.
Tried this install method now. https://wiki.sabayon.org/index.php?titl ... ling_BOINC .
Some issues so far...
Seems to have got it to work now. "systemctl start boinc && systemctl stop boinc" seems to be "systemctl start boinc-client && systemctl stop boinc-client", and some other minor things that did not seem to work according to the guide. It might need a update.

User avatar
Sagely Hen
Posts: 3435
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: A few issues with apps in a fresh install of 19.03

Post by sabayonino » Fri May 03, 2019 17:02


1 - Teamviever has a service and it can be started following the info message after install:

Code: Select all

[...]* Systemd:
 * # systemctl start teamviewerd.service
 * # systemctl enable teamviewerd.service
 * To display additional command line options simply run:
 * $ teamviewer help

2 - boinc
a) Boinc Service was moved from /usr/lib64/systemd/system/boinc.service to /usr/lib64/systemd/system/boinc-client.service
so you can edit new file

b) Your data (or boinc directory) must have the right writing/reading permissions , so check if boinc service is configured for your user and set the right permissions

c) restart the service and check if the service is running

Code: Select all

# systemctl restart boinc-client && systemctl status boinc-client

This is my configuration file:

Code: Select all

cat /usr/lib/systemd/system/boinc-client.service
Description=Berkeley Open Infrastructure Network Computing Client

ExecStart=/usr/bin/boinc --dir /backups/boinc --redirectio --allow_remote_gui_rpc
ExecStop=/usr/bin/boinccmd --quit
ExecReload=/usr/bin/boinccmd --read_cc_config
ExecStopPost=/bin/rm -f lockfile


/backups/boinc is boinc working directory and it has 775 right permission for my user
You can keep default directory (/var/lib/boinc) , so you must set the permissions for your user or adding your user to the boinc group

Code: Select all

# gpasswd <your_user> boinc
Be sure that boinc group has read/write permisisons (7 r/w (user) | 7 r/w (group) | 5 r/- (others) )

Code: Select all

# chmod 775 -R /var/lib/boinc

3 - If you don't know a service name , check /usr/lib/systemd/system directory usually.

Post Reply