lost wifi just after installation... [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

lost wifi just after installation... [Solved]

Post by Finrod » Fri Jan 25, 2019 23:04

dear all,
I've been able to install Sabayon on my Lenovo ideapad 320, and it seems to work... except that after updating, upgrading and installing some more applications I rebooted and... wifi doesn't work anymore :-(
Now working and connected thanks to an Ethernet cable.
However from tomorrow until Tuesday I'll be away, I'll bring the cable with me but I doubt I'll be able to plug it in my b&b room... good thing I can boot with Windows on this machine :-D

What should I do now to know what happened? I did most of the update, upgrade from the terminal... then I also opened the packages application and it kept telling me there were some packages not maintained (one could be base-gcc?) and to be deleted manually, and I did that... I wonder if I just managed to delete something that was needed for the wifi...

thanks!
Last edited by Finrod on Fri Feb 08, 2019 20:50, edited 1 time in total.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8186
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: lost wifi just after installation...

Post by Fitzcarraldo » Mon Jan 28, 2019 15:59

What is your Wi-Fi hardware? You can list your machine's hardware using the following commands:

Code: Select all

# lspci
# lsusb
You can check which modules (drivers) are currently loaded using the following command:

Code: Select all

# lsmod
How did you upgrade your installation? See the Sabayon Linux Wiki for the full procedure, but, in essence, the following commands should result in a sane installation:

Code: Select all

# equo update
# equo upgrade
# equo conf update
# equo deptest
# equo libtest
# equo upgrade --purge
# equo cleanup
Also, is the firmware corresponding to your Wi-Fi hardware installed?

Code: Select all

# equo search --installed linux-firmware
You can check which kernel is currently running:

Code: Select all

# uname -a
You can check which Sabayon Linux kernel images are currently available and which are installed:

Code: Select all

# equo search linux-sabayon
You can switch to another kernel image using:

Code: Select all

# kernel-switcher switch <desired kernel>

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

Re: lost wifi just after installation...

Post by Finrod » Mon Jan 28, 2019 18:10

thanks, can't check right now. I upgraded using the commands you listed, except the last 2 (I guess).
I'll go through all your infos tomorrow evening or at the latest the day after if I'll arrive home too late tomorrow.

rbrick49
Growing Hen
Posts: 116
Joined: Sun Apr 08, 2012 13:46
Location: Thailand

Re: lost wifi just after installation...

Post by rbrick49 » Tue Jan 29, 2019 1:52

have the same problem with new install of sabayon gnome tried install twice same result after updating sabayon as per the wiki both times wifi not installed will look at it later
I fixed my problem by installing kernel 4.19.16 everything is ok now
Host: sabayon.local Kernel: 4.19.0-sabayon x86_64 bits: 64

https://www.linuxcounter.net/cert/621932.png

Stupot
Sagely Hen
Posts: 1724
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: lost wifi just after installation...

Post by Stupot » Wed Jan 30, 2019 1:31

Code: Select all

# equo search linux-sabayon
Fitz, just as an fyi, I find it much easier to remember

Code: Select all

# kernel-switcher list
which gives you the same output.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8186
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: lost wifi just after installation...

Post by Fitzcarraldo » Wed Jan 30, 2019 8:49

Thanks for the tip, Stupot.

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

Re: lost wifi just after installation...

Post by Finrod » Wed Jan 30, 2019 22:33

hi to all,
quick update... not much time today and I just tried to switch kernel, from 4.14 to 4.19... wifi connected but machine super slow (in fact stuck, I had to switch it off with the physical button), tried 4.18 and it was the same, wifi but unusable machine :-(
Hopefully tomorrow I'll have the time to go through all the instructions and report... and hopefully finally fix it...

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

Re: lost wifi just after installation...

Post by Finrod » Thu Jan 31, 2019 8:52

this is what comes out from lspci:
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Processor Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) I/O Memory Management Unit
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] (rev da)
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15b3
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Host Bridge
00:02.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Processor Root Port
00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Processor Root Port
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Host Bridge
00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1578
00:09.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157d
00:09.2 Audio device: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Audio Controller
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 20)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 4b)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 49)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 4b)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b5
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

Re: lost wifi just after installation...

Post by Finrod » Thu Jan 31, 2019 8:53

lsusb output:
Bus 003 Device 004: ID 04f2:b5d7 Chicony Electronics Co., Ltd
Bus 003 Device 003: ID 0cf3:e500 Qualcomm Atheros Communications
Bus 003 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Finrod
Young Hen
Posts: 36
Joined: Thu Jan 24, 2019 22:00
Location: Italy (but very often abroad)

Re: lost wifi just after installation...

Post by Finrod » Thu Jan 31, 2019 8:54

lsmod:
Module Size Used by
fuse 102400 2
xt_tcpudp 16384 3
ip6t_rpfilter 16384 1
ip6t_REJECT 16384 2
nf_reject_ipv6 16384 1 ip6t_REJECT
ipt_REJECT 16384 2
nf_reject_ipv4 16384 1 ipt_REJECT
xt_conntrack 16384 11
nfnetlink 16384 0
ebtable_nat 16384 1
ebtable_broute 16384 1
bridge 147456 1 ebtable_broute
stp 16384 1 bridge
llc 16384 2 bridge,stp
ip6table_nat 16384 1
nf_conntrack_ipv6 16384 7
nf_defrag_ipv6 20480 1 nf_conntrack_ipv6
nf_nat_ipv6 16384 1 ip6table_nat
ip6table_mangle 16384 1
ip6table_raw 16384 1
ip6table_security 16384 1
iptable_nat 16384 1
nf_conntrack_ipv4 16384 6
nf_defrag_ipv4 16384 1 nf_conntrack_ipv4
nf_nat_ipv4 16384 1 iptable_nat
nf_nat 28672 2 nf_nat_ipv6,nf_nat_ipv4
nf_conntrack 122880 6 xt_conntrack,nf_conntrack_ipv6,nf_conntrack_ipv4,nf_nat,nf_nat_ipv6,nf_nat_ipv4
iptable_mangle 16384 1
iptable_raw 16384 1
iptable_security 16384 1
ebtable_filter 16384 1
ebtables 36864 3 ebtable_nat,ebtable_filter,ebtable_broute
ip6table_filter 16384 1
ip6_tables 28672 6 ip6table_filter,ip6table_raw,ip6table_nat,ip6table_mangle,ip6table_security
iptable_filter 16384 1
ip_tables 28672 5 iptable_filter,iptable_security,iptable_raw,iptable_nat,iptable_mangle
x_tables 32768 16 ebtables,ip6table_filter,xt_conntrack,ip6table_raw,iptable_filter,iptable_security,ip6t_rpfilter,xt_tcpudp,ip6_tables,ipt_REJECT,iptable_raw,ip_tables,ip6table_mangle,ip6table_security,ip6t_REJECT,iptable_mangle
uvcvideo 94208 0
btusb 49152 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 20480 1 btusb
bluetooth 499712 5 btrtl,btintel,btbcm,btusb
ecdh_generic 24576 1 bluetooth
r8169 81920 0
ath10k_pci 49152 0
ath10k_core 278528 1 ath10k_pci
ath 32768 1 ath10k_core
mac80211 475136 1 ath10k_core
kvm 409600 0
pcspkr 16384 0
irqbypass 16384 1 kvm
cfg80211 315392 3 ath,mac80211,ath10k_core
sp5100_tco 16384 0
efi_pstore 16384 0
fam15h_power 16384 0
input_leds 16384 0
joydev 24576 0
snd_hda_codec_generic 73728 1
snd_hda_codec_hdmi 53248 1
efivars 20480 1 efi_pstore
ideapad_laptop 32768 0
mii 16384 1 r8169
i2c_piix4 24576 0
snd_hda_intel 36864 4
sparse_keymap 16384 1 ideapad_laptop
shpchp 36864 0
tpm_crb 16384 0
tpm_tis 16384 0
tpm_tis_core 20480 1 tpm_tis
tpm 57344 3 tpm_tis,tpm_crb,tpm_tis_core
snd_hda_codec 106496 3 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core 61440 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_hwdep 16384 1 snd_hda_codec
snd_pcm 94208 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer 32768 1 snd_pcm
snd 73728 15 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm
pcc_cpufreq 16384 0
sch_fq_codel 20480 2
efivarfs 16384 1
sha256_mb 28672 0
mcryptd 16384 1 sha256_mb
sha256_ssse3 32768 4
sha256_generic 20480 1 sha256_ssse3
ipv6 462848 79 nf_conntrack_ipv6,bridge,ip6t_rpfilter,nf_defrag_ipv6,nf_nat_ipv6,nf_reject_ipv6,ip6table_mangle
crc_ccitt 16384 1 ipv6
ext4 438272 2
mbcache 16384 1 ext4
jbd2 77824 1 ext4
fscrypto 28672 1 ext4
hid_generic 16384 0
crct10dif_pclmul 16384 0
crc32_pclmul 16384 0
crc32c_intel 20480 2
ghash_clmulni_intel 16384 0
pcbc 16384 0
aesni_intel 163840 0
aes_x86_64 20480 1 aesni_intel
crypto_simd 16384 1 aesni_intel
cryptd 20480 3 crypto_simd,ghash_clmulni_intel,aesni_intel
glue_helper 16384 1 aesni_intel
serio_raw 16384 0
ehci_pci 16384 0
ehci_hcd 86016 1 ehci_pci
xhci_pci 16384 0
xhci_hcd 167936 1 xhci_pci
hid_rmi 20480 0
rmi_core 77824 1 hid_rmi
videobuf2_vmalloc 16384 2 rmi_core,uvcvideo
videobuf2_memops 16384 1 videobuf2_vmalloc
videobuf2_v4l2 24576 2 rmi_core,uvcvideo
videobuf2_core 36864 3 rmi_core,videobuf2_v4l2,uvcvideo
videodev 155648 4 videobuf2_core,rmi_core,videobuf2_v4l2,uvcvideo
media 32768 2 videodev,uvcvideo
amdkfd 122880 1
amd_iommu_v2 20480 1 amdkfd
i2c_hid 24576 0
amdgpu 2007040 3
i2c_algo_bit 16384 1 amdgpu
drm_kms_helper 147456 1 amdgpu
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
fb_sys_fops 16384 1 drm_kms_helper
ttm 94208 1 amdgpu
drm 356352 5 drm_kms_helper,amdgpu,ttm
agpgart 36864 2 ttm,drm

Post Reply