System-D Failure with Upgrade [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
VolvoBirkenstock
Advanced Hen
Posts: 206
Joined: Sun Mar 31, 2013 5:34

System-D Failure with Upgrade [Solved]

Post by VolvoBirkenstock » Sun Jan 20, 2019 5:06

Hello, Sabayon Gurus.

I upgraded my systems today via sabayon-weekly. I have upgraded a desktop and a laptop. The desktop runs 4.9. The laptop runs 4.18. Once the upgrades were complete, I rebooted both systems. The laptop booted fine. The desktop ran into problems typical of the description given in viewtopic.php?f=86&t=34902.

Given the dialog provided to stdout/stderr during boot, I assumed the issue might be an upgrade to systemd. I then observed that systemd-239-r3 was newly installed. (Understand that I previously masked =sys-apps/systemd-239-r2 to return functionality to systemd-233-r3.)

In order to correct the current issue, I performed the following using a previously saved-off patch for systemd-233-r3:

Code: Select all

su 
equo install sys-apps:systemd-233-r3.<funkyAlphaNumeric>~0.tbz2
equo mask "=sys-apps/systemd-239-r3"
exit 
I then rebooted the system and was no longer met with the need to perform "Control-D" to progress through bootup.

I thought you would want to be aware of this issue.

Thank you very much.

Post Reply