Trouble launching Plex Media Server

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
fieldstone
Baby Hen
Posts: 9
Joined: Wed Nov 07, 2007 18:37

Trouble launching Plex Media Server

Post by fieldstone » Mon May 28, 2018 4:17

I was able to install the package media-tv/plex-media-server using equo.

however, when I try to run it (sudo rc-config start plex-media-server), I get the following error message:

/usr/share/eselect/modules/rc.eselect: /etc/init.d/plex-media-server: /sbin/openrc-run: bad interpreter: No such file or directory

I'm pretty new to Sabayon from Mint / Ubuntu / Debian. I have no idea how to fix this error message, even after doing a little research. Can anyone point me in the right direction?

Stupot
Sagely Hen
Posts: 1680
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Trouble launching Plex Media Server

Post by Stupot » Tue May 29, 2018 0:57

I can help point you in the right direction. Sabayon uses systemd, not openrc. They are both init systems. It looks like the plex package is perhaps expecting openrc?

Also, where di you get the package from? I don't see it in the official repos.

fieldstone
Baby Hen
Posts: 9
Joined: Wed Nov 07, 2007 18:37

Re: Trouble launching Plex Media Server

Post by fieldstone » Wed May 30, 2018 4:48

The package came from the community repo. The page for it appears to be https://packages.gentoo.org/packages/me ... dia-server

Stupot
Sagely Hen
Posts: 1680
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Trouble launching Plex Media Server

Post by Stupot » Wed May 30, 2018 5:39

That isn't an entropy community repo, that's a portage overlay (same sort of concept, but for portage).

However, from the looks of things, the package has both openrc support and systemd support, you're just trying to use the wrong one.

Try the systemd way (as root):

Code: Select all

# systemctl start plexmediaserver
To have it start up at boot:

Code: Select all

# systemctl enable plexmediaserver

hydran
Baby Hen
Posts: 10
Joined: Sat Sep 01, 2018 4:50

Re: Trouble launching Plex Media Server

Post by hydran » Sat Sep 01, 2018 5:02

I can't launch either. It seems to install but when I try to run it from the menu I get an error saying "Could not find the program 'x-www-browser'".

I was trying to troubleshoot and came across trying ldd /usr/lib/plexmediaserver/'Plex Media Server'
Got this list of fun things I don't know anything about:

linux-vdso.so.1 (0x00007ffef59d4000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f844c82e000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f844c60d000)
libboost_atomic.so.1.59.0 => not found
libboost_system.so.1.59.0 => not found
libboost_thread.so.1.59.0 => not found
libboost_timer.so.1.59.0 => not found
libboost_program_options.so.1.59.0 => not found
libboost_locale.so.1.59.0 => not found
libboost_iostreams.so.1.59.0 => not found
libboost_filesystem.so.1.59.0 => not found
libboost_date_time.so.1.59.0 => not found
libboost_regex.so.1.59.0 => not found
libboost_chrono.so.1.59.0 => not found
libboost_random.so.1.59.0 => not found
libz.so.1 => /lib64/libz.so.1 (0x00007f844c3f4000)
libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f844c069000)
libsqlite3.so.0 => /usr/lib64/libsqlite3.so.0 (0x00007f844bd31000)
libcurl.so.4 => /usr/lib64/libcurl.so.4 (0x00007f844baa9000)
libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0 (0x00007f844b82b000)
libfreeimage.so => not found
libsoci_core.so.3.0.0 => not found
libsoci_sqlite3.so.3.0.0 => not found
libpython2.7.so.1.0 => /usr/lib64/libpython2.7.so.1.0 (0x00007f844b423000)
libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0 (0x00007f844afa5000)
libavformat.so.58 => not found
libavcodec.so.58 => not found
libavutil.so.56 => not found
libswscale.so.5 => not found
libswresample.so.3 => not found
libva.so.2 => /usr/lib64/libva.so.2 (0x00007f844ad80000)
libva-drm.so.2 => /usr/lib64/libva-drm.so.2 (0x00007f844ab7d000)
libiconv.so.2 => not found
libjemalloc.so.1 => not found
libminizip.so.1 => /usr/lib64/libminizip.so.1 (0x00007f844a970000)
libminiupnpc.so.10 => not found
libnatpmp.so.1 => not found
libtag.so.1 => /usr/lib64/libtag.so.1 (0x00007f844a65c000)
libopencv_imgproc.so.2.4 => not found
libopencv_core.so.2.4 => not found
liblrc.so.0 => not found
libgnsdk_correlates.so.3.07.7 => not found
libgnsdk_dsp.so.3.07.7 => not found
libgnsdk_fp.so.3.07.7 => not found
libgnsdk_link.so.3.07.7 => not found
libgnsdk_lookup_local.so.3.07.7 => not found
libgnsdk_lookup_localstream.so.3.07.7 => not found
libgnsdk_manager.so.3.07.7 => not found
libgnsdk_moodgrid.so.3.07.7 => not found
libgnsdk_musicid.so.3.07.7 => not found
libgnsdk_musicid_file.so.3.07.7 => not found
libgnsdk_musicid_match.so.3.07.7 => not found
libgnsdk_musicid_stream.so.3.07.7 => not found
libgnsdk_playlist.so.3.07.7 => not found
libgnsdk_rhythm.so.3.07.7 => not found
libgnsdk_storage_sqlite.so.3.07.7 => not found
libgnsdk_submit.so.3.07.7 => not found
libgnsdk_tocgen.so.3.07.7 => not found
libgnsdk_video.so.3.07.7 => not found
libm.so.6 => /lib64/libm.so.6 (0x00007f844a308000)
libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/libgcc_s.so.1 (0x00007f844a0f1000)
libc.so.6 => /lib64/libc.so.6 (0x00007f8449d1c000)
/lib64/ld-linux-x86-64.so.2 (0x00007f844ca32000)
libicuuc.so.60 => /usr/lib64/libicuuc.so.60 (0x00007f844993b000)
libnghttp2.so.14 => /usr/lib64/libnghttp2.so.14 (0x00007f844970e000)
libidn2.so.0 => /usr/lib64/libidn2.so.0 (0x00007f84494f0000)
libgssapi_krb5.so.2 => /usr/lib64/libgssapi_krb5.so.2 (0x00007f84492a0000)
libkrb5.so.3 => /usr/lib64/libkrb5.so.3 (0x00007f8448fb1000)
libk5crypto.so.3 => /usr/lib64/libk5crypto.so.3 (0x00007f8448d7b000)
libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007f8448b77000)
libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2 (0x00007f8448925000)
liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2 (0x00007f8448714000)
libutil.so.1 => /lib64/libutil.so.1 (0x00007f8448511000)
libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f84482fd000)
libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/libstdc++.so.6 (0x00007f8447ecd000)
libicudata.so.60 => /usr/lib64/libicudata.so.60 (0x00007f8446324000)
libunistring.so.2 => /usr/lib64/libunistring.so.2 (0x00007f8445f9d000)
libkrb5support.so.0 => /usr/lib64/libkrb5support.so.0 (0x00007f8445d8f000)
libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007f8445b8a000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f8445972000)
libsasl2.so.3 => /usr/lib64/libsasl2.so.3 (0x00007f8445752000)
libgnutls.so.30 => /usr/lib64/libgnutls.so.30 (0x00007f84453de000)
libtasn1.so.6 => /usr/lib64/libtasn1.so.6 (0x00007f84451ca000)
libnettle.so.6 => /usr/lib64/libnettle.so.6 (0x00007f8444f8b000)
libhogweed.so.4 => /usr/lib64/libhogweed.so.4 (0x00007f8444d51000)
libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007f8444acd000)

Help?

I mean it looks like I'm missing libgnsdk libav* libboost etc. Where do I get these? Why would they not be installed as dependencies when I installed Plex? Why would it not just fail to install without them?

hydran
Baby Hen
Posts: 10
Joined: Sat Sep 01, 2018 4:50

Re: Trouble launching Plex Media Server

Post by hydran » Fri Sep 21, 2018 3:08

Yeah I had trouble getting it to run. Finally had success. Install with rigo, make sure you have all the needed dependencies, etc etc. Im too new to tell you how to get it running at boot but you can get it going by hand from your desktop at least. Right click on your desktop (I am kinda making the assumption you are using KDE here) and select "create new" and then "link to application". Call it something like Start Plex Server. Click on the Application tab, and browse to /usr/sbin/start_pms fill in the description, name or other fields if you feel like it. Not necessary though. Don't worry about the work path thing. Click ok.

Now click on that. Okay. Seems like nothing has happened but the plex server is running. Now open Chrome. In the search\navigation bar where you type www dot whatever dot com (Im sure you're smart enough, Im just trying to make it really really clear for anyone who finds this, I am sincerely not trying to talk down to you) enter http://localhost:32400/web

This should get you going.

User avatar
sabayonino
Sagely Hen
Posts: 3279
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Trouble launching Plex Media Server

Post by sabayonino » Fri Sep 21, 2018 18:55

some output during install can help you :

Code: Select all

 Adding group 'plex' to your system ...
 *  - Groupid: next available
 * Adding user 'plex' to your system ...
 *  - Userid: 137
 *  - Shell: /bin/bash
 *  - Home: /var/lib/plexmediaserver
 *  - Groups: plex,video
 *  - GECOS: added by portage for plex-media-server
 *  - Creating /var/lib/plexmediaserver in /

add you user to the plex group

Code: Select all

# gpasswd -a <youruser> plex
then connect to
http://localhost:32400/web
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

Post Reply