Trouble launching Plex Media Server

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
fieldstone
Baby Hen
Posts: 9
Joined: Wed Nov 07, 2007 18:37

Trouble launching Plex Media Server

Post by fieldstone » Mon May 28, 2018 4:17

I was able to install the package media-tv/plex-media-server using equo.

however, when I try to run it (sudo rc-config start plex-media-server), I get the following error message:

/usr/share/eselect/modules/rc.eselect: /etc/init.d/plex-media-server: /sbin/openrc-run: bad interpreter: No such file or directory

I'm pretty new to Sabayon from Mint / Ubuntu / Debian. I have no idea how to fix this error message, even after doing a little research. Can anyone point me in the right direction?

Stupot
Sagely Hen
Posts: 1664
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Trouble launching Plex Media Server

Post by Stupot » Tue May 29, 2018 0:57

I can help point you in the right direction. Sabayon uses systemd, not openrc. They are both init systems. It looks like the plex package is perhaps expecting openrc?

Also, where di you get the package from? I don't see it in the official repos.

fieldstone
Baby Hen
Posts: 9
Joined: Wed Nov 07, 2007 18:37

Re: Trouble launching Plex Media Server

Post by fieldstone » Wed May 30, 2018 4:48

The package came from the community repo. The page for it appears to be https://packages.gentoo.org/packages/me ... dia-server

Stupot
Sagely Hen
Posts: 1664
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Trouble launching Plex Media Server

Post by Stupot » Wed May 30, 2018 5:39

That isn't an entropy community repo, that's a portage overlay (same sort of concept, but for portage).

However, from the looks of things, the package has both openrc support and systemd support, you're just trying to use the wrong one.

Try the systemd way (as root):

Code: Select all

# systemctl start plexmediaserver
To have it start up at boot:

Code: Select all

# systemctl enable plexmediaserver

Post Reply