Systemd 233: could not boot

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
Super Rabbit
Baby Hen
Posts: 2
Joined: Tue Jan 30, 2018 22:04

Systemd 233: could not boot

Post by Super Rabbit » Tue Jan 30, 2018 23:07

Hi!

I run Sabayon since more than a year and it's surprisingly the stablest OS that has ever been between my hands.

But now I'm stucked. The story:

I was with Linux 4.9. Thursday 25th I decided to move to 4.14.
Shutdown.
Friday 26th, update of systemd. Oups cannot shutdown/halt/sleep/hibernate (exactly like this thread: thread).
Hard shutdown...

Then I tried to boot, but with all my kernel (the original 4.8 installed, the 4.9, the new 4.14) I have the following message when I use the recovery mode. In normal mode the logo loads, then nothing happens, no prompt for my luks partition (my /home/user in on a separate encrypted partition).

With the 4.14 kernel I have:
[some "ACPI Error" that have always been there]
starting version 233
Could not get boot entry.
** No iSCSI initiator found
Warning: Failed to connect to lvmetad. Falling back to device scanning.
[ 6.******] cgroup: cgroup2: unknown option "nsdelegate"
[ 7.******] systemd[1]: Configuration file /lib/systemd/system/remote-fs.target is marked world-inaccessible. This has no effect as configuration data is accessible via APIs without restrictions. Proceeding anyway.
[ 8.******] vboxdrv: loading out-of-tree module taints kernel
[ 8.******] VBoxNetFlt: Successfully started.
[ 8.******] VBoxNetAdp: Successfully started.
[ 8.******] VBoxPciLinuxInit
[ 13.******] ACPI Warning: SystemIO range 0x000...urglll conflicts with OpRegion 0x000...urglll
...
[ 13.******] lpc_ich: Resource conflict(s) found affecting gpio_ich
With the 4.9 kernel I have:
[some "ACPI Error" that have always been there]
starting version 233
Could not get boot entry.
** No iSCSI initiator found
Warning: Failed to connect to lvmetad. Falling back to device scanning.
[ 6.******] cgroup: cgroup2: unknown option "nsdelegate"
[ 7.******] systemd[1]: Configuration file /lib/systemd/system/remote-fs.target is marked world-inaccessible. This has no effect as configuration data is accessible via APIs without restrictions. Proceeding anyway.
[ 7.******] systemd[1]: File /lib/systemd/system/systemd-journald.service:35 configures an IP firewall (IPAddressDeny=any), but the local system does not support BPF/cgroup based firewalling.
[ 7.******] systemd[1]: Proceeding WITHOUT firewalling in effect! (This warning is only shown for the forst loaded unit using IP firewalling.)
[ 8.******] vboxdrv: loading out-of-tree module taints kernel
[ 8.******] VBoxNetFlt: Successfully started.
[ 8.******] VBoxNetAdp: Successfully started.
[ 8.******] VBoxPciLinuxInit
With the 4.8 Linux:
Could not get boot entry.
** No iSCSI initiator found
Warning: Failed to connect to lvmetad. Falling back to device scanning.
[ 6.******] cgroup: cgroup2: unknown option "nsdelegate"
[ 7.******] systemd[1]: Configuration file /lib/systemd/system/remote-fs.target is marked world-inaccessible. This has no effect as configuration data is accessible via APIs without restrictions. Proceeding anyway.
[ 7.******] systemd[1]: File /lib/systemd/system/systemd-journald.service:35 configures an IP firewall (IPAddressDeny=any), but the local system does not support BPF/cgroup based firewalling.
[ 7.******] systemd[1]: Proceeding WITHOUT firewalling in effect! (This warning is only shown for the forst loaded unit using IP firewalling.)
Nothing on the web could help me :|

As I can't get any shell I'm a bit stucked, chrooting or a full reinstallation is approaching :pirat:

Thanks for your help! If you need further infos ask me...

joost
Sagely Hen
Posts: 2704
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Systemd 233: could not boot

Post by joost » Tue Jan 30, 2018 23:36

Hi there, thanks for your feedback on this issue!

We could perhaps try downgrade to previous systemd version that is still stored on the mirrors:

Code: Select all

wget http://mirror.de.sabayon.org/entropy/standard/sabayonlinux.org/packages/amd64/5/sys-apps/sys-apps:systemd-233-r3.825b608769af766d72733b9f684072bc67da2c61~1.tbz2
then:

Code: Select all

equo install sys-apps\:systemd-233-r3.825b608769af766d72733b9f684072bc67da2c61~1.tbz2
Even though I never ran into any issues myself, we might wanna test and see if the problem is systemd.

edit: (I just tested this procedure and I had to hard power down my PC because it wouldn't let me reboot in the normal way, but after this my system booted up fine).
Image
My blog | Twitter | Please support Sabayon: Image

Super Rabbit
Baby Hen
Posts: 2
Joined: Tue Jan 30, 2018 22:04

Re: Systemd 233: could not boot

Post by Super Rabbit » Wed Jan 31, 2018 0:08

Well, I've followed the instruction to chroot here, then yours, then equo is speaking alone:

Code: Select all

(chroot) sabayon / # equo install sys-apps\:systemd-233-r3.825b608769af766d72733b9f684072bc67da2c61~1.tbz2
☛ 
☛ Entropy is running off a Live System
☛ Performance and stability could get severely compromised
☛ 
╠  @@ Calcul des dépendances...
╠  ## [D] [sabayon-weekly->sys-apps:systemd-233-r3.825b608769af766d72733b9f684072bc67da2c61~1.tbz2] sys-apps/systemd-233-r3|1   [236-r5|0]
╠  @@ Paquets qui ont besoin d'être installés/mis à jour/rétrogradés: 1
╠  @@ Paquets qui ont besoin d'être supprimés: 0
╠  @@ Taille du téléchargement: 5.8MB
╠  @@ Espace disque libéré: 2.1MB
╠  @@ Vous avez besoin d'au moins: 9.4MB d'espace libre
╠  ::: >>>  (1/1) 1 paquet
╠  +++ >>>  (1/1) sys-apps/systemd-233-r3
╠    ## Dépaquettage: sys-apps:systemd-233-r3.825b608769af766d72733b9f684072bc67da2c61~1.tbz2
╠    ## Package phase: setup
openpty failed: 'out of pty devices'
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     4.14.0-sabayon
 * Checking for suitable kernel configuration options...
 *   CONFIG_CHECKPOINT_RESTORE:  is not set when it should be.
 *   CONFIG_FW_LOADER_USER_HELPER:       should not be set. But it is.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
╠    ## Installation du paquet: sys-apps/systemd-233-r3
╠    ## [System and service manager for Linux]
☛    ## Cannot protect broken symlink:
☛    ## /etc/sysctl.d/99-sysctl.conf
☛    ## Protection du fichier de configuration: /etc/systemd/system.conf
╠    ## Fusion automatique du fichier de configuration, jamais modifié: /etc/systemd/system.conf
☛    ## Protection du fichier de configuration: /etc/systemd/journald.conf
╠    ## Fusion automatique du fichier de configuration, jamais modifié: /etc/systemd/journald.conf
☛    ## Protection du fichier de configuration: /etc/systemd/resolved.conf
╠    ## Fusion automatique du fichier de configuration, jamais modifié: /etc/systemd/resolved.conf
☛    ## Protection du fichier de configuration: /etc/systemd/timesyncd.conf
╠    ## Fusion automatique du fichier de configuration, jamais modifié: /etc/systemd/timesyncd.conf
☛    ## Cannot protect broken symlink:
☛    ## /etc/systemd/system/multi-user.target.wants/remote-fs.target
☛    ## Cannot protect broken symlink:
☛    ## /etc/systemd/system/multi-user.target.wants/machines.target
☛    ## Cannot protect broken symlink:
☛    ## /etc/systemd/system/getty.target.wants/[email protected]
╠    ## Updating installed packages repository: sys-apps/systemd-233-r3
╠    ## Package phase: preremove
╠    ## Nettoyage des données d'application préalablement installées.
☛    ## Protecting: /lib64/libudev.so.1.6.8, library needed by:
☛    :: kde-frameworks/kdelibs-4.14.37
☛    :: x11-drivers/xf86-video-amdgpu-1.4.0
☛    :: media-libs/libv4l-1.12.5
☛    :: x11-drivers/xf86-input-evdev-2.10.5
☛    :: x11-drivers/xf86-video-openchrome-0.6.0
☛    :: x11-drivers/xf86-input-wacom-0.35.0
☛    :: media-sound/pulseaudio-11.1
☛    :: x11-drivers/xf86-input-vmmouse-13.1.0-r1
☛    :: net-misc/ofono-1.20
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: net-wireless/bluez-5.47-r1
☛    :: sys-cluster/ceph-10.2.7-r1
☛    :: media-libs/clutter-1.26.2
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: sys-apps/pciutils-3.5.5
☛    :: media-libs/libcanberra-0.30-r5
☛    :: sys-fs/dosfstools-4.1
☛    :: gnome-base/gnome-desktop-3.24.2
☛    :: kde-plasma/kwin-5.11.5
☛    :: kde-plasma/powerdevil-5.11.5
☛    :: sys-apps/usbutils-008-r1
☛    :: sys-fs/lvm2-2.02.166-r2
☛    :: dev-libs/libgudev-232
☛    :: net-wireless/gnome-bluetooth-3.20.1
☛    :: media-video/vlc-2.2.8-r1
☛    :: sys-apps/util-linux-2.30.2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-libs/libatasmart-0.19-r2
☛    :: x11-drivers/xf86-video-intel-2.99.917_p20171018
☛    :: app-admin/system-config-printer-1.4.8
☛    :: x11-drivers/xf86-video-nouveau-1.0.15
☛    :: dev-libs/libinput-1.7.3
☛    :: kde-frameworks/solid-5.42.0
☛    :: sys-apps/pcsc-lite-1.8.22
☛    :: dev-libs/libusb-1.0.21
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-libs/libblockdev-0.13
☛    :: sys-fs/udisks-1.0.5-r2
☛    :: x11-drivers/xf86-video-qxl-0.1.5
☛    :: sys-fs/zfs-0.7.5
☛    :: dev-qt/qtgui-5.9.3
☛    ## Protecting: /lib64/libudev.so.1, library needed by:
☛    :: kde-frameworks/kdelibs-4.14.37
☛    :: x11-drivers/xf86-video-amdgpu-1.4.0
☛    :: media-libs/libv4l-1.12.5
☛    :: x11-drivers/xf86-input-evdev-2.10.5
☛    :: x11-drivers/xf86-video-openchrome-0.6.0
☛    :: x11-drivers/xf86-input-wacom-0.35.0
☛    :: media-sound/pulseaudio-11.1
☛    :: x11-drivers/xf86-input-vmmouse-13.1.0-r1
☛    :: net-misc/ofono-1.20
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: net-wireless/bluez-5.47-r1
☛    :: sys-cluster/ceph-10.2.7-r1
☛    :: media-libs/clutter-1.26.2
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: sys-apps/pciutils-3.5.5
☛    :: media-libs/libcanberra-0.30-r5
☛    :: sys-fs/dosfstools-4.1
☛    :: gnome-base/gnome-desktop-3.24.2
☛    :: kde-plasma/kwin-5.11.5
☛    :: kde-plasma/powerdevil-5.11.5
☛    :: sys-apps/usbutils-008-r1
☛    :: sys-fs/lvm2-2.02.166-r2
☛    :: dev-libs/libgudev-232
☛    :: net-wireless/gnome-bluetooth-3.20.1
☛    :: media-video/vlc-2.2.8-r1
☛    :: sys-apps/util-linux-2.30.2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-libs/libatasmart-0.19-r2
☛    :: x11-drivers/xf86-video-intel-2.99.917_p20171018
☛    :: app-admin/system-config-printer-1.4.8
☛    :: x11-drivers/xf86-video-nouveau-1.0.15
☛    :: dev-libs/libinput-1.7.3
☛    :: kde-frameworks/solid-5.42.0
☛    :: sys-apps/pcsc-lite-1.8.22
☛    :: dev-libs/libusb-1.0.21
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-libs/libblockdev-0.13
☛    :: sys-fs/udisks-1.0.5-r2
☛    :: x11-drivers/xf86-video-qxl-0.1.5
☛    :: sys-fs/zfs-0.7.5
☛    :: dev-qt/qtgui-5.9.3
☛    ## Protecting: /lib64/libudev.so, library needed by:
☛    :: kde-frameworks/kdelibs-4.14.37
☛    :: x11-drivers/xf86-video-amdgpu-1.4.0
☛    :: media-libs/libv4l-1.12.5
☛    :: x11-drivers/xf86-input-evdev-2.10.5
☛    :: x11-drivers/xf86-video-openchrome-0.6.0
☛    :: x11-drivers/xf86-input-wacom-0.35.0
☛    :: media-sound/pulseaudio-11.1
☛    :: x11-drivers/xf86-input-vmmouse-13.1.0-r1
☛    :: net-misc/ofono-1.20
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: net-wireless/bluez-5.47-r1
☛    :: sys-cluster/ceph-10.2.7-r1
☛    :: media-libs/clutter-1.26.2
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: sys-apps/pciutils-3.5.5
☛    :: media-libs/libcanberra-0.30-r5
☛    :: sys-fs/dosfstools-4.1
☛    :: gnome-base/gnome-desktop-3.24.2
☛    :: kde-plasma/kwin-5.11.5
☛    :: kde-plasma/powerdevil-5.11.5
☛    :: sys-apps/usbutils-008-r1
☛    :: sys-fs/lvm2-2.02.166-r2
☛    :: dev-libs/libgudev-232
☛    :: net-wireless/gnome-bluetooth-3.20.1
☛    :: media-video/vlc-2.2.8-r1
☛    :: sys-apps/util-linux-2.30.2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-libs/libatasmart-0.19-r2
☛    :: x11-drivers/xf86-video-intel-2.99.917_p20171018
☛    :: app-admin/system-config-printer-1.4.8
☛    :: x11-drivers/xf86-video-nouveau-1.0.15
☛    :: dev-libs/libinput-1.7.3
☛    :: kde-frameworks/solid-5.42.0
☛    :: sys-apps/pcsc-lite-1.8.22
☛    :: dev-libs/libusb-1.0.21
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-libs/libblockdev-0.13
☛    :: sys-fs/udisks-1.0.5-r2
☛    :: x11-drivers/xf86-video-qxl-0.1.5
☛    :: sys-fs/zfs-0.7.5
☛    :: dev-qt/qtgui-5.9.3
☛    ## Protecting: /lib64/libsystemd.so.0.20.0, library needed by:
☛    :: sys-auth/realmd-0.16.2
☛    :: kde-apps/ksystemlog-17.12.1
☛    :: sys-auth/polkit-0.113-r4
☛    :: app-emulation/spice-vdagent-0.17.0
☛    :: sys-fs/udisks-2.1.8
☛    :: sys-apps/dbus-1.10.24
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: x11-misc/sddm-0.17.0
☛    :: net-vpn/openvpn-2.4.4
☛    :: media-gfx/sane-backends-1.0.27
☛    :: dev-db/mariadb-10.2.12
☛    :: media-sound/pulseaudio-11.1
☛    :: sys-apps/util-linux-2.30.2
☛    :: net-print/cups-2.2.4
☛    :: net-fs/samba-4.5.15
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: net-vpn/tor-0.3.2.9
☛    :: dev-lang/erlang-19.3
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-process/procps-3.3.12-r1
☛    :: app-admin/packagekit-base-1.1.5-r2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-qt/qtcore-5.9.3
☛    :: sys-apps/accountsservice-0.6.45
☛    ## Protecting: /lib64/libsystemd.so.0, library needed by:
☛    :: sys-auth/realmd-0.16.2
☛    :: kde-apps/ksystemlog-17.12.1
☛    :: sys-auth/polkit-0.113-r4
☛    :: app-emulation/spice-vdagent-0.17.0
☛    :: sys-fs/udisks-2.1.8
☛    :: sys-apps/dbus-1.10.24
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: x11-misc/sddm-0.17.0
☛    :: net-vpn/openvpn-2.4.4
☛    :: media-gfx/sane-backends-1.0.27
☛    :: dev-db/mariadb-10.2.12
☛    :: media-sound/pulseaudio-11.1
☛    :: sys-apps/util-linux-2.30.2
☛    :: net-print/cups-2.2.4
☛    :: net-fs/samba-4.5.15
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: net-vpn/tor-0.3.2.9
☛    :: dev-lang/erlang-19.3
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-process/procps-3.3.12-r1
☛    :: app-admin/packagekit-base-1.1.5-r2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-qt/qtcore-5.9.3
☛    :: sys-apps/accountsservice-0.6.45
☛    ## Protecting: /lib64/libsystemd.so, library needed by:
☛    :: sys-auth/realmd-0.16.2
☛    :: kde-apps/ksystemlog-17.12.1
☛    :: sys-auth/polkit-0.113-r4
☛    :: app-emulation/spice-vdagent-0.17.0
☛    :: sys-fs/udisks-2.1.8
☛    :: sys-apps/dbus-1.10.24
☛    :: sys-fs/multipath-tools-0.5.0-r99
☛    :: x11-misc/sddm-0.17.0
☛    :: net-vpn/openvpn-2.4.4
☛    :: media-gfx/sane-backends-1.0.27
☛    :: dev-db/mariadb-10.2.12
☛    :: media-sound/pulseaudio-11.1
☛    :: sys-apps/util-linux-2.30.2
☛    :: net-print/cups-2.2.4
☛    :: net-fs/samba-4.5.15
☛    :: gnome-base/gvfs-1.32.1-r1
☛    :: net-vpn/tor-0.3.2.9
☛    :: dev-lang/erlang-19.3
☛    :: net-misc/networkmanager-1.8.4
☛    :: sys-process/procps-3.3.12-r1
☛    :: app-admin/packagekit-base-1.1.5-r2
☛    :: x11-base/xorg-server-1.19.5
☛    :: dev-qt/qtcore-5.9.3
☛    :: sys-apps/accountsservice-0.6.45
☛    ## Protecting: /lib32/libudev.so.1.6.8, library needed by:
☛    :: net-misc/networkmanager-1.8.4
☛    :: media-libs/libv4l-1.12.5
☛    :: dev-libs/libgudev-232
☛    :: dev-libs/libusb-1.0.21
☛    :: sys-apps/pciutils-3.5.5
☛    ## Protecting: /lib32/libudev.so.1, library needed by:
☛    :: net-misc/networkmanager-1.8.4
☛    :: media-libs/libv4l-1.12.5
☛    :: dev-libs/libgudev-232
☛    :: dev-libs/libusb-1.0.21
☛    :: sys-apps/pciutils-3.5.5
☛    ## Protecting: /lib32/libudev.so, library needed by:
☛    :: net-misc/networkmanager-1.8.4
☛    :: media-libs/libv4l-1.12.5
☛    :: dev-libs/libgudev-232
☛    :: dev-libs/libusb-1.0.21
☛    :: sys-apps/pciutils-3.5.5
☛    ## Protecting: /lib32/libsystemd.so.0.20.0, library needed by:
☛    :: media-sound/pulseaudio-11.1
☛    ## Protecting: /lib32/libsystemd.so.0, library needed by:
☛    :: media-sound/pulseaudio-11.1
☛    ## Protecting: /lib32/libsystemd.so, library needed by:
☛    :: media-sound/pulseaudio-11.1
☛    :: Removing library: /lib64/libudev.so.1.6.8 [libudev.so.1, 2]
☛    :: Removing library: /lib64/libudev.so.1 [libudev.so.1, 2]
☛    :: Removing library: /lib64/libudev.so [libudev.so.1, 2]
☛    :: Removing library: /lib64/libsystemd.so.0.20.0 [libsystemd.so.0, 2]
☛    :: Removing library: /lib64/libsystemd.so.0 [libsystemd.so.0, 2]
☛    :: Removing library: /lib64/libsystemd.so [libsystemd.so.0, 2]
☛    :: Removing library: /lib32/libudev.so.1.6.8 [libudev.so.1, 1]
☛    :: Removing library: /lib32/libudev.so.1 [libudev.so.1, 1]
☛    :: Removing library: /lib32/libudev.so [libudev.so.1, 1]
☛    :: Removing library: /lib32/libsystemd.so.0.20.0 [libsystemd.so.0, 1]
☛    :: Removing library: /lib32/libsystemd.so.0 [libsystemd.so.0, 1]
☛    :: Removing library: /lib32/libsystemd.so [libsystemd.so.0, 1]
>>> Regenerating /etc/ld.so.cache...
>>> Regenerating /etc/ld.so.cache...
╠    ## Package phase: postinstall
 * Updating systemd journal catalogs ...                                                                                                                                                                                                                                [ ok ]
 * Running udev control --reload for reloading rules and databases ...                                                                                                                                                                                                  [ ok ]
╠    ## Nettoyage: sys-apps/systemd-233-r3
╠  @@ Installation terminée.
╠  @@ No configuration files to update.
Reboot ... and everything is now fine!

Thanks! :D :D

joost
Sagely Hen
Posts: 2704
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Systemd 233: could not boot

Post by joost » Wed Jan 31, 2018 0:12

Thank you very much for confirming this. :D

Sadly we are in a complex repository migration where we are moving to a new gcc version and I can't push anything to weekly repository. I will discuss this issue with the team.

I just wanna state that myself didn't run into any issues on my test systems, but as we can see now, that doesn't mean a thing.
Image
My blog | Twitter | Please support Sabayon: Image

joost
Sagely Hen
Posts: 2704
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: Systemd 233: could not boot

Post by joost » Sat Feb 03, 2018 21:33

For the record. We've downgraded systemd to last known working version. All is pushed into weekly repo.
Image
My blog | Twitter | Please support Sabayon: Image

Post Reply