Youtubevideo [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
illalien
Young Hen
Posts: 23
Joined: Wed Mar 12, 2014 20:10

Youtubevideo [Solved]

Post by illalien » Tue Aug 02, 2016 9:09

Once Plasma 5 was looking stable I decided to reinstall everything, ie Sabayon KDE.
I keep It fully updated, kernel 4.6.4.

I only have two issues, and btw, that is amazing.

One isn't very important, the bottom bar changes color and transparency randomly on reboot, I'm using standard Oxygen, but it feels unstable.
On the other hand, I've been using KDE as my main desktop since the late 90's so I have seen that behaviour before...

The other problem is more of an actual problem.
I used to be a firefox user, but chrome was preinstalled and I gave it a shot, fast, works, so OK then, I'll keep it and use it.

Lately I have noticed that Youtube videos won't load and since the last update it is more or less permanent, it loads half the page and I can see thumbnails of the video but it won't play.

I tried disabling HTML5 in chrome and it worked, but that means I'm only using flash again.

The quick and dirty solution was to download standard firefox from mozilla.org to try and figure out where the problem is, firefox works without flaws and I'll probably stick to it, it works for me.

However, I wonder, is this a bug affecting the distro, a chrome issue, just my installation or should I simply blame Adobe?
Last edited by illalien on Fri Aug 12, 2016 18:41, edited 3 times in total.

illalien
Young Hen
Posts: 23
Joined: Wed Mar 12, 2014 20:10

Re: Youtubevideo

Post by illalien » Sun Aug 07, 2016 9:34

Latest update
--purge made the wallpaper go black but the bar behaviour remains random, likely an Oxygen issue.
New version of Chrome but the problem remains and it's likely a Chrome problem.
Will mark it solved since I seem to be the only one.

The update also made the whole system sluggish.
Turns out something broke cpuscaling, it's running but not scaling.
My cpu is an old dual core AMD 260 and is suddenly locked to 800MHz, manually setting it to 3,2GHz works.

-My system only?

dave_64
Advanced Hen
Posts: 235
Joined: Sun Feb 22, 2009 20:33

Re: Youtubevideo

Post by dave_64 » Thu Aug 11, 2016 23:09

I'm surprised nobody has commented on this yet, so, maybe it's not an issue, but it's usually better to install 3rd party apps from the package manager than downloading and installing from a website. It might integrate better with kde if you use the package manager. I think English is default, so, from a root terminal, type and enter:
equo install firefox
That will ensure that upgrades of new versions of firefox are upgraded automatically when you run your upgrade procedure.
For other languages, search through the offerings and choose the language you prefer:
equo search firefox

illalien
Young Hen
Posts: 23
Joined: Wed Mar 12, 2014 20:10

Re: Youtubevideo

Post by illalien » Fri Aug 12, 2016 18:38

Since two days youtube videos play fine in Chrome, the problem has been there for months but accelerated lately.
I did search online and I'm not the only one but unfortunately there was no single solution that worked for anyone.
My guess is that this is a problem that should be fixed by youtube and they finally fixed it.

I may be the only one still using the oxygen theme and my guess is that there is a timing issue in the KDE upstart.

No comments is a good answer that way.

However.
The cpufreq problem is probably a real problem and if anyone had replied I would have filed a bugreport on it.
I built my computer eight years ago to run linux, which means it could run windows 10 without any problems and I see no reason to replace something that works fine.
It's a dual core AMD 3.2GHz but it stays on the minimum speed, 800MHz which is something I notice!
Anyone with a new system would probably never notice that their cpu isn't scaling unless they run some benchmark tests.
So, is it my ancient system or a real bug?
No comments on it implies that it is only my system that is affected = no bugreport and [SOLVED].

illalien
Young Hen
Posts: 23
Joined: Wed Mar 12, 2014 20:10

Re: Youtubevideo [Solved]

Post by illalien » Fri Oct 21, 2016 10:52

I marked this as solved a while back and it is still solved since the problem is gone.
What isn't is how it was solved.
-Updates fixed it and now it works flawlessly.

The problem appeared when trying to view a video in a browser, like on youtube, it would load and then stop.

No matter what browser used, or site visited.
Moving the mouse along the bar at the bottom shows a thumbnail view, it would almost be possible to play it there by moving the mouse, annoying.
Downloading the video, be it mp4 or flv, and playing it locally works in any player.

Googling the problem shows that it is quite common, and nobody can recreate it, filing bugs that can't be recreated is pretty hopeless.
There are tips and hints and it's all the things you try first so it's hundreds of pages filled with others having the same problem and suggestions already tried.

More or less by accident I recreated the exact problem and discovered what CAN cause it.

I have a mini mac and I don't really like it but it does what it's supposed to do, except sometimes I like to use it as a computer, which to me means virtualbox and linux.
I had more than one linux guest installed and with a recent virtualbox update I discovered that they had all stopped playing youtube videos, there is really no reason for me to do that...but it's interesting since it's the exact same problem.

I actually installed a Windows guest...and it works whether it's chrome, firefox or ie.

I installed Sabayon linux KDE as a virtualbox guest on my linux Sabayon KDE installation and the problem reappeared in the guest.
No matter what i tried, until I went into the virtualbox settings and removed the sound card.
No sound and all videos play fine, mute of course, but still, playing.
Changing the virtual sound card and rebooting gave me sound and video but no network...
A couple of reboots (and foul words) later with different combinations of virtual hardware the problem was solved.

I remember the old days on Windows 95 when you had to manually reserve IRQ and DMA to be able to use a modem AND sound card at the same time and in linux it had to be done manually.

The question is who owns this bug?
Virtualbox?
I tried several linux distributions and they all have the same problem, doesn't matter if it's chrome, firefox, chromium, html5 or flash.
They can all play downloaded videos but there is obviously something wrong with a plugin, gstreamer?

When I had the problem I didn't even consider the possibility that it could be audio causing a video problem.
Now it's too late, it works and I can't recreate the problem [Solved].

However, a little advice to anyone having the same problem in the future, try disabling the sound card?

Post Reply