FSTAB do not work auto-mounting ntfs partition

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
User avatar
Fox909
Simple Hen
Posts: 57
Joined: Tue Jun 11, 2013 7:16

FSTAB do not work auto-mounting ntfs partition

Post by Fox909 » Sun Jun 05, 2016 16:51

Hello. After up-dating I ceased to work fstab with ntfs partitions. Ext4 - working. For exemple a line of fstab:

LABEL=Data1 /run/media/rigo/Data1 ntfs defaults 0 0

Dolphin by clicking mounts about confirmation of the password. But only if the line in fstab is deleted.
Help me please, before up-dating everything worked.

P.S. KDE Partition Manager didn't work directly.

Yours faithfully, Fox909.
Justice exists, it is just not obvious!

Fitzcarraldo
Sagely Hen
Posts: 8200
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fitzcarraldo » Mon Jun 06, 2016 9:09

If you do not already have it installed, install the package sys-fs/ntfs3g. Change 'ntfs' in your fstab entry to 'ntfs-3g'. That's what I have in fstab on my machines for access to NTFS partitions. For example:

Code: Select all

/dev/sdb1 /media/SEA_DISC ntfs-3g defaults 0 0

Code: Select all

UUID=9884B0A684B08870 /media/SEA_DISC ntfs-3g defaults 0 0

User avatar
Fox909
Simple Hen
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fox909 » Mon Jun 06, 2016 14:16

This pakage is installed :( I try ntfs-3g. I even reinstall Sabayon, now gnome. Not working.

Image
Justice exists, it is just not obvious!

User avatar
Fox909
Simple Hen
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fox909 » Mon Jun 06, 2016 14:28

If mount with nautilus (requested password), all OK. Mount with fstab - parition not open :(
Image
Justice exists, it is just not obvious!

Fitzcarraldo
Sagely Hen
Posts: 8200
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fitzcarraldo » Tue Jun 07, 2016 9:30

Try putting the label in quotes, like so: LABEL="Data1".

User avatar
Fox909
Simple Hen
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fox909 » Wed Jun 08, 2016 16:29

The reasons may not be in it. I've tried it.
Image
These partitions with NTFS (don't work):
UUID=14E4E477E4E45D0C /run/media/gentoo/Torrent1 auto defaults,x-gvfs-show 0 0
LABEL="Data1" /run/media/rigo/Data1 ntfs defaults 0 0

Disk ext4 works:
UUID=43e33700-357b-44aa-84f4-cd86e1faa01d /run/media/gentoo/stemlinux ext4 defaults 0 0

Full text fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
UUID=D58B-55AB /boot/efi vfat defaults,noatime 0 2
UUID=439ea960-aaea-44c8-bbfb-7f8369f1ece4 swap swap defaults,noatime 0 0
UUID=679fd4dd-8c8e-4f2a-ae8f-42e4182b1ede / ext4 defaults,noatime 0 1
UUID=ad3f612b-8e16-4bcf-8c67-bd3431b122e1 /home ext4 defaults,noatime 0 2
UUID=14E4E477E4E45D0C /run/media/gentoo/Torrent1 auto defaults,x-gvfs-show 0 0
UUID=43e33700-357b-44aa-84f4-cd86e1faa01d /run/media/gentoo/stemlinux ext4 defaults 0 0
LABEL="Data1" /run/media/rigo/Data1 ntfs defaults 0 0

I checked, fstab similar works in other systems. In Sabayon this also worked until 16.06. Drives with NTFS can be opened in Nautilus only after deleting a record in FSTAB. I thought that the error is random and installed Sabayon again. With another DE. The problem in Sabayon KDE and GNOME in Sabayon. I don't know what to do :(

P.S. Root access I can get to the mounted disk with the error (sudo mc). Maybe the problem is in rights or groups?
Justice exists, it is just not obvious!

joost
Sagely Hen
Posts: 2752
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: FSTAB do not work auto-mounting ntfs partition

Post by joost » Thu Jun 09, 2016 14:05

Try with ntfs-3g instead of ntfs (as Fitzcarraldo explained):
LABEL="Data1" /run/media/rigo/Data1 ntfs-3g defaults 0 0
My blog | Mastodon | Please support Sabayon: Become a Patron

User avatar
Fox909
Simple Hen
Posts: 57
Joined: Tue Jun 11, 2013 7:16

Re: FSTAB do not work auto-mounting ntfs partition

Post by Fox909 » Thu Jun 09, 2016 16:38

joost wrote:Try with ntfs-3g instead of ntfs (as Fitzcarraldo explained):
LABEL="Data1" /run/media/rigo/Data1 ntfs-3g defaults 0 0
Already tried that. Does not help. The problem is not in fstab, because ext4 is mounted. And not ntfs-3g because manually mounted and ntfs. This problem can be rights, because the root can access the drives mounted with fstab... Probably. I think so...
Justice exists, it is just not obvious!

User avatar
sabayonino
Sagely Hen
Posts: 3395
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: FSTAB do not work auto-mounting ntfs partition

Post by sabayonino » Thu Jun 09, 2016 21:55

Hi

try permissions options insted of defaults

from mount ntfs-3g man page
permissions
Set standard permissions on created files and use standard access control. This option is set by default when a user mapping file is present.

Code: Select all

# mount -o remount /run/media/rigo/Data1
PS : check permissions set for /run/media/rigo/Data1

and

https://wiki.archlinux.org/index.php/NTFS-3G
maybe this can help you.

Post Reply