Black screen blinking cursor (post install)

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Black screen blinking cursor (post install)

Post by gamjaevel » Sun Apr 24, 2016 16:20

Hello everyone, I'm sure you've answered this question a million times but damn.

I recently installed Sabayon again (mate desktop) and when I boot the computer I'm welcomed with a black blinking screen with a white cursor. I read myself to adding nomodeset to boot options to bypass it, which work.

But unfortunately I currently have to boot the computer with the installation disk, and from there add boot option every time.

Could anyone guide me through the process of making the boot option permanent?

Hope it makes sense! thanks in regards

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Black screen blinking cursor (post install)

Post by wolfden » Wed Apr 27, 2016 5:43

to add options to boot line, you need to edit /boot/grub/grub.cfg and look for the line

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT=
than add the needed option to that line

than you will need to do the command

Code: Select all

grub-mkconfig -o /boot/grub/grub.cfg
when you reboot you should be good

btw, you can edit the grub line directly from the boot screen, think it is the b key, push b when grub comes up, course any changes you do will not stick, so do the above, but saves from booting a live disk to change it.

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Re: Black screen blinking cursor (post install)

Post by gamjaevel » Wed Apr 27, 2016 9:37

When i check the grub.cfg I do not find any line with the command GRUB_CMDLINE_LINUX_DEFAULT= ... Can i add it manually?

however i can find this line in /etc/default/grub and currently it looks like this : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Re: Black screen blinking cursor (post install)

Post by gamjaevel » Wed Apr 27, 2016 9:59

also, i tried restarting with these changes, and I was still greeted with a black screen :/

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Black screen blinking cursor (post install)

Post by sabayonino » Wed Apr 27, 2016 10:34

Hi Gam

you missed some info for us

Which Video Card do you have ? ( "nomodeset" set ati drivers for hd5000+ and higher seires)
Which Sabayon Version you' re (trying) running ? (Gnome,Xfce,KDE....)


Try to boot with VESA drivers , edit grub line at boot and pass

Code: Select all

xdriver=vesa
to command line

If "Live" ISO starts , please paste lspci info and drivers loaded

Code: Select all

$ sudo lspci -k
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Re: Black screen blinking cursor (post install)

Post by gamjaevel » Wed Apr 27, 2016 12:21

Hi! I'll try to sneak in a few missing parts then.
I installed the Mate-desktop edition, 16.04.

My graphic card is nVidia GeForce GT520M (according to lspci) and my installed driver is nvidia-drivers-358 (along with it's userspace)

eselect is also set to nvidia.

lspci -k shows
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520M] (rev a1)
Subsystem: Samsung Electronics Co Ltd GF119M [GeForce GT 520M]
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia

I've been using Sabayon from time to time the past 4-5 years and never encountered this problem before (with the same computer ofcourse, with no modified specs)

Note, It start perfectly when i boot with the ISO-disc which I installed from, when i add the nomodeset boot option. But currently I have to redo that step (insert the iso and boot from first harddrive with nomodeset) everytime I reboot the computer.

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Black screen blinking cursor (post install)

Post by sabayonino » Wed Apr 27, 2016 12:38

no need "nomodset" for nvidia cards , only for AMD/ATI cards (HD5000 and +)

skip this.

you can force to pass

Code: Select all

xdriver=nvidia
(don't really need)
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Re: Black screen blinking cursor (post install)

Post by gamjaevel » Wed Apr 27, 2016 12:41

Oh ok. And that line goes in the same line as I currently have nomodeset, i guess?

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Black screen blinking cursor (post install)

Post by sabayonino » Wed Apr 27, 2016 12:46

gamjaevel wrote:Oh ok. And that line goes in the same line as I currently have nomodeset, i guess?
Y'ou're right , but don't mandatory

remove "nomodset" from boot kernel line (at boot) and then from /etc/default/grub and regenerate new grub.cfg

yuo can force to load nvidia drivers with xdriver=nvidia if you want.

[edit] remove ati-drivers (you don't have any ATI cards)
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

gamjaevel
Simple Hen
Posts: 46
Joined: Tue Sep 27, 2011 18:40

Re: Black screen blinking cursor (post install)

Post by gamjaevel » Wed Apr 27, 2016 19:02

Done the above and it's still not working properly... still need the disc to get past the black screen.. this is becoming a riddle :D

I have no idea what differs the disc, from what my current options and settings

Edit: I also read about downgrading my nvidia driver, is that something that could work? Also, is it that simple that i just uninstall my current one, and install an older driver (along with it's userspace)?

Post Reply