Aorus X5, unable to get UI on LiveCD

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Aorus X5, unable to get UI on LiveCD

Post by wolfden » Mon Mar 14, 2016 3:46

are you trying to format the partition or something? I didn't do any of that as I already had it setup.

I've always been a firm believer in - the lesser the installer has to do, the lesser an issue is to rise up. So I generally always do my partitioning with like gparted from a live disk and just point the installer where to put stuff and not to touch it otherwise.

lonesomecrow
Simple Hen
Posts: 60
Joined: Thu Apr 10, 2008 5:16

Re: Aorus X5, unable to get UI on LiveCD

Post by lonesomecrow » Wed Mar 16, 2016 1:58

I had setup the partition before when I installed Ubuntu, no idea as to why it won't work, but like I said, once I have more free time, I will convert the partition to something else and give it a try

lonesomecrow
Simple Hen
Posts: 60
Joined: Thu Apr 10, 2008 5:16

Re: Aorus X5, unable to get UI on LiveCD

Post by lonesomecrow » Thu Mar 17, 2016 4:52

OK so I have spent almost half the day trying to figure this thing out. I was able to use GParted on the Sabayon LiveCD and converted my btrfs partition to ext4. Sabayon installs just fine but when I reboot, my UEFI complains about the signature verification failed and to check the boot policy in the settings. When I disable Secure Boot, I can manage to get past that specific screen, but grub complains about the UUID volume not found. I double checked /boot/grub/grub.cfg and it points to the correct partition. I don't know what I'm missing. I'm also going to mention that I have tried the instrucions on the wiki https://wiki.sabayon.org/?title=HOWTO:_Restore_Grub2 to no avail...

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Aorus X5, unable to get UI on LiveCD

Post by wolfden » Thu Mar 17, 2016 6:10

Is you issue similar to this?
viewtopic.php?f=50&t=32980

I put in what I had to do with efi

lonesomecrow
Simple Hen
Posts: 60
Joined: Thu Apr 10, 2008 5:16

Re: Aorus X5, unable to get UI on LiveCD

Post by lonesomecrow » Sat Mar 19, 2016 5:34

I gotta say that you have been such a good sport, but I'm still struggling to even boot into Sabayon. I tried your method of attempting to fix the EFI bootloader but I'm stuck in the same spot. I'm not able to boot Sabayon with Secure Boot ON or OFF. If Secure Boot is ON, the EFI bootloader complains about the boot policy under setup which I'm assuming has to do with the security certificate to be able to boot. If it's OFF, I get to a screen kinda like a terminal that says it couldn't find the UUID of the disk that was setup for Sabayon.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Aorus X5, unable to get UI on LiveCD

Post by wolfden » Wed Mar 23, 2016 5:21

well bummer, only thing I see on internet that comes close to your situation is on reddit: https://www.reddit.com/r/slackware/comm ... _bootable/

says he flipped it to legacy and it seemed to work

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Aorus X5, unable to get UI on LiveCD

Post by wolfden » Wed Mar 23, 2016 7:09

another thought just hit me, make sure the partition you setup has the boot flag

lonesomecrow
Simple Hen
Posts: 60
Joined: Thu Apr 10, 2008 5:16

Re: Aorus X5, unable to get UI on LiveCD

Post by lonesomecrow » Fri Mar 25, 2016 6:46

Thanks, will give these tips a go once I get some time.

Post Reply