Modules not loading from xen [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Modules not loading from xen [Solved]

Postby notzippy » Fri Oct 23, 2015 23:05

Hi

I am seeing a bunch of failed to find module errors in my boot log for xen,

Code: Select all
Oct 23 13:55:35 sabayon systemd[1]: Failed to insert module 'kdbus': Function not implemented
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Module 'xen_evtchn' is builtin
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to insert 'xen_gntdev': No such device
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to insert 'xen_gntalloc': No such device
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'xen-blkback'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'xen-netback'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to insert 'xen_pciback': No such device
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'evtchn'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'gntdev'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'netbk'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'blkbk'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'xen-scsibk'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'usbbk'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'pciback'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to insert 'xen_acpi_processor': No such device
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'blktap2'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'blktap'
Oct 23 13:55:35 sabayon systemd-modules-load[1771]: Failed to find module 'zfs'



The file in /etc/rc.d/init.d/xencommons is the only place I can find reference to some of those modules,
Code: Select all
BACKEND_MODULES="xen-evtchn xen-gntdev xen-gntalloc xen-blkback xen-netback xen-pciback evtchn gntdev netbk blkbk xen-scsibk usbbk pciback xen-acpi-processor blktap2 blktap"

But that doesnt jive 100% , it says it cannot insert xen_acpi_processor -yet /lib/modules/4.1.0-sabayon/kernel/drivers/xen/xen-acpi-processor.ko exists.

Guess I am also confused as to why XEN is even installed, but attempted removal of it results in removing a load of jdk, jre, jython etc etc.. packages.

Any thoughts on what is missing / or not configured ?

thanks
Nz
Last edited by notzippy on Fri Oct 23, 2015 23:33, edited 1 time in total.
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: Modules not loading from xen

Postby joost » Fri Oct 23, 2015 23:13

My educated guess is because our initramfs is generated on our build-server where these modules do exist.

We are planning to discuss doing this differently in a near future, where initramfs is (re)generated on the client PC.
joost
Sagely Hen
 
Posts: 2660
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Modules not loading from xen

Postby notzippy » Fri Oct 23, 2015 23:32

Ok, so the errors are ok for the time being.. Marking as solved..

thanks
Nz
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: Modules not loading from xen [Solved]

Postby msdobrescu » Sun Oct 08, 2017 13:00

Hi,

Is this still applicable?
I have these also:

Code: Select all
systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2017-10-08 14:56:14 EEST; 3min 32s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 1892 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 1892 (code=exited, status=1/FAILURE)

oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to find module 'blkbk'
oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to find module 'xen-scsibk'
oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to find module 'usbbk'
oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to find module 'pciback'
oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to insert 'xen_acpi_processor': No such device
oct 08 14:56:14 sabayon systemd-modules-load[1892]: Failed to find module 'blktap2'
oct 08 14:56:14 sabayon systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
oct 08 14:56:14 sabayon systemd[1]: Failed to start Load Kernel Modules.
oct 08 14:56:14 sabayon systemd[1]: systemd-modules-load.service: Unit entered failed state.
oct 08 14:56:14 sabayon systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
msdobrescu
Old Dear Hen
 
Posts: 539
Joined: Sun Aug 21, 2011 8:48


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests