problem with geforce GT 740m

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

problem with geforce GT 740m

Postby Multimandala » Mon Aug 25, 2014 17:58

ok.. I have a toshiba p70-a with integrated geforce GT 740m card. It's the first time I have one of those in a computer, it came with it, I am no gamer so never had the need for them. I'm a fairly competent user, spent couple of years playing with ubuntu, terminal fun, etc. I sold my old perfectly fine sabayon-working older i7-36xx computer to a friend then got this new i7-47xx computer with the card, and the fun started.

Right after installing sabayon I had lots of reboots , especially on the chromium & chrome apps, and the virtualbox machine I use for work-related apps only found in windows. I first thought it would be the newer Haswell cores, and I knew nothing of video cards and linux so it took me a while to find hints that the opengl features and the whole nvidia drivers in general would have a bug somewhere. Chrome has no accelaration options enabled.

I looked at reinstalling or fixing the problem, there is a similar thread here on sabayon : viewtopic.php?f=22&t=31452&p=169410&hilit=glxinfo#p169410

lspci | grep NVIDIA gets it recognized : 01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)

# lspci -v
used to get me the analog of this output, but now I don't get the 3D controller info :

01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M] (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel modules: nouveau, nvidia

------

eselect opengl list is already showing nvidia but the

glxinfo

gets me only a bunch of Xlib: extension "GLX" missing on display ":0".

optirun glxinfo, he hets errors but I get
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: VirtualGL
server glx version string: 1.4
+ whole lot of info.

----------------

I tried the https://wiki.sabayon.org/index.php?titl ... yon#NVIDIA page, did everything there

------------------.

There is also some info on http://wiki.gentoo.org/wiki/Toshiba_Satellite_P70-A : installing the microcode package helped with less reboots but I did not found how to configure them, only check version.

I have bbswitch, bumblebee and nvidia-drivers installed, but I did not do any further configuration with them. I looked to find a bumblebee guide but did not find any. On that page and others I found the graphic capabilities info for chrome and figured it would be my card.

--------------
on this page I found some interesting infos : http://www.codelinsoft.it/sito/wiki/ite ... entoo.html [ in italian ]

they say to install acpi_call but there are no version for kernel 3.15 [ I have 3.15.8 ]
and I cannot " equo install modesetting ", no package.

They are salso aying to create a xorg.conf file but I decided to come here before getting my installation more tormented with fumbling tryouts.

-----

lshw -C display gets me only

description: VGA compatible controller
product: 4th Gen Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2

while other people gets the graphic card shown in physical id : 0.

-------------------------------------------

So.... After a couple of days I would appreciate any info and help to get this working. I reinstalled the nvidia drivers, bumblebee packages and such, tried the eselect, etc, but I have not the solution so far. Any help is appreciated :-)

[ edited for clarity and typos ]
Multimandala
Baby Hen
 
Posts: 4
Joined: Mon Jun 30, 2014 21:25

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests