Problem with login, infinite loop

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Problem with login, infinite loop

Postby uncertain » Thu Jul 31, 2014 17:06

I am not sure how much is relevant, but here's the story:

I installed LibreOffice and opened an excel spreadsheet which had macros. I did not need the macros but had them enabled. When I was done I could not close the file because it said the macro was still running (something about "cannot close while BASIC is running). I also noticed my clock was wrong and read somewhere that the cpu clock should be corrected so I went into BIOS and changed it, having had to forcequit the spreadsheet. When I got back into sabayon and tried to login the screen changes to black then goes back to original login screen. I am able to login as root but, strangely, rigo does not work, I click on it and nothing happens. When I originally used rigo to install LibreOffice it said I had config files to update but last time I did that I lost an operating system from my grub menu (I multiboot Fedora and Ubuntu with Sabayon). Hoping there is a quick fix for this...
Baby Hen
Posts: 2
Joined: Thu Jul 31, 2014 16:36

Re: Problem with login, infinite loop

Postby Stupot » Fri Aug 01, 2014 3:33

You can't ignore config file updates or...well things like this happen.

Login with a terminal as your user and perform the config updates. Ctrl+Alt+f3 should get you to a terminal. Ctrl+Alt+F7 should take you back to the virtual terminal where you're xsession is running.
Sagely Hen
Posts: 1629
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Problem with login, infinite loop

Postby uncertain » Sat Aug 02, 2014 1:35

Thanks for the reply, but I cannot login as my user, that's the infinite loop. I ran 'equo conf update' and got 'All fine baby'. I thought if I started up rigo it would give me that option(for config updates) again but even after removing and reinstalling rigo it still does not work.
Baby Hen
Posts: 2
Joined: Thu Jul 31, 2014 16:36

Re: Problem with login, infinite loop

Postby Fitzcarraldo » Sun Aug 03, 2014 0:24

When you see the DM's log-in screen, press Ctrl-Alt-F2 to switch to a VT (you may have to wait a few seconds for a prompt to appear), log-in as root user and enter the following commands:

Code: Select all
# timedatectl list-timezones # List available timezones.
# timedatectl set-timezone Europe/London # Replace Europe/London with your timezone.
# timedatectl set-time "2014-08-03 00:14:00" # Set the system time (Replace with your current time, of course).
# hwclock --systohc # Set the hardware clock to be the same as the system clock.
# equo cleanup
# equo update
# equo remove libreoffice
# equo upgrade
# equo install libreoffice
# equo conf update
# equo libtest
# equo deptest

(Press the Space Bar to page through the output of the "timedatectl list-timezones", and the "q" key to exit.)
User avatar
Sagely Hen
Posts: 8085
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests