Chrome version 32 segfaults [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Chrome version 32 segfaults [Solved]

Postby betazed » Sat Feb 08, 2014 5:57

I have been having some severe performance problems with Chromium. To get around this, I found Google Chrome in the repos which brings a more current version of Flash for its own use. It, however, has its own problems and segfaults frequently with something like:
Code: Select all
$ google-chrome-stable
[6695:6695:0207/233825:ERROR:profile_sync_service.cc(1200)] History Delete Directives datatype error was encountered: Delete directives not supported with encryption.
[6695:6725:0207/233826:ERROR:audio_manager_base.cc(422)] Not implemented reached in virtual std::string media::AudioManagerBase::GetDefaultOutputDeviceID()
Segmentation fault


Chrome will run anywhere from not at all to half an hour or more but then eventually segfault with a similar error.

Also of note, since I began writing this post it now crashes with just:
Code: Select all
Segmentation fault
and no other information.

This has only developed since Chrome version 32 has been in the repos, Chrome 31 and Chromium don't have this problem. Is there a known fix?

Computer's vital stats: AMD A10-6800K w/ Radeon graphics integrated, 8 GB RAM running Sabayon with all current updates, KDE 4.12.
Last edited by betazed on Wed Mar 12, 2014 10:22, edited 1 time in total.
User avatar
betazed
Young Hen
 
Posts: 28
Joined: Thu Jan 09, 2014 11:07
Location: St. Petersburg, FL

Re: Chrome version 32 segfaults

Postby The Catboy » Sun Feb 09, 2014 15:16

I just started getting this issue as well with both chromium and Google chrome after I updated.
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Re: Chrome version 32 segfaults

Postby The Catboy » Tue Feb 11, 2014 19:36

I would like to bump this because I am still having this problem and I've tried everything to fix it.
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Re: Chrome version 32 segfaults

Postby betazed » Wed Feb 12, 2014 5:16

I am following up. I just recieved new updates for Sabayon including the new version of Chromium that is now the same version as the Chrome version that is causing the problem in my original post. Chromium has exactly the same issue now. It crashes with exactly the same error messages and has about the same variation in run time (not even opening to about half an hour or so) prior to crashing. If there is other, pertenenent information I should be providing please let me know and it will be swiftly and happily provided.
User avatar
betazed
Young Hen
 
Posts: 28
Joined: Thu Jan 09, 2014 11:07
Location: St. Petersburg, FL

Re: Chrome version 32 segfaults

Postby batvink » Wed Feb 12, 2014 14:51

this is probably due to the tcmalloc USE-flag being enabled.
It also conflicts with NVidia, if installed.
please see
viewtopic.php?f=86&t=31388
and
https://code.google.com/p/chromium/issu ... l?id=28820
The issue is old, and closed, but it might very well be still going on in V32.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Chrome version 32 segfaults

Postby The Catboy » Wed Feb 12, 2014 15:55

I am not using NVidia, I am actually using a modified Acer C7 Chromebook with a 1.1GB dual-core CPU Intel,Celeron, 4GB DDR3 RAM, and a 320GB HDD. Using these bios
http://johnlewis.ie/coreboot-on-chromeb ... -firmware/
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Re: Chrome version 32 segfaults

Postby The Catboy » Mon Feb 17, 2014 3:16

Updated to the latest of Chrome and Chromium and still having this problem.
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Re: Chrome version 32 segfaults

Postby The Catboy » Sun Feb 23, 2014 18:19

Still updated, tested out everything from my RAM to different installs, ect ect. Still getting this error.
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Re: Chrome version 32 segfaults

Postby sabayonino » Mon Feb 24, 2014 14:16

The Catboy wrote:Still updated, tested out everything from my RAM to different installs, ect ect. Still getting this error.

try to move ~/.config/chromium folder

starting chromium with a clear configuration

Code: Select all
$ mv ~/.config/chromium ~/.config/chromium_bk

Code: Select all
 $ chromium
User avatar
sabayonino
Sagely Hen
 
Posts: 2679
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Chrome version 32 segfaults

Postby The Catboy » Mon Feb 24, 2014 18:37

sabayonino wrote:
The Catboy wrote:Still updated, tested out everything from my RAM to different installs, ect ect. Still getting this error.

try to move ~/.config/chromium folder

starting chromium with a clear configuration

Code: Select all
$ mv ~/.config/chromium ~/.config/chromium_bk

Code: Select all
 $ chromium

Tried that already, still the same problem.

I am going to play around with my graphics drivers, I just realized they were set up improperly.
User avatar
The Catboy
Simple Hen
 
Posts: 57
Joined: Mon Mar 04, 2013 19:32

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron