after update trouble booting

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

after update trouble booting

Postby jabfinger » Wed Nov 20, 2013 17:59

After update the system boots all the way to setting the keyboard at that point it stalls. I cant do alt-f1 to see what is happening not sure if it is because I use a wireless keyboard. It has been a while since I upgraded I was on the sabayon 3.4.0 kernel but the system seems to find it ok and starts booting. It has been a while since I have had to troubleshoot linux and I would really like some assistance.
jabfinger
Baby Hen
 
Posts: 6
Joined: Mon Feb 22, 2010 21:06

Re: after update trouble booting

Postby cgherman » Sat Nov 23, 2013 12:30

Maybe same here. I got this error on boot process.

switch_root: can't execute '': No such file or directory
[ 3.095046] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

Unfortunately I don't have time to wait the solution and I will reinstall
cgherman
Baby Hen
 
Posts: 5
Joined: Sat May 11, 2013 7:02

Re: after update trouble booting

Postby lxnay » Tue Nov 26, 2013 0:45

Hi, this is easy to fix. A real fix has been pushed to repositories already (weekly users will get that soon as well).
Basically, just remove the following boot parameter, from the boot command:

Code: Select all
init=/linuxrc


Open /etc/default/sabayon-grub, remove that string and do:
Code: Select all
grub2-mkconfig -o /boot/grub/grub.cfg
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: after update trouble booting

Postby papilello » Wed Nov 27, 2013 14:16

I've the same problem. Can you tell me with more details how can I open and modify the boot commnd?

Thanks
papilello
Young Hen
 
Posts: 33
Joined: Sun Oct 24, 2010 19:23

Re: after update trouble booting

Postby lxnay » Wed Nov 27, 2013 18:37

When you're in GRUB (during boot), type "e" and then use the arrows to move through the text and edit it. Once done, hit F10 or CTRL+X.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: after update trouble booting

Postby Henri » Sun Dec 01, 2013 12:54

Hi
I am maybe having similar problem with my laptop unable to boot Sabayon.
It was week 47 huge (433 updates) upgrade, which somehow broke my Sabayon.
After upgrade the booting ended up with black screen. Not even a blinking cursor at the top of left corner of the screen. So I could not get to terminal with Ctrl+Alt+F1 keypress.

When I select Sabayon-recovery X86_64-3.11.0-Sabayon from grub I end up to a screen, which suggest that there is something wrong with LVM. "mdadm: No arrays found in config file or automatically...
I have no RAID system, just basic lvm partitioning with root, home and swap partitions on a SSD drive
See screenshot below.

https://www.dropbox.com/s/gtl81y6jj0p8617/Sabayon_boot_failure.JPG
Image

After I give the root password I get to the terminal. In terminal command: equo update gives an error "invalid file system encoding ANSI_X3.4-1968, must be UTF-8....
Filesystem seems to be read only and I can't therefore edit much of the files.

Please help.

I have encountered this same problem atleast two times before about a year ago in month apart. At that time reinstallation was the solution but I am kind of tired doing that and would like to learn to fix this thing. And there are two other Sabayon installations waiting for those 433 updated packages to be installed.
Sorry that I could not get the picture linked from my dropbox showing correctly.
Henri
Baby Hen
 
Posts: 6
Joined: Sun Dec 01, 2013 12:08

Re: after update trouble booting

Postby lxnay » Sun Dec 01, 2013 13:40

That is a different problem. It seems that you may have booted in single user mode ("single" in the boot parameters) or you have problems with the filesystem. Try to enter the root password and see the boot parameters by typing:
Code: Select all
cat /proc/cmdline


Also, your picture is cut, please show the FULL display!
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: after update trouble booting

Postby Henri » Sun Dec 01, 2013 17:04

Hi
Sorry about the picture. I cut out all the OK's. Here is a complete picture.
https://www.dropbox.com/sh/o2aad2qwoibncsy/ABInjD3g5w

cat /proc/cmdline gives a following result:
Code: Select all
BOOT_IMAGE=/kernel-genkernel-x86_64-3.11.0-sabayon root=/dev/mapper/vg_t8300a-lv_root ro single init_opts=single init=/linuxrc splash=verbose,theme:sabayon video=vesafb:ywrap,mtrr:3 vga=791 console=tty1 quiet dokeymap keymap=fi domdadm resume=swap:/dev/mapper/vg_t8300a-lv_swap real_resume=/dev/mapper/vg_t8300a-lv_swap dolvm root=/dev/mapper/vg_t8300a-lv_root docrypt

Text is hand copied from the screen. This Sabayon installation is old and there are some old parameters which give an error every boot but it has still worked until this last update. The screenshot and text above is from boot attempt in recovery mode.
During boot after grub screen has passed, there are 3 errors in the screen. I think those errors have been there for ages but I mention about them so that all possible reasons for boot failure that I can think of are out in the open.
https://www.dropbox.com/sh/o2aad2qwoibncsy/ABInjD3g5w
Thank you for your help.
Henri
Baby Hen
 
Posts: 6
Joined: Sun Dec 01, 2013 12:08

Re: after update trouble booting

Postby lxnay » Sun Dec 01, 2013 17:11

You are booting in single user mode!
Drop from your command line the following parameters (all of them!):
Code: Select all
single init_opts=single
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: after update trouble booting

Postby Henri » Sun Dec 01, 2013 17:32

Ok. Thanks.

I deleted single and init_opts=single from grub boot parameters.
The booting goes a bit further now and I get the Nvidia splash screen as earlier (with single parameters) but end up the same blank screen and no option for getting the terminal open.

I'll try to capture the text from the screen during boot to see where the process stops.
Henri
Baby Hen
 
Posts: 6
Joined: Sun Dec 01, 2013 12:08

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron