System freezes after configuring xorg

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: System freezes after configuring xorg

Postby Stupot » Wed Feb 19, 2014 4:08

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

That's done as root, in a command line. You are moving that file to a new location (renaming basically).
Stupot
Sagely Hen
 
Posts: 1511
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: System freezes after configuring xorg

Postby Euro3000 » Wed Feb 19, 2014 19:01

Ok, it is all right now. I switched to nouveau and it seems all fine.

It shows now that there is 1 update:
Nvidia Userspace 331.38~1
NVIDIA X11 userspace libraries and applications
January 25, 2014, from sabayon-weekly
304.119 is installed

Why this, if I am now running on nouveau?
Is there something still to do with the NVIDIA's drivers/userspace?
What do you suggest?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Stupot » Wed Feb 19, 2014 21:13

Because you still have nvidia userspace installed. Remove it and it won't want to upgrade you.

That said, nouveau has much worse performance than the proprietary drivers. If you're fine with how it's working though, that's great.
Stupot
Sagely Hen
 
Posts: 1511
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: System freezes after configuring xorg

Postby Euro3000 » Fri Feb 21, 2014 11:28

Can't belive this thing!
After removing the nvidia userspace it was all fine, video, resolution and all.
Today after starting up the machine the resolution went back to 1024x768 and again it doesn't even show the option for 1200 x 800, I can't belive what is going on?
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Euro3000 » Sat Feb 22, 2014 15:33

In the Sabayon-Wiki (Tips) I founded a command "For nVidia Kernel Mismatch" (# emerge -C nvidia-drivers; rmmod nvidia; rm /lib/modules/$(uname -r)/video/nvidia.ko; rm /usr/lib/opengl/nvidia -rf; emerge nvidia-drivers; eselect opengl set nvidia; reboot)... What is this all about?
Digging round the forum and net, I read that when using nouveau maby it is someting wrong with the "nomodeset".
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Stupot » Sat Feb 22, 2014 17:48

nvidia-drivers replace nouveau. If you are looking to use nouveau, ignore anything about nvidia-drivers and nvidia-userspace.

I know you are anxious to get the system working 100% again, but switching back and forth it making providing support confusing.

what's the output of:
Code: Select all
xrandr --verbose
Stupot
Sagely Hen
 
Posts: 1511
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: System freezes after configuring xorg

Postby Euro3000 » Sat Feb 22, 2014 22:32

Yea I know, it is all to much confusing this way. For me it is difficult to choose what is better (nouveau or nvidia) because both they have their pluses & minuses.
Nvidia has problems when the updates are installed and every update makes you feel bad while waiting it completes because it may result in no X or somthing else...
On the other hand I noticed that visiting youtube.com with nouveau the system just freezes automaticly when you want to run a video... while on cnn.com (for example)this it is not a problem.
I don't want to hurry, I know one day it will be all right; i just need time to learn (and your advises :D ).
Yestarday I reinstalled nouveau and I saw it downloaded somthing new, after that I restarted and the resolution went back to 1280 x 800.

Here is the output:

# xrandr --verbose
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096
LVDS-1 connected 1280x800+0+0 (0x95) normal (normal left inverted right x axis y axis) 331mm x 207mm
Identifier: 0x91
Timestamp: 25145
Subpixel: unknown
Gamma: 1.0:1.0:1.0
Brightness: 1.0
Clones:
CRTC: 0
CRTCs: 0 1
Transform: 1.000000 0.000000 0.000000
0.000000 1.000000 0.000000
0.000000 0.000000 1.000000
filter:
EDID:
00ffffffffffff000e14b11300000000
06110103802115780a8e2d9d55508f27
20505400000001010101010101010101
010101010101ea1a008050200d301520
13004bcf100000190000000f00202020
2020202020206e050f00000000fe0043
50540a202020202020202020000000fe
00434c414131353457413035412000c3
dithering mode: auto
supported: auto, off, on
scaling mode: Full
supported: None, Full, Center, Full aspect
1280x800 (0x95) 68.9MHz -HSync -VSync *current +preferred
h: width 1280 start 1301 end 1333 total 1408 skew 0 clock 48.9KHz
v: height 800 start 801 end 804 total 813 clock 60.2Hz
1024x768 (0x96) 63.5MHz -HSync +VSync
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz
800x600 (0x97) 38.2MHz -HSync +VSync
h: width 800 start 832 end 912 total 1024 skew 0 clock 37.4KHz
v: height 600 start 603 end 607 total 624 clock 59.9Hz
640x480 (0x98) 23.8MHz -HSync +VSync
h: width 640 start 664 end 720 total 800 skew 0 clock 29.7KHz
v: height 480 start 483 end 487 total 500 clock 59.4Hz
720x400 (0x99) 22.2MHz -HSync +VSync
h: width 720 start 744 end 808 total 896 skew 0 clock 24.8KHz
v: height 400 start 403 end 413 total 417 clock 59.6Hz
640x400 (0x9a) 20.0MHz -HSync +VSync
h: width 640 start 664 end 720 total 800 skew 0 clock 25.0KHz
v: height 400 start 403 end 409 total 417 clock 60.0Hz
640x350 (0x9b) 17.5MHz -HSync +VSync
h: width 640 start 664 end 720 total 800 skew 0 clock 21.9KHz
v: height 350 start 353 end 363 total 366 clock 59.8Hz
DVI-I-1 disconnected (normal left inverted right x axis y axis)
Identifier: 0x92
Timestamp: 25145
Subpixel: unknown
Clones:
CRTCs: 0 1
Transform: 1.000000 0.000000 0.000000
0.000000 1.000000 0.000000
0.000000 0.000000 1.000000
filter:
dithering mode: auto
supported: auto, off, on
scaling mode: Full
supported: None, Full, Center, Full aspect
subconnector: Unknown
supported: Unknown, DVI-D, DVI-A
TV-1 disconnected (normal left inverted right x axis y axis)
Identifier: 0x93
Timestamp: 25145
Subpixel: unknown
Clones:
CRTCs: 0 1
Transform: 1.000000 0.000000 0.000000
0.000000 1.000000 0.000000
0.000000 0.000000 1.000000
filter:
overscan: 50
range: (0, 100)
hue: 0
range: (0, 100)
saturation: 50
range: (0, 100)
flicker reduction: 50
range: (0, 100)
mode: PAL
supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J
subconnector: Unknown
supported: Unknown, Composite, SVIDEO, Component, SCART
select subconnector: Automatic
supported: Automatic, Composite, SVIDEO, Component, SCART
Euro3000
Young Hen
 
Posts: 21
Joined: Sat Nov 02, 2013 10:48

Re: System freezes after configuring xorg

Postby Stupot » Sun Feb 23, 2014 0:58

So, as of right now, nouveau has the right resolution and is working (although perhaps with bad performance). Unfortunately, that's the state of nouveau really, so if the performance isn't good enough, your only choice is to get the nvidia-drivers working correctly.
Stupot
Sagely Hen
 
Posts: 1511
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Previous

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: aposteeltje and 3 guests