Page 1 of 2

Can't install however can run live just fine.

Posted: Sat Oct 19, 2013 9:28
by Cruiseomaitc
I setup the partions, Even let Anaconda do it, Used two different DVDs, Run live and try it then went in DOS and tried it. All got the same response. After it gets the files ready, 5 minutes later it brings up an error log that is way to long to post. 1mil+ characters. Been on this for a week. 2GBs ram, 2gHz Intel CPU 64 bit. Right now, I'm running live just fine while I type this. Also running latest version of Sabayon.
If I'm leaving something out please ask.
Thanks.

Re: Can't install however can run live just fine.

Posted: Sun Oct 20, 2013 1:38
by dave_64
I think your processor and RAM are adequate.
You say you "setup the partitions", and let the installer do it. Are you using the default install?...letting the installer make the appropriate partitions?
And, does your harddrive have any pre-existing data or operating system on it? Are you trying to setup a dual boot?
What is your video card/chip?

Re: Can't install however can run live just fine.

Posted: Sun Oct 20, 2013 5:50
by Cruiseomaitc
Yes, Default Install and let the installer do all the work. I even tried it manually. The HDD had 2 existing partitions when I first tried it. Then wiped the drive clean and still had problems. No dual-boot at this time. I run win 7 on a different drive. Not sure what video card I'm running. It is a Dell latitude D830.

Re: Can't install however can run live just fine.

Posted: Sun Oct 20, 2013 14:43
by Fitzcarraldo
Have you tried using GParted from a LiveCD to create the partitions manually, before running the SL Installer? I usually find that creating the partitions separately beforehand works, whereas using the partition manager in the SL Installer usually results in a failed installation in my case.

Re: Can't install however can run live just fine.

Posted: Sun Oct 20, 2013 17:42
by dave_64
I agree. Use gparted, or PartedMagic to wipe your target drive. Although, at that point, I usually start installing, but, with the "custom install" or partitioning option. If I am trying to wipe the drive of an lvm partition with sabayon's installer, I seem to have only one choice to install...another lvm install. By deleting any, and all, pre-existing partitions on the target drive (with gparted or PartedMagic), I can use the sabayon installer to create swap and /, which is all I ever use.
I always use the "custom install and partitioning" option. I don't like lvm (the default install), but it has it's place in some situations.

Re: Can't install however can run live just fine.

Posted: Mon Oct 21, 2013 2:07
by tobias boon
Just so happens I registered in this forum for the exact same problem. My specs are similar to Cruiseomaitc's though I'm on a 32-bit machine plus my HDD is completely clean after a quick run with DBAN. I'm also posting this from a Pendrive live USB which works perfectly but I just can't install SL XFCE no matter how many times I try...

The error I get is pretty nasty too judging by the size of it, pastebin.com and pastebin.sabayon.org rejected it so I had to look for a different place to dump it on: http://paste2.org/jGdgBD8O

Please help :(

EDIT: more details if needed - viewtopic.php?f=50&t=30940

Re: Can't install however can run live just fine.

Posted: Mon Oct 21, 2013 10:11
by Cruiseomaitc
Tried gparted on the live CD, No go. However, When I get to where it asks what to do, I told it to "replace" the existing linux install and after that failed, went manually and did it without touching a thing just clicked next and still failed. I'd like to have both Sabayon and Ubuntu on the drive. Ubuntu installs fine but will not see anything internet so I can't get it setup whereas Sabayon works OOTB but will not install. Currently the drive has no Linux distros installed.

Re: Can't install however can run live just fine.

Posted: Tue Oct 22, 2013 13:32
by Fitzcarraldo
Did you try setting up ext4 partitions with GParted and using the SL Installer to install into those, i.e. not using LVM at all? I usually avoid LVM.

Re: Can't install however can run live just fine.

Posted: Tue Oct 22, 2013 20:27
by Cruiseomatic
Yes. Where I get fuzzy is where I get to the install options whether to use replace or custom. Something tells me Anaconda is doing what it wants to regardless concerning lvm. I've tried almost everything and nothing seems to work. Maybe its me. I don't know.

Re: Can't install however can run live just fine.

Posted: Tue Oct 22, 2013 20:49
by dave_64
Again, make sure the target drive is "clean", in other words, not partitioned, and not formatted. It is called "free space", or unpartitioned space. Gparted can do that. The sabayon installer should be able to do that too, but I have had some "issues" with using sabayon installer to delete lvm partitions. Anyway, after you have cleared your target drive of any and all partitions, you can boot the livedvd and start installing. After the first few pages you will have an option to use "custom install or partitioning". Choose that option.
Your target drive should be visable in graphic format, and it should be all "Free space".
Now create a partition, make it "file system type" = swap
Make size = 4000
Ok, now create another partition with:
mount point = /
file system type = ext4
size = 60000
That would be a 60 gb partition. You can increase the size according to your taste, but 60 gb would be close to minimum for a decent test.