Unable to install from emerge / problems with gcc [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Unable to install from emerge / problems with gcc [Solved]

Postby likearaptor » Fri Oct 11, 2013 3:04

Hi,

I have installed Sabayon multiple times and had no issuses like this before, so I am at a loss to what to do. I always install Sabayon/Mate combo, install my favorite apps with equo, and then I emerge rpm, and use rpm to install google-chrome rpm, which works great every time. On my home laptop, I installed the OS, many apps from equo, but then when I go to install rpm from portage I get this error:

Code: Select all
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking how to print strings... printf
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... no
checking for gcc... no
checking for x86_64-pc-linux-gnu-cc... no
checking for cc... no
checking for x86_64-pc-linux-gnu-cl.exe... no
checking for cl.exe... no
configure: error: in `/var/tmp/portage/dev-util/pkgconfig-0.28/work/pkg-config-0.28':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/pkgconfig-0.28/work/pkg-config-0.28/config.log
 * ERROR: dev-util/pkgconfig-0.28 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 2906:  Called econf '--docdir=/usr/share/doc/pkgconfig-0.28/html' '--with-system-include-path=/usr/include' '--with-system-library-path=/usr/lib64'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=dev-util/pkgconfig-0.28'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/pkgconfig-0.28'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/pkgconfig-0.28/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/pkgconfig-0.28/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/pkgconfig-0.28/work/pkg-config-0.28'
 * S: '/var/tmp/portage/dev-util/pkgconfig-0.28/work/pkg-config-0.28'

>>> Failed to emerge dev-util/pkgconfig-0.28, Log file:

>>>  '/var/tmp/portage/dev-util/pkgconfig-0.28/temp/build.log'

 * Messages for package dev-util/pkgconfig-0.28:

 * ERROR: dev-util/pkgconfig-0.28 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 2906:  Called econf '--docdir=/usr/share/doc/pkgconfig-0.28/html' '--with-system-include-path=/usr/include' '--with-system-library-path=/usr/lib64'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *            die "econf failed"


I did do a emerge --update before I ran the command. What I see is it cannot find gcc "no acceptable C compiler found in $PATH". So I tried to figure out what was going on. I a not able to find the gcc or cpp binaries anywhere on the root partition. If I run "gcc-config -l" I get

Code: Select all
 [1] x86_64-pc-linux-gnu-4.7.3
 [2] x86_64-pc-linux-gnu-4.7.3-hardenednopie
 [3] x86_64-pc-linux-gnu-4.7.3-hardenednopiessp
 [4] x86_64-pc-linux-gnu-4.7.3-hardenednossp
 [5] x86_64-pc-linux-gnu-4.7.3-vanilla *


I can switch inbetween the various configs, log out and back in but I don't have gcc or cpp in my path like the error says. Being a long time Gentoo fan I know compilers are very necessary to install anything with emerge. I assume something was corrupt from this last install since I have no problem installs apps with emerge before. My work computer has no issues and it is running the same setup. Any ideas on how I can fix this without having to reinstall the OS again?
Last edited by likearaptor on Fri Oct 11, 2013 5:39, edited 1 time in total.
likearaptor
Baby Hen
 
Posts: 3
Joined: Mon Sep 09, 2013 17:43

Re: Unable to install anything from emerge / problems with g

Postby Stupot » Fri Oct 11, 2013 5:34

Try resintalling sys-devel/gcc-4.7.3, maybe sys-devel/gcc-config-1.7.3, and sys-devel/base-gcc-4.7.3.

One of those packages probably sets the path.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Unable to install anything from emerge / problems with g

Postby likearaptor » Fri Oct 11, 2013 5:39

Stupot wrote:Try resintalling sys-devel/gcc-4.7.3, maybe sys-devel/gcc-config-1.7.3, and sys-devel/base-gcc-4.7.3.

One of those packages probably sets the path.


You are awesome, the first package was the one that wasn't working right. Now to have fun with emerge :) Thanks
likearaptor
Baby Hen
 
Posts: 3
Joined: Mon Sep 09, 2013 17:43


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 3 guests

cron