How to get my WICD auto start on login? [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

How to get my WICD auto start on login? [Solved]

Postby gocool » Tue Oct 01, 2013 12:41

Hi,
When I login I get a window to enter the root password for my wicd to begin.

After entering the password and select on "remember the password", still I get the same dialog box the next reboot.

Is there a way to make it remember?

I use KDE.

regards,
Gocool
Last edited by gocool on Tue Dec 10, 2013 17:22, edited 1 time in total.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: How to get my WICD auto start on login?

Postby dave_64 » Tue Oct 01, 2013 19:54

It's been a long time since I did this, and, I can't remember exactly how to do it, but, if I remember correctly, you make a link in your home directory, in the .kde4 subdirectory (a hidden directory), and the sub sub directory Autostart, to the wicd command (including the path to it, of course).
I don't know if this is relevent with systemd, but another thing we did was run these two commands (as root):
rc-update add wicd default
rc-update del networkmanager
You might want to wait for a more confident response or confirmation on some of this.
dave_64
Advanced Hen
 
Posts: 226
Joined: Sun Feb 22, 2009 20:33

Re: How to get my WICD auto start on login?

Postby gocool » Fri Oct 04, 2013 2:18

Since I have systemd, i think it's going to be different...but not sure...
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: How to get my WICD auto start on login?

Postby dave_64 » Fri Oct 04, 2013 3:54

Sorry I can't give you a more definitive answer, but I don't know how things and what things are changed with systemd. As you suggest, the rc-update commands may not work with systemd.
I should have mentioned that after running those commands, you need to reboot for them to take effect. I also noticed that the word "networkmanager" should be:
NetworkManager
And, of course, to reverse the process and restore networkmanager:
rc-update add NetworkManager default
rc-update del wicd
dave_64
Advanced Hen
 
Posts: 226
Joined: Sun Feb 22, 2009 20:33

Re: How to get my WICD auto start on login?

Postby gocool » Fri Oct 04, 2013 13:34

wicd is already in the default

Code: Select all
sabayon # rc-update | grep wicd
                 wicd |      default 


And my wicd is working perfectly, but the only thing is after KDE is launched, it shows a dialog box to enter the root password, and I don't want to enter it every time the machine boots.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: How to get my WICD auto start on login?

Postby dave_64 » Sat Oct 05, 2013 4:28

You might get some ideas if you google on:
gentoo wicd autostart
This link looks interesting:
http://forums.gentoo.org/viewtopic-t-96 ... 91365ebddf
dave_64
Advanced Hen
 
Posts: 226
Joined: Sun Feb 22, 2009 20:33

Re: How to get my WICD auto start on login?

Postby daywatch » Sun Oct 06, 2013 7:45

with systemd, after installing net-misc/wicd:

Code: Select all
# systemctl disable NetworkManager
# systemctl stop NetworkManager
# systemctl enable wicd


after, enable the wicd client with the --tray option in your startup apps .Don't know how in KDE, I am not using it, in xfce is already made and entry for wicd-gtk --tray at Settings > Session and Startup > Application Autostart.
I suppose for KDE you must install also kde-misc/wicd-client-kde

reboot and you should be happy.
daywatch
Baby Hen
 
Posts: 3
Joined: Sat Sep 28, 2013 12:19

Re: How to get my WICD auto start on login?

Postby gocool » Tue Dec 10, 2013 17:21

Awesome...that worked. Thank you again.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests