Problems with the new updates - webcam doesnt work [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Problems with the new updates - webcam doesnt work [Solved]

Postby gocool » Thu Sep 12, 2013 20:07

Hi,

Just a day or two back there was a huge list of updates which was pushed.

I updated it using

Code: Select all
equo update && equo upgrade --ask


There were around 200+ updates. And after that my webcam just doesnt work anymore. I use KDE.

I used to have this issue on and off and had many threads opened in this forum, but no help.

In short I just couldnt understand this. When an updates is pushed, the webcam stops working, then another update comes and it starts working, then another one comes and it stops working...so on and so forth. I first thought to have a look if there are any updates happening to the driver or the video and started to monitor it...but no use.

My XOrg config file is here

My system and hwinfo is here

My enabled services and the runlevels is here

My dmesg is here

My rc.log is here

My /var/log/messages is here

My KDM log is here


Is this being looked at? Is it just me?

My machine is current.

Let me know what other info you need from me and I'll be more than glad to provide you with it.

~ gocool
Last edited by gocool on Tue Sep 17, 2013 18:43, edited 1 time in total.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - webcam doesnt work

Postby gocool » Tue Sep 17, 2013 0:26

I heard there was some issues with kernel 3.7. So I installed kernel 3.10...still my webcam doesnt work
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - webcam doesnt work

Postby linuxfluesterer » Tue Sep 17, 2013 7:57

Hallo gocool.
You've just posted your hardware info with a kernel 3.7 installed. I thought, you've installed Kernel 3.10 now.
Which program do you use to check webcam? Kopete is installed already. You can check your cam is shown in 'Settings', 'Install or Setup' and then 'Video'. I just saw myself here.

Pls, could you install and run:
Code: Select all
hwinfo --usb

Post here then, pls.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - webcam doesnt work

Postby gocool » Tue Sep 17, 2013 14:30

Sorry linuxfluesterer for that. Yes I have the new 3.10 kernel.

Code: Select all
sabayon dev # eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.7.0-sabayon
  [2]   linux-3.10.0-sabayon *


Code: Select all
sabayon dev # uname -r
3.10.0-sabayon


I used cheese to test it and also skype to test it. Both used to work before.

Here is the hwinfo of my machine
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - webcam doesnt work

Postby gocool » Tue Sep 17, 2013 16:06

... continuing from the above, when I tried to do a equo deptest, I am finding this discrepancy, is this something which I need to be concerned
Code: Select all
sabayon user # equo deptest
>>  @@ Running dependency test...
>>  @@ These are the dependencies not found:
>>    # <x11-base/xorg-server-1.13.99
>>       # Needed by:
>>       # x11-drivers/xf86-video-mga-1.6.2
>>  @@ Installing available packages in 10 seconds ...
>> No packages found.
(1, False)


What is this x11-drivers/xf86-video-mga-1.6.2? Does my video card require mga? If not can I remove it?

Code: Select all
sabayon user # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *

gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - webcam doesnt work

Postby linuxfluesterer » Tue Sep 17, 2013 16:30

Hallo gocool.
Exactly, your webcam is recognized:
Code: Select all
06: USB 00.0: 0000 Unclassified device
  [Created at usb.122]
  Unique ID: jxEh.uDuPqhZNn05
  Parent ID: zPk0.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb4/4-4/4-4:1.0
  SysFS BusID: 4-4:1.0
  Hardware Class: unknown
  Model: "Logitech Unclassified device"
  Hotplug: USB
  Vendor: usb 0x046d "Logitech, Inc."
  Device: usb 0x09b0
  Revision: "0.06"
  Driver: "uvcvideo"
  Driver Modules: "uvcvideo"
  Device File: /dev/input/event9
  Device Number: char 13:73
  Speed: 480 Mbps
  Module Alias: "usb:v046Dp09B0d0006dcEFdsc02dp01ic0Eisc01ip00in00"
  Driver Info #0:
    Driver Status: uvcvideo is active
    Driver Activation Cmd: "modprobe uvcvideo"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #5 (Hub)

Read, what Stupot says about packages, which are no more in repository. You can remove them.
https://forum.sabayon.org/viewtopic.php?f=86&t=30732&p=166164&hilit=deptest#p166164
Don't care the topic, pls. Remove is recommended anyway, when after an upgrade there are packages no more in repo.

Exactly, I'm rather sure, that is not the cause for your webcam problem, but, who knows? Remove xf86-video-mga-1.6.2 and then reboot (for me). When back in KDE again, pls, start your Kopete. Go to the settings of Kopete and then 'Video'.
Do you see yourself in cam? My point is, does at least one program show your cam?

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - webcam doesnt work

Postby gocool » Tue Sep 17, 2013 18:42

linuxflusterer...YOU DID YOUR MAGIC AGAIN.

I just removed that package and rebooted it...and voila, my cheese and my skype shows the video.

Well my kopete just doesnt launch for some reason...but hey...I never use it...so no complains.

You better send in your picture to me, so that I can frame it in my house and pay my obeisances ever day... you just are my lucky charm.
gocool
Growing Hen
 
Posts: 139
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - webcam doesnt work [Solv

Postby linuxfluesterer » Tue Sep 17, 2013 18:57

You're welcome, my friend. Thank you for warm words. Pls. mark the thread as [Solved].

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - webcam doesnt work [Solv

Postby linuxfluesterer » Tue Sep 17, 2013 18:58

You're welcome, my friend. Thank you for warm words.

-Linuxfluesterer (I love KDE ...)
TTIP is NOT YET stopped. Especially consider NHS and ISDS topics. Talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 699
Joined: Thu Sep 20, 2012 19:47
Location: Germany


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 6 guests