Problems with the new updates-Ext drive mount issues[Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: Problems with the new updates - External drive doesnt mo

Postby linuxfluesterer » Mon Sep 16, 2013 15:25

What you you receive, when you do a:
Code: Select all
lsof | grep run
?
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 774
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - External drive doesnt mo

Postby linuxfluesterer » Mon Sep 16, 2013 15:43

There is another way to find out, which process uses your disk, the fuser command (you've mentioned it already).
But be sure of the correct drive, shown with fdisk -l (you showed /dev/sdb1):
Code: Select all
fuser -m /dev/sdb1

Then you'll get a number, a pid... Maybe there are more than one.
But you should be able to kill any process with:
Code: Select all
kill -9 <pid>

Then you should be able to umount, respective to mount that drive again.
Let me know pls.

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 774
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - External drive doesnt mo

Postby gocool » Mon Sep 16, 2013 16:15

fuser came up with nothing

Code: Select all
sabayon user # fuser -m /dev/sdb1
sabayon user #


lsof came up with a big list

Code: Select all
sabayon user # lsof | grep run | pastebunz
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
      Output information may be incomplete.
https://pastebin.sabayon.org/pastie/13324
sabayon user #

You can find the output here.

Thankyou for all the trouble you are taking for me.
gocool
Growing Hen
 
Posts: 149
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - External drive doesnt mo

Postby linuxfluesterer » Mon Sep 16, 2013 17:49

I have found an interesting link due to your message. I remember, you have kernel 3.7 in use, haven't you?
So read this, pls :
https://bugzilla.redhat.com/show_bug.cgi?id=909735
and then I'd really encourage you to install a new kernel, I think, 3.10 is a good one.
So, boot with your USB Life System again, then connect your NTFS drive and see what happens then. When working fine, take a decision. New Kernel or maybe new install. Remember: Kernels are NEVER upgraded by Rigo or 'equo upgrade'!
This is a procedure you must do with consciousness. That is the reason, why you still have kernel 3.7 in use.

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 774
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates - External drive doesnt mo

Postby gocool » Mon Sep 16, 2013 18:17

linuxfluesterer...thank you for the link.

Yes I do see an entry in my /etc/mtab for sdb1

So can i edit it and remove the line?

After removing will it make mouting impossible for future?

And yes I am willing to upgrade my kernel using kernel-switcher to 3.10

Do let me know for the above three questions.

And I have no words to describe your help, as always indebted.
gocool
Growing Hen
 
Posts: 149
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates - External drive doesnt mo

Postby gocool » Mon Sep 16, 2013 18:34

continuing from the above post...

I went ahead and removed the line which has /dev/sdb1 from /etc/mtab and rebooted...AND VOILA...I GOT TO GET MY EXTERNAL USB DRIVE MOUNTED AGAIN.

linuxfluesterer...you are A GOD IN INFORMATION...my humble salutations to you.
gocool
Growing Hen
 
Posts: 149
Joined: Wed Aug 06, 2008 13:37

Re: Problems with the new updates-Ext drive mount issues[Sol

Postby linuxfluesterer » Mon Sep 16, 2013 19:38

How can I say, gocool?
Thank God. I'm glad, that finally I could help you.
And now, have fun with Sabayon again... :)

-Linuxfluesterer (I love KDE ...)
Take away Facebook from me and let there be real people again...
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 774
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Problems with the new updates-Ext drive mount issues[Sol

Postby gocool » Tue Sep 17, 2013 0:21

I have my webcam issue yet to be resolved. (I have created separate post for it)
gocool
Growing Hen
 
Posts: 149
Joined: Wed Aug 06, 2008 13:37

Previous

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron