Upgrade trashed my system and now Rigo won't start!?

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: Upgrade trashed my system and now Rigo won't start!?

Postby life-on-mars » Mon Jul 29, 2013 12:50

VolvoBirkenstock wrote:However, no version number was returned for "entropy", and this deviates from the description seen in http://wiki.sabayon.org/index.php?title=En:Entropy.


Code: Select all
equo s entropy


That should give you the entropy version.

I wouldn't count that much on anything written in the wiki. Much of it is either incorrect or outdated. Most likely because wiki.sabayon.org is not open for everyone (looks more like an invite-only club to me).
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: Upgrade trashed my system and now Rigo won't start!?

Postby VolvoBirkenstock » Wed Jul 31, 2013 0:55

Thank you, life-on-mars.
The entropy version has checked out as the correct one.
Now if only I could get rigo working...
VolvoBirkenstock
Growing Hen
 
Posts: 147
Joined: Sun Mar 31, 2013 5:34

Re: Upgrade trashed my system and now Rigo won't start!?

Postby VolvoBirkenstock » Wed Jul 31, 2013 3:49

I just discovered that I can run rigo from the command line if I am root. When I run rigo as root, equo update reports nothing new, even though I use sabayon weekly and my last update was last week. I still cannot start rigo from either the command line or the desktop icon if I am a "regular user".
VolvoBirkenstock
Growing Hen
 
Posts: 147
Joined: Sun Mar 31, 2013 5:34

Re: Upgrade trashed my system and now Rigo won't start!?

Postby VolvoBirkenstock » Wed Jul 31, 2013 3:51

By the way, when I run rigo from the command line as root and try to manage repositories, the rigo display blanks along with the following written to the konsole where root started rigo:
Code: Select all
Traceback (most recent call last):
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 1035, in do_render
    is_rtl)
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 902, in _render_icon
    icon = self._icon
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 890, in _icon
    self._icon_size, 0)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Failed to load icon

(rigo:11465): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion `path != NULL' failed

(rigo:11465): GLib-GIO-CRITICAL **: g_loadable_icon_load: assertion `G_IS_LOADABLE_ICON (icon)' failed
Traceback (most recent call last):
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 1035, in do_render
    is_rtl)
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 902, in _render_icon
    icon = self._icon
  File "/usr/lib/rigo/rigo/ui/gtk3/widgets/cellrenderers.py", line 890, in _icon
    self._icon_size, 0)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
gi._glib.GError: Failed to load icon
VolvoBirkenstock
Growing Hen
 
Posts: 147
Joined: Sun Mar 31, 2013 5:34

Re: Upgrade trashed my system and now Rigo won't start!?

Postby joost » Wed Jul 31, 2013 8:11

joost wrote:A guess, maybe this will fix it.
run as root:
Code: Select all
equo install gdk-pixbuf

joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Upgrade trashed my system and now Rigo won't start!?

Postby VolvoBirkenstock » Thu Aug 01, 2013 1:57

Thank you, joost. That fixed it. The gdk-pixbuf now on my system is x11-libs/gdk-pixbuf-2.28.2. This is the same revision on my system that I reported in the 9th post to this thread. Did another package downloaded during an upgrade overwrite something normally distributed under x11-libs/gdk-pixbuf-2.28.2? Otherwise I have no idea what could have caused this issue.

I would mark this thread "Solved", except that I'm not the original author.

Again, thank you very much, joost. Most excellent. :-)
VolvoBirkenstock
Growing Hen
 
Posts: 147
Joined: Sun Mar 31, 2013 5:34

Previous

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: edjen and 2 guests