Got a virus?? help

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
Young Hen
Posts: 31
Joined: Sat Jun 22, 2013 21:24

Got a virus?? help

Post by Beerforfree » Wed Jul 24, 2013 3:08

I don't know what happened, until yesterday my notebook was working great, today I turned it on, did not connect to WiFi, after rebooting even the tray icon disapeared. I try to get into some configuations like Time & Date no permision, Network no permision, Network Connection I can access it but I can't do anyting, everything is grayed.
Under Session & Starup Network is listed to autostart

It looks like my user lost some rights and isn´t running some services. I don't remeber changing anything of this, I just downloaded some movies from youtube last night and played cards

<strike>I tried to log in as su from the GUI but looks not to be possible, from a terminal is it possible but I'm not skilled at all with all linux commands</strike>
Shame my self, I've used the wrong user su instead of root

I logged as root and found my network is disabled, when I enable it a message appearsThe configuration could not be saved Invalid data was found

for the wired config I just choosed DHCP

I'm using xfce
If someone could give some tips how to recover it I would appreciate any suggestion and guidelines

Simple Hen
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: Got a virus?? help

Post by life-on-mars » Thu Jul 25, 2013 5:22

It's very unlikely that this is caused by a virus.

Where exactly does the message you're talking about appear?
Is wired networking still working?
Does your wlan0 interface appear when you run ifconfig in a terminal?
Did you try to turn off networking and turn it on again?
Do you get any error messages when you run dconf-editor in a terminal?
Can other devices/computer still connect to your router?
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖

Young Hen
Posts: 31
Joined: Sat Jun 22, 2013 21:24

Re: Got a virus?? help

Post by Beerforfree » Tue Jul 30, 2013 1:55

The message appears at
Application Menu/Settings/Network here tried to enable the Network Manager as root with no success

Meanwhile I realized some stuff with help of a friend
Network recovered using command iwlist scanning a few times
The network manager crashed that's why I'm not seeing the icon tray anymore and lost WLAN connection at that time. The network manager is still not working and I have no idea how to bring it back to life

dconf-editor works, not much to see in it...

How do I find out which network manager is installed so as to re-install it or remove it completely since it isn't for much use in this state?

Post Reply