After Jul 22 update, can't get past GRUB menu [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Baby Hen
Posts: 2
Joined: Wed Jul 24, 2013 11:22

Re: After Jul 22 update, can't get past GRUB menu

Post by shadow4k » Wed Jul 24, 2013 16:48

I have the same problem. My device is encrypted too. When I add 'nomodeset', the systems stops at a later stage, while determining the root device. I don't even get asked for the password to encrypt the volume. :cry:

>> Determining root device...
!! Block device /dev/mapper/vg_shadow-lv_root is not a valid root device...

Afterwards I get asked to file in a bug report with a shown massage, which begins with
"Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100"

I dont't even get as far as dontregister. If I'd have a console I could just backup my home directory an reinstall the whole system.

Has anyone any ideas?

Edit: I hve that problem since I updated to Kernel 3.7.0 yesterday. Before everything was running fine.

Edit No. 2:
Well... while trying to get to my encrypted home folder on my encryped harddisk, I accidentally killed the file system. So the boot problem should be fixed after reinstalling the system. :roll:

Baby Hen
Posts: 16
Joined: Sun Jul 22, 2012 10:57

Re: After Jul 22 update, can't get past GRUB menu

Post by dontregister » Fri Jul 26, 2013 4:46

I grabbed the 3.9.10-3 kernel update today, and I am no longer having any problems. Hooray! I was able to revert my grub command and am not blacklisting radeon any more. Thanks to everyone who worked on it in package land.

Post Reply