Problems upgrading my old computer

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Problems upgrading my old computer

Postby mrizzone » Thu Jul 18, 2013 22:06

Hello! I have installed Sabayon GNOME in a 5-6 years PC. In order to upgrade it properly I added these lines to my .bashrc

Code: Select all
>=x11-drivers/nvidia-drivers-310.19
>=media-video/nvidia-settings-310.19
>=x11-drivers/nvidia-userspace-310.19


I run these commands:

Code: Select all
equo update
equo install entropy equo
equo upgrade
equo deptest
equo conf update
equo libtest


with this result:
Code: Select all
juan@juan ~ $ su
Password:
su: Authentication failure
juan@juan ~ $ su
Password:
juan juan # equo update
>> Repository sabayon-weekly hasn't been downloaded yet.
>> Repository sabayon-weekly is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!
>>  @@ Repositories synchronization ...
>>   # Sabayon Linux Official Repository
>>   # Repository URL: http://pkg.sabayon.org/standard/sabayon-weekly/database/x86/5
>>   # Repository local path: /var/lib/entropy/client/database/x86/sabayon-weekly/standard/x86/5
>>   # Repository API: 2
>>    Downloading repository ...
>>    Downloading checksum packages.db.dumplight.bz2.md5 ...
>>    packages.db.meta: available, w00t!.
>>      << unpacked meta file: 00-sabayon.package.keywords
>>      << unpacked meta file: 00-sabayon.package.mask
>>      << unpacked meta file: 00-sabayon.package.unmask
>>      << unpacked meta file: 00-sabayon.package.use
>>      << unpacked meta file: eapi
>>      << unpacked meta file: make.conf
>>      << unpacked meta file: make.profile
>>      << unpacked meta file: packages.db.critical
>>      << unpacked meta file: packages.db.fallback_mirrors
>>      << unpacked meta file: packages.db.keywords
>>      << unpacked meta file: packages.db.lic_whitelist
>>      << unpacked meta file: packages.db.mask
>>      << unpacked meta file: packages.db.mirrors
>>      << unpacked meta file: packages.db.post_update.sh
>>      << unpacked meta file: packages.db.post_upgrade.sh
>>      << unpacked meta file: packages.db.restricted
>>      << unpacked meta file: packages.db.revision
>>      << unpacked meta file: packages.db.system_mask
>>      << unpacked meta file: packages.db.webservices
>>      << unpacked meta file: parent
>>    Downloading GPG signature of repository metafile packages.db.meta.asc ..>>    packages.db.meta.asc: not available, it's ok.
>>    notice.rss: available, w00t!.
>>    Repository revision: 2782
>>    Downloaded repository status: OK
>>    Unpacking database to packages.db.dumplight ...
>>    Injecting downloaded dump packages.db.dumplight, please wait ...
>>  * ATTENTION: forcing packages metadata update.
>>  * Updating system database using repository sabayon-weekly.
>>  * SPM: Running packages metadata update, it could take a while.
Emaint: fix moveinst       100% [============================================>]
>>  * Entropy: action: slotmove dev-libs/boost 1.46 0.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move x11-libs/vdpau-video x11-libs/libva-vdpau-driver.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: slotmove <net-libs/farstream-0.1.90 0 0.1.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/zd1211-firmware sys-firmware/zd1211-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/ipw2200-firmware sys-firmware/ipw2200-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/b43-firmware sys-firmware/b43-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/ipw2100-firmware sys-firmware/ipw2100-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/bluez-firmware sys-firmware/bluez-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move net-wireless/zd1201-firmware sys-firmware/zd1201-firmware.
>>  @@ Entropy: package move actions complete.
>>  * Entropy: action: move app-misc/sabayonlive-tools app-misc/sabayon-live.
>>  @@ Entropy: package move actions complete.
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/bluez-firmware-1.2' to '/var/tmp/entropy/bluez-firmware-1.2'
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/b43-firmware-4.174.64.19' to '/var/tmp/entropy/b43-firmware-4.174.64.19'
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/ipw2100-firmware-1.3' to '/var/tmp/entropy/ipw2100-firmware-1.3'
>>  * SPM: Moving old entry '/var/db/pkg/app-misc/sabayonlive-tools-2.3-r19' to '/var/tmp/entropy/sabayonlive-tools-2.3-r19'
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/ipw2200-firmware-3.1' to '/var/tmp/entropy/ipw2200-firmware-3.1'
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/zd1201-firmware-0.14' to '/var/tmp/entropy/zd1201-firmware-0.14'
>>  * SPM: Moving old entry '/var/db/pkg/net-wireless/zd1211-firmware-1.4' to '/var/tmp/entropy/zd1211-firmware-1.4'
>>  * SPM: Moving old entry '/var/db/pkg/x11-libs/vdpau-video-0.7.3' to '/var/tmp/entropy/vdpau-video-0.7.3'
>>  @@ Entropy: package moves completed successfully.
>>    Indexing Repository metadata ...
>>  @@ /etc/make.profile: link differs. Updating.
>>  @@ /etc/make.profile: new link does not exist. Reverting.
>>  @@ Security Advisories: getting latest advisories ...
>>    # Security Advisories: verification successful.
>>    # Security Advisories: installing ...
>>  @@ Security Advisories: updated successfully
>>  @@  Notice board: sabayon-weekly
>>     [0] [Thu, 20 Sep 2012 09:16:14 +0000] Title: Important: Sabayon needs your donation NOW
>>     [1] [Sun, 14 Oct 2012 20:13:01 +0000] Title: Important AMD GPU related changes in Linux Kernel 3.6+
>>     [2] [Sun, 17 Mar 2013 07:53:17 +0000] Title: Beware AMD Radeon legacy and NVIDIA GeForce legacy users
>>     [3] [Fri, 12 Apr 2013 05:38:18 +0000] Title: SystemD replacing Udev, don't panic!
juan juan # equo install entropy equo
>>
>>
>>  !!! Please update the following critical packages:
>>   # >=sys-apps/entropy-205
>>   # >=sys-apps/portage-2.2.0_alpha142
>>   # >sys-libs/glibc-2.16.9999
>>   # sys-devel/base-gcc:4.7
>>  !!! You should install them as soon as possible
>>
>>
>>  @@ Calculating dependencies ...
>>  @@ Conflicting packages were pulled in:
>>
>>   #  x11-drivers/nvidia-userspace-304.88
>>   #  x11-drivers/nvidia-userspace-173.14.37
>>
>>  @@  Please mask conflicts using: equo mask <package>
juan juan # equo upgrade
>>  @@ Calculating System Updates...
>>  @@ Calculating dependencies ...
>>  @@ Conflicting packages were pulled in:
>>
>>   #  x11-drivers/nvidia-userspace-304.88
>>   #  x11-drivers/nvidia-userspace-173.14.37
>>
>>  @@  Please mask conflicts using: equo mask <package>
juan juan # equo upgrade
>>  @@ Calculating System Updates...
>>  @@ Calculating dependencies ...
>>  @@ Conflicting packages were pulled in:
>>
>>   #  x11-drivers/nvidia-userspace-304.88
>>   #  x11-drivers/nvidia-userspace-173.14.37
>>
>>  @@  Please mask conflicts using: equo mask <package>
juan juan # equo deptest
>>  @@ Running dependency test ...
>>  @@  (1157/1157) Checking dev-libs/yajl-1.0.11
juan juan # equo conf update
>>  @@ Scanning filesystem ...
>> All fine baby. Nothing to do!
juan juan # equo libtest
>>  @@ Libraries test
>>  @@ discarding directory: /usr/lib64, because it's symlinked on: /usr/lib
>>  @@ discarding directory: /lib64, because it's symlinked on: /lib
>>  @@ Collecting broken executables
>>  @@ Attention: don't worry about libraries that are shown here but not later.
>>    (74.3%) /usr/lib/python2.7/site-packages/tpfarstream.so [ libtelepathy-farstream.so.0 ]
>>  @@ Matching broken libraries/executables
>>  @@ Libraries/Executables statistics:
>>  ## Matched:
>>    /usr/lib/python2.7/site-packages/tpfarstream.so => net-libs/telepathy-farstream-0.6.0 [sabayon-weekly]
>>  @@ Installing available packages in 10 seconds ...
>>  @@ Calculating dependencies ...
>>  @@ Conflicting packages were pulled in:
>>
>>   #  x11-drivers/nvidia-userspace-304.88
>>   #  x11-drivers/nvidia-userspace-173.14.37
>>
>>  @@  Please mask conflicts using: equo mask <package>
juan juan # equo install libreoffice
>>
>>
>>  !!! Please update the following critical packages:
>>   # >=sys-apps/entropy-205
>>   # >=sys-apps/portage-2.2.0_alpha142
>>   # >sys-libs/glibc-2.16.9999
>>   # sys-devel/base-gcc:4.7
>>  !!! You should install them as soon as possible
>>
>>
>>  @@ Calculating dependencies ...
>>  @@ Conflicting packages were pulled in:
>>
>>   #  x11-drivers/nvidia-userspace-304.88
>>   #  x11-drivers/nvidia-userspace-173.14.37
>>
>>  @@  Please mask conflicts using: equo mask <package>
juan juan #


As you can see, I have a conflict with the video drivers, but don't know how to resolve it. Any help is welcome.

Thanks!
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56

Re: Problems upgrading my old computer

Postby dave_64 » Thu Jul 18, 2013 23:22

Although I can't be sure, this looks like a problem I encountered a week or two ago. My solution was to remove the 3 lines in the package.mask file and then install the latest nvidia drivers. My guess is that nvidia developers decided not to deprecate the older nvidia cards, so bundled them up in their latest driver package.
By the way, you don't need to actually remove the 3 lines in the package.mask file. Just edit each of the lines by putting a # symbol at the beginning of the line. The hash mark will make the line un-actionable by the package manager. If my solution is wrong, you may eventually have to restore the 3 lines (delete the hash marks).
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Problems upgrading my old computer

Postby dave_64 » Thu Jul 18, 2013 23:25

I just noticed that you put those lines in .bashrc. That's not where they belong. Maybe that's your problem.
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Problems upgrading my old computer

Postby mrizzone » Fri Jul 19, 2013 2:12

Thanks man you're right. I'll make the adjustements the next week, still in touch!
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 4 guests