GNOME-Keyring does not accept password anymore

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

GNOME-Keyring does not accept password anymore

Postby Honeyman » Tue Jul 16, 2013 23:08

I have the MATE desktop environment installed under Sabayon 11. Until the last update yesterday a window would pop up after booting the system, asking me to provide my personal login password, since the GNOME-keyring didn't get unlocked during the startup process (So far I have not found a solution for this). Well, from now on, this window does not appear automatically anymore. When I launch the Evolution mail client, GNOME-keyring suddenly asks for my password (The passwords for my mail accounts are stored in the GNOME-keyring). Unfortunately it does not accept my password for whatever reason. I checked the keyboard layout, that is correct. I cannot even cancel the inquiries by the GNOME-keyring manager! As a consequence I cannot use Evolution anymore for reading my mails.

What can I do about that issue?
Last edited by Honeyman on Tue Jul 23, 2013 22:50, edited 1 time in total.
Je me regarde pour me désoler,
je me compare pour me consoler

Maurice de Talleyrand
Honeyman
Growing Hen
 
Posts: 159
Joined: Sun Apr 08, 2012 2:25
Location: Berlin, Germany

Re: GNOME-Keyring does not accept password anymore

Postby life-on-mars » Mon Jul 22, 2013 13:06

Did you change your login password?
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: GNOME-Keyring does not accept password anymore

Postby Honeyman » Mon Jul 22, 2013 13:48

No
Je me regarde pour me désoler,
je me compare pour me consoler

Maurice de Talleyrand
Honeyman
Growing Hen
 
Posts: 159
Joined: Sun Apr 08, 2012 2:25
Location: Berlin, Germany

Re: GNOME-Keyring does not accept password anymore

Postby life-on-mars » Mon Jul 22, 2013 17:26

You say it happened after an upgrade, right? Was your Displaymanager or dbus upgraded? You can check the write dates in your entropy cache to find it out. I'm not sure of gnome-keyring uses dbus, but if your dbus system is broken that would explain it. It is your Displaymanager that starts your dbus session daemon and also opens your keyring. With lightdm e.g. it can happen that dbusd is not properly started and various apps that use dconf break.

try
Code: Select all
dconf-editor

as normal user to find out if your dbus session daemon works. If you see an error message that says the daemon doesn't accept connections, something is wrong.

If dbus doesn't work, there is a good chance that changing your DM to gdm solves the problem. Otherwise, you still can try switching to gdm. Install gdm and change your DM in /etc/conf.d/xdm:
Code: Select all
equo i gdm
sed -e 's/DISPLAYMANAGER/#DISPLAYMANAGER/g' -i /etc/conf.d/xdm
echo 'DISPLAYMANAGER="gdm"' >> /etc/conf.d/xdm
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: GNOME-Keyring does not accept password anymore

Postby Honeyman » Wed Jul 24, 2013 22:50

I launched dconf-editor via the command line:

Code: Select all
pascal@Sabayon:~$ dconf-editor

** (dconf-editor:6057): WARNING **: dconf-schema.vala:330: Unknown property on <schema>, extends

** (dconf-editor:6057): WARNING **: dconf-schema.vala:330: Unknown property on <schema>, extends

** (dconf-editor:6057): WARNING **: dconf-schema.vala:330: Unknown property on <schema>, extends
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.


I searched dconf-editor for 'schema' and found that it has to do with the MATE terminal and was set to default value 0. I have the suspicion that this warning has nothing to do with my problem. Elsewhere in dconf-editor I could not find anything related to gnome-keyring except for settings on the keyring's behaviour when suspending or hibernating the computer. This being a desktop computer this is presumably irrelevant.

Regarding the 'Fontconfig warning' I checked the file in question /etc/fonts/conf.d/50-user.conf and frankly I'm unsure whether it is a wise idea to change value for 'deprecated' in the line
Code: Select all
<include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>


to
Code: Select all
<include ignore_missing="yes" deprecated="no">~/.fonts.conf</include>


I seem to be using lsdm as the process list tells me the /usr/bin/lxdm-binary is running.
Je me regarde pour me désoler,
je me compare pour me consoler

Maurice de Talleyrand
Honeyman
Growing Hen
 
Posts: 159
Joined: Sun Apr 08, 2012 2:25
Location: Berlin, Germany

Re: GNOME-Keyring does not accept password anymore

Postby life-on-mars » Thu Jul 25, 2013 3:28

Well, doesn't look like the problem is with D-Bus.

Perhaps you can try using polkit to run something from a terminal and see if the spits out any error messages.
Code: Select all
pkexec <random command>


I assume Rigo is also using pkexec, so this should at least sort out if the problem is with Rigo or Polkit.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: GNOME-Keyring does not accept password anymore

Postby Honeyman » Thu Jul 25, 2013 22:14

I ran (as normal user)
Code: Select all
$ pkexec mount | column -t


Then a window popped up asking me to choose a user in whose name the command is to be executed and I'm presented with a coice between my user name, pascal, and sabayonmce, which somehow the system created. I do not know what this user's role is, but I will leave alone for the while being. Then I have to type in my login password and the command gets executed. No error messages or any other weird things.


I only need the GNOME-keyring for Evolution mail as in it the passwords for my 7 mail accounts are stored. Now I realized that I have to type in my password exactly 7 times (the same number as mail accounts configured) before the window demanding my password goes away, so I imagine the keyring is called upon separately for each mail account. Not the mail account passwords are required each time but the keyring password. As to what I have read about systemd so far (http://lwn.net/Articles/389149/) this behavior would make some sense. The service GNOME-keyring is launched only when it is needed and not per default at the boot process. Evolution wants access to the keyring for each mail account it wants to retrieve messages from when launched. Still quite annoying to have to type in the password 7 times, since systemd, Evolution, GNOME-keyring or whatever is the real 'culprit' cannot remember that the keyring has already been unlocked.
Je me regarde pour me désoler,
je me compare pour me consoler

Maurice de Talleyrand
Honeyman
Growing Hen
 
Posts: 159
Joined: Sun Apr 08, 2012 2:25
Location: Berlin, Germany

Re: GNOME-Keyring does not accept password anymore

Postby life-on-mars » Fri Jul 26, 2013 6:12

I did an upgrade on one of my machines (involuntarily -- I did only equo i midori, and equo decided to do a full upgrade :roll: ), and the same thing happened to me. The entropy logs show that gnome-keyring was updated.

So it looks like there is something wrong with gnome-keyring 3.8.0 or the way it is upgraded.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖
life-on-mars
Simple Hen
 
Posts: 83
Joined: Fri Jul 12, 2013 14:05


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: marcin32 and 1 guest