Upgrade is running since 3 day and never end!!! [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Fri Jul 12, 2013 9:18

I never run more than one OS in the VM. each machine has 2CPU and 2GB mem and never run together only one machine and in case I need to test on the other I stop the running one and start the needed one, so I am sure this is not the problem. can any one help me please.
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby joost » Fri Jul 12, 2013 9:19

Notice the mirrorsort option!!!
Code: Select all
Linux1 exports # equo repo --help
usage: equo repo [-h]
                 {enable,disable,add,remove,rename,list,mirrorsort,merge} ...

manage repositories

optional arguments:
  -h, --help            show this help message and exit

action:
  manage repositories

  {enable,disable,add,remove,rename,list,mirrorsort,merge}
                        available commands
    enable              enable repositories
    disable             disable repositories
    add                 add a repository
    remove              remove a repository
    rename              rename a repository
    list                list active repositories
    mirrorsort          reorder mirrors basing on response time
    merge               merge content of source repository to destination
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Fri Jul 12, 2013 13:51

well it is exactly the same as in your machine, and I am hanging with the same package since I started the upgrade yesterday
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Fri Jul 12, 2013 13:56

please help, what can I do any idea again I am hanging with equo upgrade --fetch, I need to upgrade 86 package but I hang wit the 13th package, can any of you give me an idea what to do?
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby Stupot » Fri Jul 12, 2013 17:49

Here's what I would do:

Update the repo, upgrade entropy itself, mirrorsort, try the upgrade again
Code: Select all
# equo update
# equo install equo --relaxed
# equo repo mirrorsort sabayon-weekly
#equo upgrade


Can you copy and paste a snippet of the console output when it fails? I'm almost wondering if you're running out of space, although I would assume that would make it stop and not try again over and over.

Does it try from the same mirror each time you are getting disconnected? If so, it's possible to remove that mirror, although after the mirrorsort, it might not be a problem anymore.
Stupot
Sagely Hen
 
Posts: 1549
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Upgrade is running since 3 day and never end!!!

Postby Fitzcarraldo » Fri Jul 12, 2013 17:57

hifnawy, correct me if I'm wrong but you appear not to have understood what joost told you. Have you done the following?

Code: Select all
$ su
Password:  <-- Enter the root user's password here.
# equo repo mirrorsort <repository>

where <repository> is the repository you are using (e.g. sabayonlinux.org or sabayon-weekly). If you don't know which repository you are using, you can find out by using the equo repo list command:

Code: Select all
# equo repo list
>>
>> Entropy is running off a Live System
>> Performance and stability could get severely compromised
>>
* sabayon-weekly
    Sabayon Linux Official Repository

If you have not already done so, please study the SL Wiki article titled Entropy.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7985
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Sat Jul 13, 2013 21:20

thanks, Stupot it looks fine now but I can not say it is working, before it was running from Italy, now it went to the best connectivity in Holland I hope I can make the upgrade.
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Sat Jul 13, 2013 21:35

Dear Fitzcarraldo, you are correct I misunderstood Joost, but now I mad the mirror update and the speed of each mirror was checked and it works now with the fastest mirror, before it was going always to a server in Italy but now it is working with another server and it seems that the packet order has changed too
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Sat Jul 13, 2013 22:38

it is working now I got 33 packets from 86, thanks for your highly appreciated support.
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

Re: Upgrade is running since 3 day and never end!!!

Postby hifnawy » Sun Jul 14, 2013 1:13

hi guys, sorry but it seems that I was happy too early I am hanging again with the packet 37 of 86 app-backup:deja-dup-27.3.1
I think the problem in the repo the mirrors are not updated or not really sync, any idea???
the packet is not available on the servers
hifnawy
Baby Hen
 
Posts: 15
Joined: Wed Jul 10, 2013 22:20

PreviousNext

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron