AltGr no work

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

AltGr no work

Postby violazoli » Sat Jun 22, 2013 5:19

Hi, excuse me for the bad English... I am new Sabayon-user. I installed the "core" variant, and have several small problems. No problem, I solved all - except ONE, the BIGGEST! The AltGr not work. Without this key I cannot use the Sabayon, because I have a Logitech K400 wireless keyboard, and I use it in the hun garian layout. The hungarian language has lot of ascended characters, for example "í, Í" (iacute, Iacute). They are with the Altgr-J pressing and Shift+AltGr-J pressing. But the AltGr not work me... Please help!
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Re: AltGr no work

Postby Fitzcarraldo » Sun Jun 23, 2013 13:02

Which Desktop Environment are you using? If it's KDE, usually app-i18n/ibus is the culprit when this kind of thing happens (see e.g. http://forum.sabayon.org/viewtopic.php?f=86&t=26389). Try:

Code: Select all
equo remove --nodeps --ask app-i18n/ibus
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7983
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: AltGr no work

Postby violazoli » Sun Jun 23, 2013 14:24

Hi, I not use KDE, Gnome, etc. I not like the bloatware desktop environments. The "core" comes to me with Fluxbox, but I think, this is not a fluxbox-problem, because I installed an other window manager, named SithWM (it is very simple/minimal...), and the problem not solved! I think, the problem in the Xorg. I tried it with my own xmodmaprc file jet, copyed from my previous distro (Ubuntu 11.10), in the Ubuntu this own kyboard layout work me very good, with all characters, but under Sabayon it work me not. The "normal" keys work good, but the AltGr-hotkey — not. I verifyed my xmodmaprc file, and this is correct, I was find the iacute and Iacute strings in the correct place. Just the AltGr not work me. I think, my xorg not good configured. AltGr not work me in the LibreOffice, Firefox, in the Urxvt terminal-emulator... Absolutely not work. I am sad, because if this problem not solved, I cannot use the sabayon, this is my very-very big problem, because I am novelist, I NEED and MUST have the hungarian ascended characters! I very like sabayon, yes, but I cannot find solution/solving to this problem. I use since 10 years Linux, I like the commandline, I am not full beginner, but sorry, I am NOT a "profi hacker", just a "power user". And I not know enough good the working method of the X server.
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Re: AltGr no work

Postby Fitzcarraldo » Sun Jun 23, 2013 18:12

Difficult to say, since AltGr works fine on all my machines.

Do you have the file /etc/X11/xorg.conf? Or a file in /etc/X11/xorg.conf.d directory? If you do, please post the contents here.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7983
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: AltGr no work

Postby violazoli » Sun Jun 23, 2013 23:05

My /etc/X11/xorg.conf

excuse me, the forum not enable me the attach...

Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
#    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga0"
    Driver      "intel"
    #BusID    "PCI:00:02"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
#    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device        "SabayonVga0"
    Monitor       "Generic Monitor"
    #Option       "AddARGBGLXVisuals" "true"
    #Option       "RegistryDwords" "EnableBrightnessControl=1"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection


Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "hu"
#        Option "XkbVariant" "complete"
        Option  "XkbOptions" "terminate:ctrl_alt_bksp"
 EndSection

Section "Files"
   FontPath     "/Files/Fonts/Misc/"
   FontPath     "/Files/Fonts/TrueType/"
   FontPath     "/Files/Fonts/OTF"
   FontPath     "/Files/Fonts/Type1/"
   FontPath     "/Files/Fonts/100dpi/"
   FontPath     "/Files/Fonts/75dpi/"
EndSection


Moderator edit: Added Code tags. Please use the Code button when posting lengthy console output or files.
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Re: AltGr no work

Postby violazoli » Sun Jun 23, 2013 23:07

And, I have this line in the xorg.conf

Option "XkbOptions" "terminate:ctrl_alt_bksp"

but the ctrl-alt-backspace not work, sorry!
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Re: AltGr no work

Postby Fitzcarraldo » Sun Jun 23, 2013 23:22

Comment out the XkbOptions line for the time being.

Try adding the following:

Code: Select all
Option "XkbVariant" "altgr-intl"
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7983
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: AltGr no work

Postby violazoli » Mon Jun 24, 2013 0:07

I tryed it, but no help. If I not use my own xmodmaprc file, the keyboard layout the english, and the AltGr no work. If I use my own xmodmaprc file (xmodmap .xmodmaprc line in the .xinitrc file) then the keyboard layout ALMOST good for my, almost the hungarian (with my special/preferred changes), but the AltGr not work. (Under Ubuntu it work good, of course, therefore this is not hardware error). I not understand... I have the "Option "XkbLayout" "hu"" line in the xorg.conf and the layout not hungarian... Okay, under the non-graphical terminals I have the english layout, okay, thats no problem for me. But under X?! In Firefox, and terminalemulators?! Maybe the X-server not find the hungarian layout?

Please see this:

cat Xorg.0.log | grep EE

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 232.067] Initializing built-in extension MIT-SCREEN-SAVER
[ 232.406] (EE) Error loading keymap /tmp/server-0.xkm


[ 232.406] (EE) XKB: Failed to load keymap. Loading default keymap instead.
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Re: AltGr no work

Postby Fitzcarraldo » Mon Jun 24, 2013 10:55

Perhaps you have not got the locale set up correctly. Follow the instructions in the section Locale system in the Gentoo Linux Localization Guide.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7983
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: AltGr no work

Postby violazoli » Mon Jun 24, 2013 13:49

I do the tips in the localization guide. Now under/in the CONSOLE I have the hungarian characters, and the AltGr work good. But, sorry, under X, in Firefox or terminalemulators - not. Under X, I have the english (US) keyboard layout. Or if I use my own layout in the .xmodmaprc, the AltGr not work.

Of course, after the settings I run the locale-gen and
env-update && source /etc/profile
commands.

My settings.

[email protected] ~ $ xmodmap
xmodmap: up to 4 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x69)
mod1 Alt_L (0x40), Alt_R (0x6c), Meta_L (0xcd)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_L (0x85), Super_R (0x86), Super_L (0xce), Hyper_L (0xcf)
mod5 ISO_Level3_Shift (0x5c), Mode_switch (0xcb)


From my xorg.conf.
Section "ServerLayout"
Identifier "Main Layout"
Screen 0 "Screen 0"
EndSection

Section "Extensions"
#Option "Composite" "Enable"
EndSection


Section "InputClass"
Identifier "keyboard"
MatchIsKeyboard "yes"
Option "XkbLayout" "hu"
Option "XkbModel" "pc104"
Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "terminate:ctrl_alt_bksp"

EndSection


[email protected] /etc/X11 $ locale
LANG=hu_HU.UTF-8
LC_CTYPE=hu_HU.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=hu_HU.UTF-8
LC_COLLATE="hu_HU.UTF-8"
LC_MONETARY="hu_HU.UTF-8"
LC_MESSAGES=hu_HU.UTF-8
LC_PAPER=hu_HU.UTF-8
LC_NAME="hu_HU.UTF-8"
LC_ADDRESS="hu_HU.UTF-8"
LC_TELEPHONE="hu_HU.UTF-8"
LC_MEASUREMENT="hu_HU.UTF-8"
LC_IDENTIFICATION="hu_HU.UTF-8"
LC_ALL=

From the /etc/make.conf

LINGUAS="en en_US hu"
violazoli
Simple Hen
 
Posts: 40
Joined: Tue Jun 18, 2013 0:02

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest