Firefox font glitches [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Firefox font glitches [Solved]

Postby vedg » Wed May 29, 2013 15:08

Hi everyone,

I installed Sabayon 13.04 XFCE on my PC recently and was able to configure everything as I like it, except for fixing an awful Firefox fonts problem.

The problem: sometimes a few lines of text on web-page are displayed with bold font. When I zoom in or select text, fonts are back to normal. Also the font doesn't just become bold, but also distorted, unreadable. See screenshots:
http://s24.postimg.org/wm412s81h/glitch.png
http://s21.postimg.org/xjemtk4gn/clear.png
http://s7.postimg.org/x8wxma3jf/glitch2.png
http://s18.postimg.org/sywyt8r8p/clear2.png

All software is up to date, including kernel (enabled repository - sabayon-weekly).
Detailed system information:
1. I tried to reproduce this problem in Midori and failed.
2. PC specs:
1) graphic card: NVidia GeForce GTS 250/PCIe/SSE2.
2) monitor: Samsung SyncMaster 1680x1050.
3. Kernel: linux-3.9.0-sabayon.
4. eselect-ed graphic driver: nvidia(x11-drivers/nvidia-drivers-313.30#3.9.0-sabayon).
5. Software versions: XFCE 4.10, Firefox 20.0.1.
6. Settings->Appearance->Fonts:
1) Default font: Sans, 12.
2) Enable anti-aliasing = true.
3) Hinting: Slight (problem also occurred with Full hinting).
4) Sub-pixel order RGB (verified on http://www.lagom.nl/lcd-test/ ).
5) Custom DPI setting: 96 (problem exists with this turned off too).
7. Firefox->Preferences->Content:
1) Default font Arial, 18 (problem exists with DejaVu Sans, Serif too).
2) Detailed settings (screenshots):
http://s21.postimg.org/stxvwfs7r/Firefo ... _Fonts.png
http://s24.postimg.org/xndgje3sl/Firefo ... Colors.png

Has anyone else experienced similar problems?
How can this problem be solved?
Thanks in advance.
Last edited by vedg on Sun Jul 21, 2013 18:48, edited 1 time in total.
vedg
Baby Hen
 
Posts: 12
Joined: Wed May 29, 2013 12:25
Location: Ukraine

Re: Firefox font glitches

Postby jreveles » Fri May 31, 2013 2:50

Thanks for posting this!!. I have exactly the same problem and have been looking for a fix. So I would be glad to read someone's fix if there's anyone.

Thanks
jreveles
Baby Hen
 
Posts: 3
Joined: Fri May 31, 2013 2:47

Re: Firefox font glitches

Postby jreveles » Fri May 31, 2013 3:02

BTW, the only differences I have with your setup is this:

-- Latest KDE (4.10.3)
-- Kernel: latest 3.8
-- graphic card: Intel

All the rest is the same, I have enven tried the same settings changes, but nothing fixes it.
jreveles
Baby Hen
 
Posts: 3
Joined: Fri May 31, 2013 2:47

Re: Firefox font glitches

Postby ASX » Sat Jun 01, 2013 15:34

Hi ,

I'm experiencing a similar behavior on my kde installation, and in my case is not limited to Firefox, in fact the same glitch sometimes appeared in Thundherbird, Claw-Mail, Konsole ...

Additionally, as I'm using Sabayon from only 5 months, it was visible also visible on a different KDE distro I was using previously.

I have also noticed that, when the glitch appear out, if I open a new window (i.e. starting a new app) the screen get redrawn and the glitch disappear.

The above suggest that the issue is somewhat system-wide, not distro specific, and not related to a specific application or a specific DE, possibly related to Xorg itself, or part of it, like the antialiasing features.

Disabling the antialiasing subpixel rendering, seems to attenuate the problem ...

That's all for now. Looking forward for your confirmation about being the same issue or not.
ASX
Baby Hen
 
Posts: 7
Joined: Thu May 30, 2013 19:10

Re: Firefox font glitches

Postby vedg » Sat Jun 01, 2013 18:51

I tried disabling anti-aliasing in Settings->Appearance->Fonts.
The result: system fonts became much thinner - almost not readable.
I proceeded then and tested Firefox (I didn't notice any font change in it); I was able to get a glitch in a 3 minutes.

It seems that system font settings do not affect Firefox at all.

There is no anti-aliasing option in Firefox settings.

I didn't notice this glitch in any other application (I use KDevelop and kdesvn regularly).
I never noticed this glitch in any other distro (I used only Ubuntu, Mint, Debian).
vedg
Baby Hen
 
Posts: 12
Joined: Wed May 29, 2013 12:25
Location: Ukraine

Re: Firefox font glitches

Postby ASX » Sat Jun 01, 2013 19:55

Below an example of the glitch from Thunderbird, while I can't assert it is the same issue, look like very similar.

Image
ASX
Baby Hen
 
Posts: 7
Joined: Thu May 30, 2013 19:10

Re: Firefox font glitches

Postby vedg » Sun Jun 02, 2013 8:44

I confirm that opening maximized window makes the glitch disappear.
Opening small window and dragging it over the glitch doesn't help. After maximizing and minimizing it - glitch disappears.

ASX wrote:Below an example of the glitch from Thunderbird, while I can't assert it is the same issue, look like very similar.

Looks like this is the same glitch. But, as I said, I didn't notice it anywhere, but in Firefox in Sabayon.

My guesses:
1) it is specific to a few apps (Firefox, Thundherbird, Claw-Mail, Konsole ... ), from which I use only Firefox;

2) it is specific for some group of distros (maybe gentoo-like or {not debian});
in which distros have you noticed it?

3) maybe it is specific for some settings / software versions / hardware (or combination of those), which explains that there is no info about it in the Internet.
vedg
Baby Hen
 
Posts: 12
Joined: Wed May 29, 2013 12:25
Location: Ukraine


Re: Firefox font glitches

Postby apaz » Mon Jun 10, 2013 17:32

Try this:
firefox ---> about:config -->search bar: "azure"
change "false" with "true" in:

gfx.content.azure.enabled

Andrea
apaz
Simple Hen
 
Posts: 81
Joined: Wed Apr 07, 2010 19:04

Re: Firefox font glitches

Postby vedg » Mon Jun 10, 2013 18:23

First of all: thanks for replies.

>change "false" with "true" in:
>gfx.content.azure.enabled
Not only this doesn't eliminate the problem, it also makes browser unstable - it crashes often.

As for the link, provided by Fitzcarraldo:
https://bugs.gentoo.org/show_bug.cgi?id=454252
The best proposed solution is to recompile Firefox with some flags ( mozconfig_annotate '' --disable-system-cairo ).

Also this bug seems to be fixed upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=722975

If I would have enough time, I might bother with recompiling.
If not - I'd just wait for fix to be delivered by Firefox update.

I believe that I should mark this problem as solved after appearance of fixed Firefox version in Sabayon's repository.
vedg
Baby Hen
 
Posts: 12
Joined: Wed May 29, 2013 12:25
Location: Ukraine

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron