File sharing with Samba

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

File sharing with Samba

Postby rmcellig » Sat May 11, 2013 2:00

I am totally new to Sabayon and the Gentoo way of computing. I have used Ubuntu, and Arch based distros as well as Puppy Linux. One of the things I need to do is share files and folders using Samba.

When I was using Ubuntu, there was a great GUI tool called system-config-samba. Is there a similar GUI tool for Sabayon? If not, is it pretty straight forward setting up file sharing? I'm using the latest xfce Sabayon flavor.
rmcellig
Baby Hen
 
Posts: 8
Joined: Sat May 11, 2013 1:45

Re: File sharing with Samba

Postby wolfden » Sat May 11, 2013 10:34

don't look like it, but http://wiki.sabayon.org/index.php?title ... amba_Share probably a good start
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: File sharing with Samba

Postby rmcellig » Sat May 11, 2013 12:06

Thanks!

I took a look at the document you recomended. In it it says that if you right mouse click on a folder, go to properties that you can share a folder that way:

Now add your shared folders either GUI or by direct paths in smb.conf. By GUI, select your folder -> Properties -> Sharing and set it up there.

I don't see any option to share when I do this.
rmcellig
Baby Hen
 
Posts: 8
Joined: Sat May 11, 2013 1:45

Re: File sharing with Samba

Postby rmcellig » Sat May 11, 2013 13:47

OK. I think I am making progress. I installed the thunar shares option . I do have Samba installed and I did restart my machine.

"You may need to install Samba. Check your user permissions (usershare group) and re-login"

What does this mean? Like I said I have Samba installed.
rmcellig
Baby Hen
 
Posts: 8
Joined: Sat May 11, 2013 1:45

Re: File sharing with Samba

Postby Ryuno-Ki » Sat May 11, 2013 14:35

rmcellig wrote:"You may need to install Samba. Check your user permissions (usershare group) and re-login"

What does this mean? Like I said I have Samba installed.


There should be a group samba or share or so ...
See http://wiki.sabayon.org/index.php?title ... ging_Users
(Not running Linux right now)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: File sharing with Samba

Postby Fitzcarraldo » Thu May 16, 2013 21:00

rmcellig wrote:OK. I think I am making progress. I installed the thunar shares option . I do have Samba installed and I did restart my machine.

"You may need to install Samba. Check your user permissions (usershare group) and re-login"

What does this mean? Like I said I have Samba installed.

Samba is a major pain in the neck. I've been battling it since 2006. The trouble is, every blog and forum post -- including my posts in these forums -- suggest different fixes that work for a while and then stop for some reason. Anyway, what did you do in /etc/samba/smb.conf? See the instructions in the following Xfce Wiki post to set it up: thunar-shares-plugin. Mind you, the last time that article was modified was in February 2009, and the Linux Samba software has been through several revisions since then. Anyway, give it a try.

I came across a very good Samba tutorial on the Web by an Ubuntu user: SAMBA_V1-1.pdf. He doesn't use 'security = share' on the target Linux machine(s); he uses 'security = user'. Read his tutorial, but my understanding is that it means you have to set up a Samba user on the target Linux machine who corresponds to an existing Linux user on that machine, and you access the remote share by supplying a user name and password when prompted. This is the secure and recommended way to do it (I think 'security = share' may even be deprecated in the latest version of Samba). If the target machine is a Windows machine, you would have to enter when prompted the user name of a Windows user of the target machine (depending on how you have set up the share on the Windows machine, since you may have just set up the Windows machine to have a public shared folder not requiring a password). But have a look through his tutorial. Then you can explain it to me!
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: File sharing with Samba

Postby rmcellig » Fri May 17, 2013 0:27

This worked for me. To start or stop the samba server:
sudo /etc/init.d/samba start
sudo /etc/init.d/samba stop

To set up a samba user. This example uses my name

sudo smbpasswd -a randy

This is what my smb.conf file looks like. I made it very simple. The server string can be anything you like. Try to keep the name as short as possible. You can see the one share I have is desktop. Again, keep the name short and make sure that every share name is different. Hope this helps. Worked for me and it is very easy. To test if you have everything set up properly. In the terminal type sudo testparm.

Code: Select all
[email protected] ~ $ sudo testparm
Password:
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[desktop]"
Processing section "[printers]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
   server string = sabayon
   map to guest = Bad Password
   printcap name = cups
   idmap config * : backend = tdb

[desktop]
   path = /home/randy/Desktop/
   read only = No

[printers]
   comment = All Printers
   path = /var/spool/samba
   guest ok = Yes
   printable = Yes
   print ok = Yes
   browseable = No
rmcellig
Baby Hen
 
Posts: 8
Joined: Sat May 11, 2013 1:45


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron