wlan and ethernet not working after installation [Solved]

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

Re: wlan and ethernet not working after installation

Postby Fitzcarraldo » Sun May 12, 2013 10:21

To automate the process at each boot, create a file /etc/local.d/01ethernet.start containing the following lines:

Code: Select all
#!/bin/bash
# Force the broadcom module to be loaded before the tg3 module:
rmmod tg3 && modprobe broadcom && modprobe tg3

and make it executable:

Code: Select all
# chmod +x /etc/local.d/01ethernet.start

(N.B. The above assumes you are using OpenRC, not systemd.)
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wlan and ethernet not working after installation [Solved

Postby bennypr0fane » Sun May 12, 2013 14:53

Thank you, everything works now!
I'm thinking if we're gonna have this topic in a specialised subforum, we might as well move the complete thread (not just the ethernet part) to networking. It seemed a good place to me here because this is one of the typical issues that frequently come up after first installing a new distro. However, moderators please decide about the right place as you see fit.
bennypr0fane
Baby Hen
 
Posts: 14
Joined: Fri May 10, 2013 11:23

Re: wlan and ethernet not working after installation [Solved

Postby Fitzcarraldo » Sun May 12, 2013 16:37

Good to know. Moving the thread to the 'Networking and Wireless' shed (forum), as it is more appropriate.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: wlan and ethernet not working after installation

Postby marc-andre » Sat Jun 01, 2013 0:16

Hi,

Fitzcarraldo wrote:(N.B. The above assumes you are using OpenRC, not systemd.)


And how to automate it if using systemd? If by any chance someone knows...

Thanks in advance!
marc-andre
Baby Hen
 
Posts: 1
Joined: Sat Jun 01, 2013 0:13

Previous

Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest