XBMC crashing [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

XBMC crashing [Solved]

Postby nickdanger » Wed May 01, 2013 5:08

After many successful uses of XBMC, it is now crashing. Maybe "abnormal termination" is a better description. The XBMC starts as expected, and navigation is normal. When I play either a video or a sound file (mp3) the file loads and starts playing. After about three minutes, the program exits, and returns me to a normal desktop. The system is not "locked up" and all other programs run as expected after XBMC exits. I can restart XBMC, select a file, and repeat the cycle all over without re-booting the PC. The crash log is long so I will only paste the end, which should be where the problem is recorded.

Code: Select all
############## XBMC CRASH LOG ###############
################ SYSTEM INFO ################
 Date: Tue Apr 30 20:17:24 MDT 2013
 XBMC Options:
 Arch: x86_64
 Kernel: Linux 3.8.0-sabayon #1 SMP Sat Apr 27 18:24:29 UTC 2013
 Release:
    LSB Version:   n/a
    Distributor ID:   Sabayon
    Description:   Sabayon Linux amd64 13.04
    Release:   n/a
    Codename:   n/a
############## END SYSTEM INFO ##############
################# LOG FILE ##################
02:12:11 T:140015621031872   ERROR: GLX: Same window as before, refreshing context
02:12:11 T:140015621031872  NOTICE: Running database version Addons15
02:12:11 T:140015621031872  NOTICE: Running database version ViewModes4
02:12:11 T:140015621031872  NOTICE: Running database version Textures13
02:12:12 T:140015621031872  NOTICE: Running database version MyMusic32
02:12:12 T:140015621031872  NOTICE: Running database version MyVideos75
02:12:12 T:140015621031872  NOTICE: Running database version TV22
02:12:12 T:140015621031872  NOTICE: Running database version Epg7
02:12:12 T:140015621031872  NOTICE: start dvd mediatype detection
02:12:12 T:140015621031872  NOTICE: initializing playlistplayer
02:12:12 T:140015621031872  NOTICE: DONE initializing playlistplayer
02:12:12 T:140015622510336  NOTICE: Thread CDetectDVDMedia start, auto delete: false
02:12:12 T:140015302678272  NOTICE: Thread XBPyThread start, auto delete: false
02:12:12 T:140015621031872  NOTICE: UpdateLibraries - Starting video library startup scan
02:12:12 T:140015294285568  NOTICE: Thread CVideoInfoScanner start, auto delete: false
02:12:12 T:140015621031872  NOTICE: initialize done
02:12:12 T:140015621031872  NOTICE: Running the application...
02:12:12 T:140015285892864  NOTICE: Thread XBPyThread start, auto delete: false
02:12:12 T:140015302678272  NOTICE: -->Python Interpreter Initialized<--
02:12:12 T:140015285892864  NOTICE: -->Python Interpreter Initialized<--
02:12:12 T:140015103026944  NOTICE: Thread Jobworker start, auto delete: true
02:12:12 T:140015621031872  NOTICE: ES: Starting event server
02:12:12 T:140015094634240  NOTICE: Thread CEventServer start, auto delete: false
02:12:12 T:140015094634240  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
02:12:12 T:140015094634240  NOTICE: UDP: Listening on port 9777
02:12:12 T:140015086241536  NOTICE: Thread CTCPServer start, auto delete: false
02:12:12 T:140015621031872  NOTICE: starting zeroconf publishing
02:12:12 T:140014591670016  NOTICE: Thread Jobworker start, auto delete: true
02:12:12 T:140015294285568  NOTICE: VideoInfoScanner: Starting scan ..
02:12:13 T:140015622510336  NOTICE: Thread CRssReader start, auto delete: false
02:12:13 T:140015294285568  NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:00
02:12:13 T:140015302678272  NOTICE: Thread Jobworker start, auto delete: true
02:12:13 T:140015285892864  NOTICE:  StorageServer Module loaded RUN
02:12:13 T:140015285892864  NOTICE: StorageClient-2.5.0 Starting server
02:12:13 T:140015285892864  NOTICE: StorageServer-2.5.0 Storage Server starting /home/nd/.xbmc/userdata/addon_data/script.common.plugin.cache/commoncache.db
02:12:13 T:140015294285568  NOTICE: Thread CFileCache start, auto delete: false
02:12:15 T:140015294285568  NOTICE: Thread Background Loader start, auto delete: false
02:12:42 T:140015621031872  NOTICE: Previous line repeats 4 times.
02:12:42 T:140015621031872   ERROR: Control 50 in window 10501 has been asked to focus, but it can't
02:12:54 T:140015294285568  NOTICE: Thread Background Loader start, auto delete: false
02:13:01 T:140015294285568  NOTICE: Thread CFileCache start, auto delete: false
02:13:01 T:140014576932608  NOTICE: Thread PAPlayer start, auto delete: false
02:13:01 T:140015330027264 WARNING: PulseAudio: Stream underflow
02:13:03 T:140014568539904 WARNING: Previous line repeats 2 times.
02:13:03 T:140014568539904  NOTICE: Thread Background Loader start, auto delete: false
02:13:03 T:140015330027264  NOTICE: Previous line repeats 1 times.
02:13:03 T:140015330027264 WARNING: PulseAudio: Stream underflow
02:17:18 T:140015103026944 WARNING: Previous line repeats 602 times.
02:17:18 T:140015103026944  NOTICE: Thread CFileCache start, auto delete: false
02:17:19 T:140015330027264 WARNING: PulseAudio: Stream underflow
02:17:24 T:140015294285568 WARNING: Previous line repeats 23 times.
02:17:24 T:140015294285568  NOTICE: Thread Jobworker start, auto delete: true
############ END XBMC CRASH LOG #############


I am using the HDMI output of my ATI 7850 video card for both the graphics monitor, and the sound system. I have installed all updates to this date.

Summary:
Computer
Processor 4x AMD Phenom(tm) 9600 Quad-Core Processor 2300 mhz
Memory 4047MB (565MB used)
Free Memory 3168628 kB
Buffers 53816 kB
Free Virtual Memory 6160380 kB
KernelStack 3344 kB
Machine Type Physical machine
Operating System Sabayon Linux amd64 13.04
Kernel Linux 3.8.0-sabayon (x86_64)
Version #1 SMP Sat Apr 27 18:24:29 UTC 2013
C Library GNU C Library version 2.15 (stable)
Display Resolution 1680x1050 pixels
OpenGL Renderer AMD Radeon HD 7800 Series
X11 Vendor The X.Org Foundation Version 1.13.3
Audio Adapter
Advanced Micro Devices [AMD] nee ATI Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]

Any ideas about what I should try?
Thank You.
N.D.
Last edited by nickdanger on Sat May 04, 2013 21:47, edited 1 time in total.
nickdanger
Simple Hen
 
Posts: 89
Joined: Mon Aug 10, 2009 4:02

Re: XBMC crashing

Postby Fitzcarraldo » Fri May 03, 2013 22:57

Looks like it might be a problem with PulseAudio. Try disabling PulseAudio as explained in the following post, to see if it has an effect: Re: XBMC crashes upon playing next item in playlist.

P.S. Please use the Code button when posting console output. I've added Code tags to the XBMC crash log output in your post.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: XBMC crashing

Postby nickdanger » Sat May 04, 2013 17:19

Ok, I will try disabling PulseAudio. PulseAudio does give a good GUI for detecting and selecting the HDMI sound. I used Alsa on another system, and it was very rudimentary. There were a lot of "phantom" devices listed, and I think maybe each was one channel of the 7.1 channel audio output.
Thank You!
N.D.
nickdanger
Simple Hen
 
Posts: 89
Joined: Mon Aug 10, 2009 4:02

Re: XBMC crashing

Postby nickdanger » Sat May 04, 2013 20:54

Yes, disabling PulseAudio did fix the problem with XBMC exiting at the start of a new file. Unfortunately, I now have two more problems that were not there before. The first is a very odd "staccato" audio, that sounds like what I used to get in Microsoft Windows when the interrupts conflicted. The second is that XBMC now hangs when I shut it down. Hard lockup, no cursor movement, so I drop down to console, become SU and reboot to get out of XBMC. I am using the ATI proprietary video card drivers, which I only mention because the audio is coming from the ATI card HDMI output. When I try to play the same files in Movie Player I get an error, "Configured audiosink audiosinkbin is not working."

UPDATE: I re-enabled PulseAudio to see if disabling it really did cause the problems I described above. The result was: 1. Audio as smooth as a baby's bottom 2. XBMC can be shutdown as expected 3. No more errors in Movie Player. Obviously some fiendishly complicated interaction between PulseAudio, XBMC, and most likely the ATI (AMD) Catalyst proprietary video (& HDMI audio) drivers. When PulseAudio is enabled the opengl visualizations in XBMC do not work correctly, but they do work when it is disabled. I am leaving the PulseAudio enabled because I am worse without it, and I do not need the opengl visualizations in XBMC. The problem with the abnormal termination at the beginning of the next audio file, can be solved by enabling a one second crossfade in the XBMC settings. At least that is working for me so far. The adverse software interactions will eventually be solved upstream, or possibly when the ATI Radeon open source video drivers catch up with my AMD "Pitcairn" series video card. I think the Dev's are still working on the "Southern Islands" generation currently, and when I try to use them, I get severe frame buffer problems (flashing, and jumping, or black screens) so for now I must use the proprietary Catalyst drivers, which I think play a big part in the software conflicts. I believe none of this is related directly to the distro, but thank you for putting me on the right track!
nickdanger
Simple Hen
 
Posts: 89
Joined: Mon Aug 10, 2009 4:02


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest