Sabayon KDE ignoring newly installed games in menu. [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 4
Joined: Sun Apr 14, 2013 4:43

Sabayon KDE ignoring newly installed games in menu. [Solved]

Post by Dreyeth » Sat Apr 27, 2013 2:27

Been hunting around for the cause of this issue for awhile, it was present right after installation
of Sabayon 11 and still present after being fully updated to the latest packages.

All partitions were formatted for a fresh clean install, happened on two different installations,
first time updates wheren't performed cleanly, second time followed to the letter on updating
immediately after install.

After installation of a game that does install menu entries into [Applications -> Games]
but not the sub directories like [Games -> Arcade] would be completely igonored even
though doing a menu search would find their entry with the correct icons.

Right clicking on the KDE launcher and selecting edit applications and opening KDE Menu Editor
clicking [Edit -> Restore to System Menu] fixes the issue, though careful this will nuke any
manual customizations you've made to the menu entries.

This took me awhile to find, and several hours of grief trying to figure out what was wrong on my own,
before finding a post talking about the menu restore feature.

Pretty sure this from the stock Sabayon installation image and all the way to updated to current,
so figured I'd post it since everyone using a KDE edition probable has this problem.

And the first thing a newbie ^^ is going to do is see whats in the games repositories (like Steam)
and wonder why they have no menu entries for anything they installed.

The original post is @ ... 9&t=127650

Post Reply