Can't install Sabayon version >=11 [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Can't install Sabayon version >=11 [Solved]

Postby mrizzone » Thu Apr 18, 2013 15:06

Hello! I have an AMD 64. Until Sabayon 10 all versions work fine, but 11 and 13.4 give the same error, a terminal screen with an error message who tells something about "don't screen available" or something. Any clue? Thanks!
Last edited by mrizzone on Wed Apr 24, 2013 15:44, edited 1 time in total.
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56

Re: Can't install Sabayon version >=11

Postby Stupot » Thu Apr 18, 2013 17:15

Please be more specific. Give us the exact error and tell us what sort of hardware you are running this on. Nobody will be able to give you the fix with the information you provided.
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Can't install Sabayon version >=11

Postby mrizzone » Thu Apr 18, 2013 19:03

I have this message in a terminal screen:

Code: Select all
Welcome to Sabayon Linux 13.4 x86 GNOME
AMD Athlon(TM) 64x2 Dual Core Processor 5000+

locahost root#


OK, when I type

Code: Select all
startx


i have a long list of things which ends with:

Code: Select all
Fatal server error
no screens found (EE)
xinit: unable to connect to server
connection refused
xinit: server error.
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56

Re: Can't install Sabayon version >=11

Postby dave_64 » Thu Apr 18, 2013 19:19

If you have an old nvidia card, you may need to install an older video driver, which is not difficult at all. It seems you have installed sabayon 11, but I can't tell for sure. Are you getting to the terminal from the live dvd? Or, is that from an installed sabayon? Is the command prompt from a graphical terminal? Or is it a full screen black background terminal (which is called a console...I think).
What is your video card? If you don't know, you can get the make and model from the command prompt with this command:
lspci

Look for something like this, which is what mine shows in the VGA line:
01:00.0 VGA compatible controller: NVIDIA Corporation GT215 [GeForce GT 240] (rev a2)
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Can't install Sabayon version >=11

Postby mrizzone » Thu Apr 18, 2013 19:57

I have installed Sabayon 10, and have this screen from a Sabayon 13.4 live DVD, in blank screen, not a graphical interfase.

the command lspci give me these response:

Code: Select all
localhost juan # lspci
00:00.0 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: NVIDIA Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP61 USB 1.1 Controller (rev a3)
00:02.1 USB controller: NVIDIA Corporation MCP61 USB 2.0 Controller (rev a3)
00:04.0 PCI bridge: NVIDIA Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: NVIDIA Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56

Re: Can't install Sabayon version >=11

Postby dave_64 » Thu Apr 18, 2013 20:32

I don't know what sabayon that is. Last time I checked, the most recent sabayon is version 11. Are you sure that's a sabayon? Ubuntu's latest offering is 13.04. In any case, you have a 6150 nvidia card, and you need older drivers for that card. This situation came up when the 3.6 kernel came into play, if I remember correctly. I don't know how to advise you, but if it was me, I would either install and upgrade a version 10, or try to install 11 if you can. After installing it, you would probably have to install the older drivers. From a root prompt:
equo install nvidia-drivers-304.64#$(uname -r) --ask
You should get a graphical interface when you reboot. To make it permanent would require another step.
There may be a better way to handle it, but I know you have to deal with the driver situation at some point.
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Can't install Sabayon version >=11

Postby Stupot » Thu Apr 18, 2013 21:20

dave_64, Sabayon started rolling out monthly releases automatically. http://sabayon.org/article/what%E2%80%9 ... %80%99-bbq
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Can't install Sabayon version >=11

Postby dave_64 » Thu Apr 18, 2013 22:05

Ok, yeah, I see that now...thanks for the info, Stupot.
I recently installed version 11 on a computer with an old video card (nvidia 7300), and had no trouble getting a graphical interface from the livedvd. After installing version 11, I switched to the older driver as shown above. I am surprised that you can not get a graphical interface from the livedvd of version 11. With my limited knowledge and experience, I would probably install version 10, upgrade it, and change those drivers as shown above. Maybe somebody else can help you install 13.4...maybe there is some parameter you can add at bootup that will get you to a graphical interface so that you can install it from there.
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Can't install Sabayon version >=11

Postby Ryuno-Ki » Thu Apr 18, 2013 23:11

I'd rather install the old nvidia drivers and mask the new ones before upgrading if I were you ;-)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Can't install Sabayon version >=11

Postby mrizzone » Thu Apr 18, 2013 23:39

I'm a newbie looking for support and technical ads. How I can install the old drivers? Thanks
mrizzone
Simple Hen
 
Posts: 96
Joined: Sun Feb 10, 2013 23:56

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests