UEFI Dual Boot

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

UEFI Dual Boot

Postby darkreaper476 » Mon Feb 25, 2013 7:25

So I had the balls to attempt to install a linux distro on my Samsung laptop that is susceptible to brick from the samsung-module. I choose Sabayon because I've used it before , its simple, and has UEFI support now, I thought. I installed Sabayon on what was my win8 recovery partition at the end of the disc. During the installation, when I was asked to install the boot loader, it didn't ask for UEFI, just bios. So I chose to install it on "SDA5" which is the last partition on the HDD, I know that MBR partition booting likes to be up front but I didn't want to destroy my UEFI partition and I read that UEFI can boot to bios/MBR partition. It does nothing. It boots right into win8, no grub prompt, nothing.

Any help would be great, I'd love to get linux up again. THANKS
darkreaper476
Baby Hen
 
Posts: 10
Joined: Sat Apr 10, 2010 8:01

Re: UEFI Dual Boot

Postby darkreaper476 » Tue Feb 26, 2013 5:39

OH SNAP!! Well I just realized that I downloaded, burned, and installed Sabayon 10!!!! I THOUGHT IT WAS 11 I SWEAR!!

Well I'm going to try 11 after I have it burned it, hopefully it wont brick my system! :D
darkreaper476
Baby Hen
 
Posts: 10
Joined: Sat Apr 10, 2010 8:01

Re: UEFI Dual Boot

Postby darkreaper476 » Tue Feb 26, 2013 19:35

Well I burned 11 and it wont boot, I tested it on another computer and it booted just fine. It takes me straight to a grub console on my laptop... Guess I have to try another distro... I so don't want a mint....
darkreaper476
Baby Hen
 
Posts: 10
Joined: Sat Apr 10, 2010 8:01

Re: UEFI Dual Boot

Postby sgunhouse » Tue Feb 26, 2013 22:28

Same issue here, on a UEFI/SecureBoot system (Windows 8 laptop) I get stuck on a grub prompt, while on an older system it boots just fine.
sgunhouse
Baby Hen
 
Posts: 3
Joined: Tue Sep 25, 2007 23:08

Re: UEFI Dual Boot

Postby Ryuno-Ki » Wed Feb 27, 2013 21:12

I asked lxnay today.
He'll spend an eye on UEFI next week. Too much to do at the moment.
The proper way would be filling a bug report on Sabayon's bugzilla by the way.
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: UEFI Dual Boot

Postby sgunhouse » Tue Mar 05, 2013 6:50

Personally, was hoping someone had a solution - what to type at the prompt to get it to boot.
sgunhouse
Baby Hen
 
Posts: 3
Joined: Tue Sep 25, 2007 23:08


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest