Unable to get ati-drivers to work in sabayon 11 [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Unable to get ati-drivers to work in sabayon 11 [Solved]

Postby sharkwouter » Sat Feb 16, 2013 23:34

Here is what I did to install the drivers:
I installed Sabayon 11, the kernel-sources and the ati-drivers
ran aticonfig --initial
added quiet splash nomodeset to grub 2
rebooted

What happened next is that my entire system freezes after the splash screen. If I disable the splash screen it will still freeze. I am unable to enter any of the tty's while it's frozen, the only thing I can do is reset the machine.

Has anyone gotten the ati-drivers-13.1 to work on the 3.7 kernel that comes with sabayon 11 x64? My graphics card is an amd hd 7850 btw.
Last edited by sharkwouter on Sun Feb 17, 2013 18:56, edited 1 time in total.
sharkwouter
Baby Hen
 
Posts: 4
Joined: Sat Feb 16, 2013 23:26

Re: Unable to get ati-drivers to work in sabayon 11

Postby Provia » Sun Feb 17, 2013 0:57

You have installed the drivers from sabayon repo?

The Sabayon 11 live DVD don't already enable the proprietary ati driver?
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Unable to get ati-drivers to work in sabayon 11

Postby sharkwouter » Sun Feb 17, 2013 1:10

Provia wrote:You have installed the drivers from sabayon repo?

The Sabayon 11 live DVD don't already enable the proprietary ati driver?

Yes I got them from the repo. By default I had no 3d acceleration, gnome launched in fallback mode.
sharkwouter
Baby Hen
 
Posts: 4
Joined: Sat Feb 16, 2013 23:26

Re: Unable to get ati-drivers to work in sabayon 11

Postby Provia » Sun Feb 17, 2013 10:48

Ok, i've seen you have missed a step. After driver installation and aticonfig set opengl rendering on ati prop. drivers. Type in console or in recovery mode

Code: Select all
sudo eselect opengl set ati


Then say to me if it work :)
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Unable to get ati-drivers to work in sabayon 11

Postby sharkwouter » Sun Feb 17, 2013 11:53

That did the trick, thanks a lot.
I am on kernel 3.5 atm tho, but I got the same issue. I should try it with 3.7 later.
sharkwouter
Baby Hen
 
Posts: 4
Joined: Sat Feb 16, 2013 23:26

Re: Unable to get ati-drivers to work in sabayon 11

Postby Provia » Sun Feb 17, 2013 11:56

sharkwouter wrote:That did the trick, thanks a lot.
I am on kernel 3.5 atm tho, but I got the same issue. I should try it with 3.7 later.


I don't understand, you have solved the problem or not?
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Unable to get ati-drivers to work in sabayon 11

Postby sharkwouter » Sun Feb 17, 2013 15:50

Provia wrote:
sharkwouter wrote:That did the trick, thanks a lot.
I am on kernel 3.5 atm tho, but I got the same issue. I should try it with 3.7 later.


I don't understand, you have solved the problem or not?

Ye it's fixed, it also worked with the default kernel.
sharkwouter
Baby Hen
 
Posts: 4
Joined: Sat Feb 16, 2013 23:26

Re: Unable to get ati-drivers to work in sabayon 11

Postby Provia » Sun Feb 17, 2013 15:56

Perfect!
Please put a [solved] at the end of the topic title.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests