equo upgrade showing error

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

lemon09
Baby Hen
Posts: 18
Joined: Thu Feb 14, 2013 10:00

equo upgrade showing error

Post by lemon09 » Thu Feb 14, 2013 10:09

hi.
For the first time i've installed sabayon in my machine. After that following the wiki link

Code: Select all

http://wiki.sabayon.org/index.php?title=En:Entropy
i tried upgrading my system. however it ends up in an error. it reads the following

Code: Select all

...
 >>  +++ >>>  (4/653) perl-core/Scalar-List-Utils-1.270.0
>>    ## Unpacking: perl-core:Scalar-List-Utils-1.270.0~1.tbz2
>>    ## Installing package: perl-core/Scalar-List-Utils-1.270.0
>>    ## [Scalar-List-Utils module for perl]
>>    ## Updating database: perl-core/Scalar-List-Utils-1.270.0
>>    ## Cleaning previously installed application data.
>>    ## Package phase: postremove
>>    ## Package phase: postinstall
[color=#FF4000]>>    ## Source Package Manager is too old, please update it: UnsupportedAPIException()[/color]
>>    ## An error occured. Action aborted.
>>  @@ No configuration files to update.
localhost Documents # 
i tried upgrading it using rigo but there's also no luck. it's all the same.
Please help.

manifesto
Growing Hen
Posts: 180
Joined: Mon Jul 19, 2010 22:21

Re: equo upgrade showing error

Post by manifesto » Thu Feb 14, 2013 10:13

You may try to upgrade entropry/equo first.
http://wiki.sabayon.org/index.php?title ... using_Equo

lemon09
Baby Hen
Posts: 18
Joined: Thu Feb 14, 2013 10:00

Re: equo upgrade showing error

Post by lemon09 » Thu Feb 14, 2013 10:30

i have already performed that step. it is the same problem there.

Code: Select all

...
>>  ::: >>>  (91/92) 3 packages
>>    ## Package checksum matches: net-libs:libupnp-1.6.17~2.tbz2
>>    ## Package checksum matches: sys-libs:libavc1394-0.5.4~0.tbz2
>>    ## Package checksum matches: media-video:vlc-2.0.5~4.tbz2
>>  ::: >>>  (92/92) 1 package
>>    ## Package checksum matches: media-plugins:gst-plugins-cdio-0.10.19~4.tbz2
>>  +++ >>>  (1/274) dev-libs/glib-2.34.3
>>    ## Unpacking: dev-libs:glib-2.34.3~0.tbz2
>>    ## Package phase: setup
>>    ## Source Package Manager is too old, please update it: UnsupportedAPIException()
>>    ## An error occured. Action aborted.
>>  @@ No configuration files to update.
localhost Documents # 

loverollingrelease
Simple Hen
Posts: 46
Joined: Fri Jul 27, 2012 21:14

Re: equo upgrade showing error

Post by loverollingrelease » Thu Feb 14, 2013 10:54

well, equo is still "too old" and not updated

have you tried to use all the following steps
http://wiki.sabayon.org/index.php?title ... t_to_do.3F

lemon09
Baby Hen
Posts: 18
Joined: Thu Feb 14, 2013 10:00

Re: equo upgrade showing error

Post by lemon09 » Thu Feb 14, 2013 17:54

@loverollingrelease
yes....surely i have tried it....but again there is no luck...

User avatar
sabayonino
Sagely Hen
Posts: 3232
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: equo upgrade showing error

Post by sabayonino » Thu Feb 14, 2013 18:11

equo version installed ? :

Code: Select all

# equo --version
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

lemon09
Baby Hen
Posts: 18
Joined: Thu Feb 14, 2013 10:00

Re: equo upgrade showing error

Post by lemon09 » Thu Feb 14, 2013 19:43

@sabayonino

Code: Select all

localhost Documents # equo --version
175
localhost Documents # 

User avatar
sabayonino
Sagely Hen
Posts: 3232
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: equo upgrade showing error

Post by sabayonino » Thu Feb 14, 2013 19:47

equo version is latest version ...

maybe entropy version is old

Code: Select all

# entropy --version
retry :

Code: Select all

# equo update --force
# equo install equo entropy --relaxed
# equo upgrade --ask
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

lemon09
Baby Hen
Posts: 18
Joined: Thu Feb 14, 2013 10:00

Re: equo upgrade showing error

Post by lemon09 » Thu Feb 14, 2013 19:52

Code: Select all

# entropy --version
bash: entropy: command not found


User avatar
sabayonino
Sagely Hen
Posts: 3232
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: equo upgrade showing error

Post by sabayonino » Thu Feb 14, 2013 22:25

lemon09 wrote:

Code: Select all

# entropy --version
bash: entropy: command not found

:mrgreen: my bad ...

Code: Select all

# equo  search entropy
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

Post Reply