Can't start X after update [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Can't start X after update [Solved]

Postby pottzie » Sun Feb 10, 2013 0:21

I've had Sabayon for about 3 weeks now, and all was well. I just had Chromium lock up while watching a video, and had to do a hard reboot to get the system going again. When I rebooted, (I usually just leave my computer turned on), after loading the screens saying that the kernel was loading, when it went to start the Operating system, instead of starting the system, all that I have is a flashing cursor in the upper left hand corner.

I tried rebooting and using the advanced option, but when I gace the root password and told bash to startx, it said that it "could not create lock file in /tmp/.tx0-lock"

Is there anything that I can do to correct this?
Last edited by pottzie on Mon Feb 11, 2013 1:04, edited 1 time in total.
pottzie
Young Hen
 
Posts: 23
Joined: Thu Feb 16, 2012 2:42

Re: Can't start X after update

Postby pottzie » Sun Feb 10, 2013 3:20

It dawned on me after posting this that not only did I update the system, but when the update finished, Rigo showed that there were files that needed to be edited or altered. Not sure which files, but I've always just accepted whatever seems to be the option to automatically accept or update the files. That's what I did after the latest update, and that may be what's causing this problem.

I can get to a terminal by rebooting to the advanced option, and signing in as root. I just tried updating using "equo update," and I get a message saying that "Invalid file system encoding ANSI_X3.4-1968, must be UTF-8. Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values. Please execute: LC_ALL=en_US.UTF-8 /usr/bin/equo-update"

After doing that and trying again to update equo, I received a similar message, this time for /user/bin/equo install entropy rigo.

Not sure where to go from here, and not sure if this helps pinpoint my problem or just adds muddle to the mix, but it's what I've done so far.
pottzie
Young Hen
 
Posts: 23
Joined: Thu Feb 16, 2012 2:42

Re: Can't start X after update

Postby dave_64 » Sun Feb 10, 2013 21:00

If you have an older nvidia card you might find the following link useful:
viewtopic.php?f=86&t=28654
In my case, the first two steps were enough to get me a graphical interface. After that, I did the next two steps to make it permanent through subsequent upgrades.
By the way, when you get the flashing cursor in the upper right hand corner of a black screen, use a key combo of ctrl + alt + f1 to get a login prompt. Login as root and use equo to perform package management functions.
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: Can't start X after update

Postby pottzie » Mon Feb 11, 2013 1:03

Well, I got impatient and just re installed Sabayon. Like fixing a wart with a cutting torch, but that's what I went with.

Thanks.
pottzie
Young Hen
 
Posts: 23
Joined: Thu Feb 16, 2012 2:42


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests

cron