KDE hangs on boot [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

KDE hangs on boot [Solved]

Postby momiji2 » Tue Feb 05, 2013 19:24

I have just freshly installed Sabayon X KDE AMD64- this worked fine - I liked Sabayon +KDE so much I wanted to do a fresh install for a fresh start.
I then updated with Rigo, this went fine too. All freshly installed and fully updated.

On rebooting the system seems to boot normally (booting 70% is the last message I see) hang just before the login screen.
Cursor at top left of screen on blue design with 'sabayon' at bottom centre of sreen.

I am scratching my head here, I'd be grateful for any suggestions.
Last edited by momiji2 on Thu Feb 07, 2013 11:36, edited 1 time in total.
momiji2
Baby Hen
 
Posts: 15
Joined: Tue Feb 05, 2013 19:07
Location: United Kingdom

Re: KDE hangs on boot

Postby Ryuno-Ki » Tue Feb 05, 2013 19:59

Usually you have the chance to press Alt+F1 or F2 while booting Sabayon.
Does this provide any information (e.g. where does it stop?)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: KDE hangs on boot

Postby momiji2 » Tue Feb 05, 2013 21:37

Thankyou, F2 gives
I am pressing of the Pause/Break button really fast here

last few steps are:

Setting up kdm
INIT: Entering runlevel 3
starting syslog-ng
starting ufw

and then instead of flipping to the 'hang screen' this time it puts me to the console (I think that is what it is) a text login which I am able to do
momiji2
Baby Hen
 
Posts: 15
Joined: Tue Feb 05, 2013 19:07
Location: United Kingdom

Re: KDE hangs on boot

Postby momiji2 » Tue Feb 05, 2013 21:57

I have captured a few more steps

the steps continue to:
Running cpufreq-set --governor ondemand
Starting cupsd
Starting mdadm monitor
(possibly another step or two but too fast for me right now)

then to console login
momiji2
Baby Hen
 
Posts: 15
Joined: Tue Feb 05, 2013 19:07
Location: United Kingdom

Re: KDE hangs on boot

Postby Ryuno-Ki » Tue Feb 05, 2013 22:56

momiji2 wrote:then to console login

Black screen with blinking white underscore?
Yes, that's a console.

In case you can login … some logs would be nice. uhm,
Code: Select all
$ dmesg | pastebunz
$ cat /var/log/Xorg.0.log | pastebunz
$ cat .xsession-errors


Otherwise, what happens if you run
Code: Select all
startx
/etc/init.d/xdm restart

?
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: KDE hangs on boot

Postby momiji2 » Tue Feb 05, 2013 23:21

.xsession-errors is enormous - perhaps a clue here?

startx gives: (last lines of /var/log/Xorg.0.log are the same)
Fatal server error:
no screens found
Server terminated with error (1) closing log file
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

/etc/init.d/xdm.restart - goes straight to what I now think is the console background, but with the cursor blinking in top left corner. No input possible.

Have not been able to reliably get to the console prompt, most often it is just a blank cursor with no input available
This is what I have at the moment
momiji2
Baby Hen
 
Posts: 15
Joined: Tue Feb 05, 2013 19:07
Location: United Kingdom

Re: KDE hangs on boot

Postby dave_64 » Wed Feb 06, 2013 6:31

When you get to that "cursor blinking in the top left corner", you should be able to get to the console with a key combo of alt + f1 or alt+f2. Then you can log in.
What is your video card?
dave_64
Advanced Hen
 
Posts: 225
Joined: Sun Feb 22, 2009 20:33

Re: KDE hangs on boot

Postby Ryuno-Ki » Wed Feb 06, 2013 19:14

dave_64 wrote:[…]you should be able to get to the console with a key combo of alt + f1 or alt+f2.[…]

Don't forget Ctrl -> Ctrl+Alt+F1 (or F2 or … or F6).
Code: Select all
$ cat .xsession-errors | tail -N 10  # displays the last N=10 lines of .xsession-errors

Of course your file is huge now - you have tried logging in several times ;)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: KDE hangs on boot

Postby Ryuno-Ki » Wed Feb 06, 2013 19:27

momiji2 wrote:
Code: Select all
Fatal server error:
no screens found
Server terminated with error (1) closing log file
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


*Codeboxes added*
I searched a bit (have a look here). We need some more information:
Code: Select all
# lspci | grep VGA
$ lsmod | grep nvidia | pastebunz
$ cat /etc/X11/xorg.conf | pastebunz # after you tried to run startx

It could be a driver conflict (e.g. between nv and nvidia and nouveau and KMS).
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: KDE hangs on boot

Postby momiji2 » Wed Feb 06, 2013 19:43

Video card is ATI RV350 [Radeon X1600]
- got this info from hardinfo - have set up a dual boot with Fedora 18, this is working fine.

I will reboot into Sabayon to find the other info
momiji2
Baby Hen
 
Posts: 15
Joined: Tue Feb 05, 2013 19:07
Location: United Kingdom

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 6 guests