Gnome hangs at startup

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Gnome hangs at startup

Postby fire_dragon » Wed Jan 23, 2013 22:57

Dear friends,
I use KDE and installed Gnome through Rigo a while ago. it worked well.

Now I installed Mate and Cinnamon through Rigo for testing purposes and they work well, but now Gnome doesn't work anymore. I can access the login screen which is running on kdm, then I choose the entry Gnome and it starts and also starts some of my autostart applications somehow, but they disappear quickly and one application stays on top filling 3/4 of the screen, it has toolbar on top or anything besides the pure inside window of the application. I can choose exit but it will not exit. I cannot click anywhere or do anything except keys like Ctrl+Alt+F1 work to exit to prompt. From there I can login as root and reboot then. I cannot start any other window manager then, it sais x is already open, guessable I would have to exit x first to start a new x with the new window manager. Mouse also doesn't work in this Alt+Ctrl+F1 screen. Anyway, this isn't the problem.

In Rigo I tried the option reinstall on gnome, but no change.

After gnome was working and broken there was no software update through Rigo done. After the main update on monday, on tuesday Gnome still worked.

Any idea to make gnome work again?
fire_dragon
Simple Hen
 
Posts: 49
Joined: Wed Oct 24, 2012 13:22

Re: Gnome hangs at startup

Postby Ryuno-Ki » Thu Jan 24, 2013 7:37

fire_dragon wrote:I cannot click anywhere or do anything except keys like Ctrl+Alt+F1 work to exit to prompt. From there I can login as root and reboot then.

I recommend you to restart xdm, which will bring you back to the login screen:
Code: Select all
# /etc/init.d/xdm restart

fire_dragon wrote:I cannot start any other window manager then, it sais x is already open, guessable I would have to exit x first to start a new x with the new window manager.

See the manpages/help sites. Most window manager (e.g. KWin) have a "--replace" option which will replace Mutter (window manager of GNOME 3). I've read about hints, that this may break the desktop environment, since GNOME don't like anything else than Mutter *sighs*. Be warned.

Hm, most Desktop Environments creat error logs. .xsession-error.log or something like that. Have a look at it and paste it here:
Code: Select all
$ cat .xsession-error.log | pastebunz
or upload the file, if non-empty. Sorry, I'm not running my Sabayon box right now.

Sorry, I don't use GNOME resp. dislike the third edition. But I hope I can help you with some commands :)
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Gnome hangs at startup

Postby fire_dragon » Fri Jan 25, 2013 16:40

The command

Code: Select all
/etc/init.d/xdm restart

works well, thanks, its useful.

Mutter is installed according to Rigo, but the system will start up with KDM and then I don't know what Gnome uses.

I have searched my whole harddisks for "xsession-error.log", no file found.

Thank you for your help.
fire_dragon
Simple Hen
 
Posts: 49
Joined: Wed Oct 24, 2012 13:22

Re: Gnome hangs at startup

Postby Ryuno-Ki » Fri Jan 25, 2013 18:02

fire_dragon wrote:Mutter is installed according to Rigo, but the system will start up with KDM and then I don't know what Gnome uses.

Mutter … it's the window manager GNOME 3 uses in general. KDE uses KWin, LXDE Openbox and so on.

fire_dragon wrote:I have searched my whole harddisks for "xsession-error.log", no file found.

I've looked for it right now. It's just .xsession-errors. Note the leading dot!

In case you have any other desktop environment installed you could search the manpages for a --replace option. This could become very ugly …
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Gnome hangs at startup

Postby fire_dragon » Mon Jan 28, 2013 17:40

xsession error log shows this:

Code: Select all
/etc/X11/Xresources:5:3: error: invalid preprocessing directive #XFT
/etc/X11/Xresources:6:3: error: invalid preprocessing directive #These
/etc/X11/Xresources:7:3: error: invalid preprocessing directive #google
/etc/X11/Xresources:8:3: error: invalid preprocessing directive #crap
/etc/X11/Xresources:9:3: error: invalid preprocessing directive #normally
/etc/X11/Xresources:10:3: error: invalid preprocessing directive #because
/etc/X11/Xresources:11:3: error: invalid preprocessing directive #a
/etc/X11/Xresources:12:3: error: invalid preprocessing directive #autohinter
/etc/X11/Xresources:13:3: error: invalid preprocessing directive #(
/etc/X11/Xresources:14:3: error: invalid preprocessing directive #TT
/etc/X11/Xresources:15:3: error: invalid preprocessing directive #/
/etc/X11/Xresources:16:3: error: invalid preprocessing directive #rendered
/etc/X11/Xresources:17:3: error: invalid preprocessing directive #should
/etc/X11/Xresources:18:3: error: invalid preprocessing directive #that
/etc/X11/Xresources:19:3: error: invalid preprocessing directive #avoid
/etc/X11/Xresources:20:3: error: invalid preprocessing directive #INFINALITY_FT_AUTOFIT_FORCE_SLIGHT_HINTING
/etc/X11/Xresources:21:3: error: invalid preprocessing directive #use
/etc/X11/Xresources:22:3: error: invalid preprocessing directive #full
/etc/X11/Xresources:22:30: warning: missing terminating ' character [enabled by default]
/etc/X11/Xresources:23:3: error: invalid preprocessing directive #circumstances
/etc/X11/Xresources:24:3: error: invalid preprocessing directive #good
/etc/X11/Xresources:5:3: error: invalid preprocessing directive #XFT
/etc/X11/Xresources:6:3: error: invalid preprocessing directive #These
/etc/X11/Xresources:7:3: error: invalid preprocessing directive #google
/etc/X11/Xresources:8:3: error: invalid preprocessing directive #crap
/etc/X11/Xresources:9:3: error: invalid preprocessing directive #normally
/etc/X11/Xresources:10:3: error: invalid preprocessing directive #because
/etc/X11/Xresources:11:3: error: invalid preprocessing directive #a
/etc/X11/Xresources:12:3: error: invalid preprocessing directive #autohinter
/etc/X11/Xresources:13:3: error: invalid preprocessing directive #(
/etc/X11/Xresources:14:3: error: invalid preprocessing directive #TT
/etc/X11/Xresources:15:3: error: invalid preprocessing directive #/
/etc/X11/Xresources:16:3: error: invalid preprocessing directive #rendered
/etc/X11/Xresources:17:3: error: invalid preprocessing directive #should
/etc/X11/Xresources:18:3: error: invalid preprocessing directive #that
/etc/X11/Xresources:19:3: error: invalid preprocessing directive #avoid
/etc/X11/Xresources:20:3: error: invalid preprocessing directive #INFINALITY_FT_AUTOFIT_FORCE_SLIGHT_HINTING
/etc/X11/Xresources:21:3: error: invalid preprocessing directive #use
/etc/X11/Xresources:22:3: error: invalid preprocessing directive #full
/etc/X11/Xresources:22:30: warning: missing terminating ' character [enabled by default]
/etc/X11/Xresources:23:3: error: invalid preprocessing directive #circumstances
/etc/X11/Xresources:24:3: error: invalid preprocessing directive #good
startkde: Starting up...
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
kbuildsycoca4(9729) KBuildSycoca::checkTimestamps: checking file timestamps
kbuildsycoca4(9729) KBuildSycoca::checkTimestamps: timestamps check ok
kbuildsycoca4(9729) kdemain: Emitting notifyDatabaseChanged ()
QObject::connect: Cannot connect (null)::deviceFound(Device*) to BlueDevilDaemon::deviceFound(Device*)
QObject::connect: Cannot connect QTimer::timeout() to (null)::stopDiscovery()
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kded(9726)/kdeui (Wallet): The kwalletd service has been disabled
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
>>> 0x222e3c0 created Job Job
>>> 0x223a7a0 created JobFactory
>>> 0x21cb0d0 created JobFactory
>>> 0x21cbed0 created Job Job
>>> 0x21e7440 created Job Job
>>> 0x21cb0d0 deleted JobFactory
>>> 0x223a7a0 deleted JobFactory
>>> 0x222e3c0 deleted Job Job
fire_dragon
Simple Hen
 
Posts: 49
Joined: Wed Oct 24, 2012 13:22


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 7 guests