New install problem

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

New install problem

Postby cheltor » Fri Jan 18, 2013 21:46

Hi, I am looking for an alternative to that dreadful Windows 8, My machine is a Dell XPS L502X laptop with nVidia. I have created a new 200Gb partition on the hard drive, downloaded the image Sabayon_Linux_10_amd64_G.iso and checked its MD5 which was correct, burnt the image onto a DVD with ImgBurn and it validated OK. Then booted the live image and it came up OK, I set up the wireless network and decided to install on the empty partition on the hard drive. The install completed OK and I got the 'congratulations' message and telling me to reboot to pick up the new installation. Great I thought! So I rebooted and got the splash screen and the bar at the base moved steadily to the end. Then the screen went blank and I got the rotating pointer for about a minute then an arrow pointer and nothing the machine was locked up! the only way out was to crash the machine and restart.
Has anyone any ideas as to what the problem is? I cannot get into the hard drive installation to check it out.
Baby Hen
Posts: 3
Joined: Fri Jan 18, 2013 21:28

Re: New install problem

Postby Ryuno-Ki » Sat Jan 19, 2013 8:45

Hm, there are a few post concerning Windows 8 here. I have to admit, that the search sucks at this point, so I just link them here.

Maybe there's something helpfully for you. I don't have Windows 8 (just Windows XP running in VirtualBox ;-)).
Good luck!
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests
Old Dear Hen
Posts: 452
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: New install problem

Postby dunsurfin » Sat Jan 19, 2013 11:40

If you're getting as far as the splash screen and progress bar it suggests a possible graphics problem. If you can get to a command prompt from the initial boot screen you can (as root) try
Code: Select all
eselect opengl list
and see if nvidia is there and if it's selected (by an asterisk). If it's not selected then try
Code: Select all
 eselect opengl set nvidia
and reboot.
Something else to try from the CLI is
Code: Select all
equo update
followed by
Code: Select all
equo upgrade
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
Sagely Hen
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: New install problem

Postby cheltor » Sat Jan 19, 2013 22:31

Thanks for the advice folks, there is another twist to the problem, I installed the Mate desktop version and it installed with no problems (except I had no sound) but I prefer the Gnome desktop!!!. On the original (Gnome)install problem, as it booted on the live DVD with no problems - I got a properly displayed desktop and was able to run the install to disk program, then does this not indicate that Sabayon was able to work with the nVidia card? So it has to be something that is behaving differently when booting from the hard drive.
Baby Hen
Posts: 3
Joined: Fri Jan 18, 2013 21:28

Re: New install problem

Postby anomaly65 » Sun Jan 20, 2013 0:23

dunsurfin's advice looks good. Might consider pressing "alt-F2" when the X (xdm/etc) should appear and get a console login, then proceed with his ideas.

Might also post back (from livedvd even) output from "lspci" command to clue everyone in on various hardwire items (like which nvidia card is in the laptop; might be the issue?).

I'm betting a lot of the win8 issues are coming from the expiration of MBR (old enough to get a drink in a bar now) to GPT for the disk partition tables. Gonna be ugly, but gparted cd is a good download and nice gui to resize and squeeze the windows partition down a bit if needed:-)

Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
Technological Hen
Posts: 305
Joined: Sat Nov 17, 2007 15:37

Re: New install problem

Postby DeadlyWolf » Sun Jan 20, 2013 12:04

This is an Optimus Dell I believe. As far as I know this is still the way to install the drivers, ... &Itemid=23

More information is here
Linux User #521458.
Young Hen
Posts: 34
Joined: Sat Aug 28, 2010 5:49
Location: Queensland Australia

Re: New install problem

Postby cheltor » Tue Jan 29, 2013 20:55

Thanks for the advice everyone. As I said I put the mate version on and that was fine, I then tried to put the gnome version back on to try out you various suggestions only to find that this time I could not even get the live CD to load, the screen froze before it loaded, and I tried several times. So I am giving up on this one. Thanks again.
Baby Hen
Posts: 3
Joined: Fri Jan 18, 2013 21:28

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 6 guests