Equo-Rigo no-go [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Equo-Rigo no-go [Solved]

Postby mosesj01 » Mon Jan 07, 2013 23:54

Alrighty, then...

I need to run this by the more experienced. Here's the general situation:

A) Uname info: Linux iGeek-p6200 3.2.0-sabayon #1 SMP Thu May 24 15:59:45 UTC 2012 i686 Intel(R) Pentium(R) CPU P6200 @ 2.13GHz GenuineIntel GNU/Linux
B) Rigo notification icon -- shows 391 updates as available
C) Equo and Rigo -- neither will allow for an upgrade of the packages, citing a "dependencies not found" message following the "Calculating dependencies..." function of "equo upgrade"
D) The items not found are listed here:

Not found: >=dev-libs/glib-2.33.12:2
>> # package needed by:
>> # [from: sabayon-limbo] gnome-base/gvfs-1.14.2
>> # [from: sabayon-limbo] x11-libs/pango-1.32.5
>> # Not found: ~dev-python/pygobject-cairo-3.4.2[threads,python_targets_python2_7,-python_single_target_python2_6,-python_single_target_python2_7,-python_single_target_python3_1,-python_single_target_python3_2,-python_single_target_python3_3]
>> # package needed by:
>> # [from: sabayon-limbo] dev-python/pygobject-3.4.2-r1
>> # Not found: >=dev-libs/glib-2.33.4:2
>> # package needed by:
>> # [from: sabayon-limbo] gnome-base/gnome-session-3.6.2
>> # Not found: >=dev-libs/glib-2.34.0:2
>> # package needed by:
>> # [from: sabayon-limbo] x11-libs/gdk-pixbuf-2.26.5
>> # Not found: >=dev-libs/gobject-introspection-1.33.10
>> # package needed by:
>> # [from: sabayon-limbo] dev-libs/gjs-1.34.0
>> # Not found: ~dev-python/pygobject-base-3.4.2[threads,-examples,-test,python_targets_python2_7,-python_single_target_python2_6,-python_single_target_python2_7,-python_single_target_python3_1,-python_single_target_python3_2,-python_single_target_python3_3]
>> # package needed by:
>> # [from: sabayon-limbo] dev-python/pygobject-3.4.2-r1
>> # Not found: dev-python/pygobject-base:3[python_targets_python2_7,python_single_target_python2_7(+)]
>> # package needed by:
>> # [from: sabayon-limbo] gnome-base/gnome-applets-3.6.0-r1
>> # [from: sabayon-limbo] gnome-extra/cinnamon-1.6.7
>> # Not found: >=dev-python/pygobject-base-2.90.1:3[python_targets_python2_7,-python_single_target_python2_6,-python_single_target_python2_7,-python_single_target_python3_2,-python_single_target_python3_3]
>> # package needed by:
>> # [from: sabayon-limbo] dev-python/pyatspi-2.6.0-r1
>> # Not found: dev-python/pygobject-base:3[python_targets_python2_7,-python_single_target_python2_6,-python_single_target_python2_7]
>> # package needed by:
>> # [from: sabayon-limbo] gnome-base/gnome-menus-3.6.1-r2
>> # [from: sabayon-limbo] gnome-base/gnome-shell-3.6.2-r1
>> # Not found: >=dev-libs/glib-2.33.1
>> # package needed by:
>> # [from: sabayon-limbo] x11-libs/gtk+-3.6.3-r2
>> # Not found: >=dev-libs/glib-2.33.3:2
>> # package needed by:
>> # [from: sabayon-limbo] net-im/empathy-3.6.2-r2
>> # [from: sabayon-limbo] gnome-base/dconf-0.14.1
>> # [from: sabayon-limbo] gnome-base/gnome-desktop-3.6.2


I don't know why or how things got to this lock-up point. I have done vanilla-normal updates regularly for a year with no issues. This recent attempt was the first time I've run into such a problem.

Most times, I am savvy enough to diagnose a problem and find some solution, but this one has me stumped. Anyone have an idea what this may be and how I could resolve, workaround, or cope with the problem?

Thanks.
Last edited by mosesj01 on Fri Jan 11, 2013 1:58, edited 1 time in total.
mosesj01
Baby Hen
 
Posts: 7
Joined: Sun Apr 01, 2012 22:15

Re: Equo-Rigo no-go

Postby Stupot » Tue Jan 08, 2013 2:41

Are you using the sabayon-limbo repository on purpose? It's for testing out packages that aren't necessarily ready for prime time.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Equo-Rigo no-go

Postby mosesj01 » Tue Jan 08, 2013 5:13

I may have had an inkling or a good reason at the time, way back when I added it. How bad would it be to remove it at this time, best guess?
mosesj01
Baby Hen
 
Posts: 7
Joined: Sun Apr 01, 2012 22:15

Re: Equo-Rigo no-go

Postby Stupot » Tue Jan 08, 2013 5:16

If you remove it, a number of packages will probably be downgraded. If you have KDE installed, for instance, it will roll back everything from 4.9.5 to 4.9.4.

Your problem could also just go away with time when some stuff gets sorted out by the maintainers. But if this sort of things scares you, you probably shouldn't be running with limbo enabled. It can and will break from time to time.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Equo-Rigo no-go

Postby lxnay » Wed Jan 09, 2013 0:48

Why did you enable sabayon-limbo if you are using sabayon-weekly? You cannot do that.
(sabayonlinux.org + sabayon-limbo) OR (sabayon-weekly).
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Equo-Rigo no-go

Postby mosesj01 » Wed Jan 09, 2013 16:53

lxnay wrote:Why did you enable sabayon-limbo if you are using sabayon-weekly? You cannot do that.
(sabayonlinux.org + sabayon-limbo) OR (sabayon-weekly).


Why? I don't know, but now I know how the character from the 1970s show "Greatest American Hero" felt when he lost the manual to his super-suit. Uncle Ben Parker is lecturing me right now on the use of great power.

And yes, limbo has been disabled and the updates proceeded with no hang-ups. I had a feeling it was a simple, right-in-front-of-you, type of resolution to the problem. Thanks, all.
mosesj01
Baby Hen
 
Posts: 7
Joined: Sun Apr 01, 2012 22:15

Re: Equo-Rigo no-go

Postby Ryuno-Ki » Wed Jan 09, 2013 19:27

mosesj01 wrote:I had a feeling it was a simple, right-in-front-of-you, type of resolution to the problem. Thanks, all.

In case you consider your thread as solved, please mark it as [Solved].
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 2 guests