Can't log in to KDE after the last update.[Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Can't log in to KDE after the last update.[Solved]

Postby dirigible » Sun Dec 23, 2012 8:02

I decided to look for updates today. Rigo found some so I went ahead.
Before proceeding I decided to un-install KDE wallpapers. I don't use any of those images.
I wonder if this is how I broke my KDE?

When I rebooted I got some kind of message saying the previous session type was no longer valid. If I choose the default option the screen goes blank for a couple of seconds and then I'm back at the login screen.

Anyway now it looks like I can only log into sessions called fluxbox or failsafe. Console login works too. Fluxbox looks like somekind of desktop environment but I can't make out how to connect to the internet from there.

Any suggestions?
Last edited by dirigible on Mon Jan 07, 2013 11:46, edited 1 time in total.
dirigible
Young Hen
 
Posts: 36
Joined: Sun Sep 02, 2012 13:18

Re: Can't log in to KDE after the last update.

Postby wolfden » Sun Dec 23, 2012 9:11

The .xsession-errors file in home directory is a good spot to start looking for errors. Try logging into KDE and after it fails access the file via console. Sometimes renaming the .kde folder (not sure exact name) will work also. That will reset entire KDE to a default KDE session.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Can't log in to KDE after the last update.

Postby dirigible » Sun Dec 23, 2012 13:39

That KDE folder is called .kde4 so I renamed it to .kde5 and then back to .kde4. KDE still won't fire up.

I have no idea how to interperet the contents of.xsession-errors. Should I post a copy here?

I notice that issuing the command "Rigo" in fluxbox works. Is there a way to get an internet connection in fluxbox?
Perhaps something needs to be reinstalled.
dirigible
Young Hen
 
Posts: 36
Joined: Sun Sep 02, 2012 13:18

Re: Can't log in to KDE after the last update.

Postby creh » Sun Dec 23, 2012 17:58

You should rename the folder then login to KDE. Don't rename it back to ".kde4". "nm-applet" should work for the network connection
creh
Young Hen
 
Posts: 25
Joined: Mon Nov 19, 2012 17:03
Location: Vienna, Austria

Re: Can't log in to KDE after the last update.

Postby dirigible » Wed Dec 26, 2012 23:06

Renaming the folder isn't helping.

Run “nm-applet” in fluxbox doesn't work.
Does fluxbox use a different Network Manager to KDE?
dirigible
Young Hen
 
Posts: 36
Joined: Sun Sep 02, 2012 13:18

Re: Can't log in to KDE after the last update.

Postby creh » Thu Dec 27, 2012 0:57

Do you have nm-applet installed? It's not on the KDE iso. To start it automatically you can change the line
Code: Select all
exec /usr/bin/fluxbox

to
Code: Select all
nm-applet & exec /usr/bin/fluxbox

in the file /home/username/.fluxbox/startup
creh
Young Hen
 
Posts: 25
Joined: Mon Nov 19, 2012 17:03
Location: Vienna, Austria

Re: Can't log in to KDE after the last update.

Postby dirigible » Thu Dec 27, 2012 3:06

It's not installed.
I wasn't even aware Fluxbox was there as a backup desktop environment until this problem happened.
Looks like I'm going to backup and reinstall Sab KDE from scratch. This time ensuring Fluxbox can connect to the web incase I ever need it.

Rigo says the network manager applet comes in 3 flavours, all just under 1MB to download.

Nm Applet Gtk2 0.9.4.1~0
Nm Applet Gtk2 0.9.6.4~0
& Nm Applet 0.9.6.4~0

Which one is right for the Fluxbox DE?
dirigible
Young Hen
 
Posts: 36
Joined: Sun Sep 02, 2012 13:18

Re: Can't log in to KDE after the last update.

Postby creh » Thu Dec 27, 2012 10:48

All three of them should work. I have gnome-extra/nm-applet-0.9.6.4 installed. You probably need a polkit authentication agent. The KDE agent is located at /usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1.
You can add
Code: Select all
/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1 &

to the file '/home/username/.fluxbox/startup' before 'exec /usr/bin/fluxbox'
creh
Young Hen
 
Posts: 25
Joined: Mon Nov 19, 2012 17:03
Location: Vienna, Austria

Re: Can't log in to KDE after the last update.

Postby dirigible » Sat Dec 29, 2012 2:01

Reinstalled Sabayon KDE from scratch. Installed nm-applet and checked Fluxbox could connect to the net.

Then I decided to uninstall KDE wallpapers again to see if it was the removal of this package which caused the problem (It may have been something else in the update).

Same result, I no longer have KDE as a session option.
Is this normal? Does the KDE desktop environment depend on the KDE wallpapers package? I had always assumed pretty wallpapers were an option.

Anyway, I reinstalled the KDE wallpapers and still don't have KDE as a session type option.
Is this fixable without doing a full reinstall again?
dirigible
Young Hen
 
Posts: 36
Joined: Sun Sep 02, 2012 13:18

Re: Can't log in to KDE after the last update.

Postby dave_64 » Sun Dec 30, 2012 1:05

You might run:
equo install kde-wallpapers --pretend

Then install the packages that show up as a result of that command.
I show 4 packages when I run that command.
dave_64
Advanced Hen
 
Posts: 226
Joined: Sun Feb 22, 2009 20:33

Next

Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron