Sabayon dont start after last update. [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Sabayon dont start after last update. [Solved]

Post by francesco21 » Thu Dec 13, 2012 11:02

I've this problem with sabayon 10. I've update the system and after the reboot the sytem dont start, i can see only the comand line. Does you have any solution?

manifesto
Growing Hen
Posts: 180
Joined: Mon Jul 19, 2010 22:21

Re: Sabayon dont start after last update.

Post by manifesto » Thu Dec 13, 2012 14:05

what do the screen says ?
maybe it is asking for root device, then type /dev/sdaX or something like that.

francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Re: Sabayon dont start after last update.

Post by francesco21 » Thu Dec 13, 2012 21:39

This method don't work. It's not the first time with this problem, for me, what can i do to start the system by command line?

francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Re: Sabayon dont start after last update.

Post by francesco21 » Thu Dec 13, 2012 22:11

I had a similar problem with sabayon 8, because the nvidia 7300 geforce was in the black list. After the 8 version i don't have problem, i ask: can be the same problem?

manifesto
Growing Hen
Posts: 180
Joined: Mon Jul 19, 2010 22:21

Re: Sabayon dont start after last update.

Post by manifesto » Thu Dec 13, 2012 22:30

If you dont say what is on the screen we cant help.
Please be precise do you have black screen or something written on it waiting for your input ?

Ryuno-Ki
Old Dear Hen
Posts: 471
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany
Contact:

Re: Sabayon dont start after last update.

Post by Ryuno-Ki » Thu Dec 13, 2012 22:55

francesco21 wrote:It's not the first time with this problem, for me, what can i do to start the system by command line?
I had a similar problem some days ago, too. In case you have a legacy graphic card (mine is NVIDIA GeForce 6150SE) the problem is, that your card isn't supported by the recent driver.

First thing: Sign in on a TTY (e.g. Ctrl+Alt+F3) as root and have a look into the dmesg:

Code: Select all

# tail -n 10 /var/log/dmesg
You can add "|pastebunz" if you want to share the output with us (post the link).

My dmesg claimed something about an unsupported graphic card (sorry, I don't remember the exact log). You can search the whole file also:

Code: Select all

# cat /var/log/dmesg | grep -i -A 5 NVIDIA
searches dmesg, ignoring lower-/uppercase and prints the following five lines after a match, too.

You can read about the needed NVIDIA-drivers version in dmesg. In this case, use this instruction while modifying the version to the needed one. If you're unsure, report some output ;-)

N.B.

Code: Select all

#`uname -r` --ask
is deprecated. The recommended syntax is

Code: Select all

#$(uname -r) --ask
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests

francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Re: Sabayon dont start after last update.

Post by francesco21 » Sat Dec 15, 2012 2:35

I try this method an i will let you know. :D

francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Re: Sabayon dont start after last update.

Post by francesco21 » Sat Dec 15, 2012 10:54

With the first command you wrote, # tail -n 10 /var/log/dmesg , i get the following response:

Your system is not currently configured to dirve a VGA console on the primary VGA devide. The NVIDIA linux graphics driver requires the use of a text-mode VGA console. Use of other console drivers including, but not limited to, vesafis, may result in corruption and stability problem, and is not supported.

Help me, my PC is stopped from 5 days and i must to use Windows.. :cry:

francesco21
Growing Hen
Posts: 122
Joined: Tue May 29, 2012 20:51

Re: Sabayon dont start after last update.

Post by francesco21 » Tue Dec 18, 2012 12:52

Solved with:

equo install x11-drivers/nvidia-drivers-304.64#'uname -r'

Thank you so much to all who have helped me

dave_64
Advanced Hen
Posts: 226
Joined: Sun Feb 22, 2009 20:33

Re: Sabayon dont start after last update. [Solved]

Post by dave_64 » Tue Dec 18, 2012 16:53

I fixed computers for 3 people over the weekend using the 304.64 driver. All of them had the nvidia 6150 chipsets. I usually run equo deptest before installing the 304 driver, and a few other checks, such as eselect kernel list, and, eselect opengl list.
Thanks for sharing the command you used...it's a bit more "elegant" than my method.

Post Reply