xorg.conf

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

xorg.conf

Postby amandus » Thu Dec 06, 2012 13:22

I have installed Sabayon but it failes on my graphic card (Nvidia FX5200)
I got this at boot with live cd:
/sys/module/nvidia (3105) !
/sys/module/nvidia (3106) !

I have tried to install nouveau driver instead of nvidia and put nouveau in my xorg.conf but it did not work,

Are there anything else I must do? So I can get it to work with nouveau?
amandus
Simple Hen
 
Posts: 50
Joined: Mon Oct 01, 2012 15:09
Location: Sweden

Re: xorg.conf

Postby steffie » Thu Dec 06, 2012 14:39

Supported Cards for 173.14.xx:
GeForce PCX 5750
GeForce PCX 5900
Quadro FX 330/GeForce PCX 5300
Quadro FX 330/Quadro NVS 280 PCI-E
Quadro FX 1300
GeForce FX 5800 Ultra
GeForce FX 5800
Quadro FX 2000
Quadro FX 1000
GeForce FX 5600 Ultra
GeForce FX 5600
GeForce FX 5600XT
GeForce FX Go5600
GeForce FX Go5650
Quadro FX Go700
GeForce FX 5200
GeForce FX 5200 Ultra
GeForce FX 5200
GeForce FX 5200LE
GeForce FX Go5200
GeForce FX Go5250
GeForce FX 5500
GeForce FX 5100
GeForce FX Go5200 32M/64M
steffie
Simple Hen
 
Posts: 66
Joined: Fri May 04, 2012 2:40
Location: Neustadt a. Rbge.

Re: xorg.conf

Postby batvink » Fri Dec 07, 2012 10:42

Open your favourite konsole/terminal as root, and enter:
Code: Select all
equo remove nvidia-drivers --ask

It should remove the current installed nvidia-driver plus dependencies. (check that...)
Then:
Code: Select all
equo install nvidia-drivers-173.14.36#`uname -r` --ask

(also check that the right drivers plus dependencies getting installed, according to the command.)
If everything went well, the new (right) drivers are installed.

Now, when upgrading the System, it probably also wants to upgrade your nvidia-driver,
which you don't want., so you have to mask all future nvidia-drivers it may want to upgrade to...
Enter (while still running the terminal) as root:
Code: Select all
nano -w /etc/entropy/packages/package.mask

Scroll to the end of the list, and enter the following:
Code: Select all
>=x11-drivers/nvidia-drivers-174.0.0
>=media-video/nvidia-settings-174.0.0
>=x11-drivers/nvidia-userspace-174.0.0

Save the file by pressing (CTRL+O) and leave the nano-editor by pressing (CTRL+X)

Next, edit xorg:
Code: Select all
nano -w /etc/X11/xorg.conf

search under: section "device" if the driver is nvidia:
Code: Select all
Section "Device"

    Identifier  "SabayonVga0"
    Driver      "nvidia"
    #BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
#    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection

If not, correct it, save, and close the editor.
Restart X:
Code: Select all
/etc/init.d/xdm restart

It closes all programs, the session, and brings you back to login.
Now you should login properly with a working X.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: xorg.conf

Postby amandus » Sat Dec 08, 2012 9:39

The big problem is that I can´t get it to load the install when I click the icon "Install" on the desktop.
amandus
Simple Hen
 
Posts: 50
Joined: Mon Oct 01, 2012 15:09
Location: Sweden

Re: xorg.conf

Postby micia » Sat Dec 08, 2012 9:57

I am a bit confused, when does this issue happen exactly?

Is Sabayon installed on your system or are you trying to install it and you can't open the installer at all? By your first post I assumed you already installed Sabayon but the graphical interface doesn't load because of your drivers.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: xorg.conf

Postby amandus » Sat Dec 08, 2012 10:15

Yes I did a text installation and then I tried to install a driver but it fails, then I try a new installation and go in safe mode and then the desktop comes up but nothing happens when I click the icon.

I removed the first installation with gparted, and saw that the installation put in LVM and that I don´t want. I could´n find any choice for other filesystem in text mode install. Now I have put in Arch Linux, but I want Sabayon.
amandus
Simple Hen
 
Posts: 50
Joined: Mon Oct 01, 2012 15:09
Location: Sweden

Re: xorg.conf

Postby micia » Sat Dec 08, 2012 10:45

No need for that, it's an easy fix really, did you try the xdriver=vesa boot parameter in the live boot menu?
http://wiki.sabayonlinux.org/index.php?title=En:Sabayon_Linux#Boot_parameters_and_workarounds_for_problematic_Hardware

Once you get Sabayon installed (with your preferred partitioning scheme) it's easy to fix that.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: xorg.conf

Postby amandus » Sat Dec 08, 2012 11:30

Yes I have tried that, it was then I got a desktop up but the install icon don´t work then.
amandus
Simple Hen
 
Posts: 50
Joined: Mon Oct 01, 2012 15:09
Location: Sweden

Re: xorg.conf

Postby micia » Sat Dec 08, 2012 12:14

When you are in graphical mode, does it produce any output if run from within a console window?

If running on KDE live:
(run as normal user)
Code: Select all
kdesu installer


Otherwise:
(run as normal user)
Code: Select all
gksu installer


You could also try to run with:
xdriver=nouveau
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: xorg.conf

Postby batvink » Sat Dec 08, 2012 15:23

Do you remember when you downloaded the ISO,? 'cause there were problems with them around 28-11-2012
Issues like: installer doesn't work, bad graphics, etc.

If Micia's sugestion also don't work,
Please try to burn a fresh ISO., and reinstall.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands


Return to Beginners|Newbies Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron