aMule crashes on launch [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
bitERROR
Simple Hen
Posts: 43
Joined: Mon Jul 04, 2011 20:14

aMule crashes on launch [Solved]

Post by bitERROR » Mon Mar 12, 2012 11:44

When I try to start amuled (amule daemon) via ssh I got this message and doesn't starts.

Code: Select all

[email protected] ~ $ amuled
 2012-03-12 11:39:39: Initialising aMuleD 2.3.1 compiled with wxGTK2 v2.8.12
 2012-03-12 11:39:39: Checking if there is an instance already running...
 2012-03-12 11:39:39: No other instances are running.
        aMule Version: aMuleD 2.3.1 compiled with wxGTK2 v2.8.12

Terminated after throwing an instance of 'CEOFException'
        what(): SafeIO::EOF: Attempt to read past end of file.
        backtrace:
[2] ?? in amuled[0x8072083]
[3] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb702d2ff]
[4] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb702d376]
[5] ?? in amuled[0x80716eb]
[6] __libc_start_main in /lib/libc.so.6[0xb6d11e03]
[7] ?? in amuled[0x806ea7d]

Avortat
This is a Sabayon 8 running without desktop environment. So amule gui isn't started, and no others instances (as said in the message).

I looked for the installed version of wxGTK

Code: Select all

[email protected] ~ $ equo query installed wxGTK
>>  @@ S'està cercant...
>>      @@ Paquet: x11-libs/wxGTK-2.8.12.0 branca: 5, [__system__]
>>         Instal·lat:       Versió: 2.8.12.0 ~ tag: NoTag ~ revisió: 3
>>         Slot:             2.8
>>         Pàgina inicial:   http://wxwidgets.org/
>>         Descripció:       GTK+ version of wxWidgets, a cross-platform
>>                           C++ GUI toolkit.
>>         Llicència:        GPL-2 wxWinLL-3
>>  Keyword:       wxGTK
>>  S'han trobat:  1 entry
Last edited by bitERROR on Wed Mar 14, 2012 15:02, edited 2 times in total.

bitERROR
Simple Hen
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: aMule crashes on launch

Post by bitERROR » Wed Mar 14, 2012 12:29

not working yet, any suggestion?

dudumomo
Growing Hen
Posts: 149
Joined: Tue Nov 16, 2010 14:40
Contact:

Re: aMule crashes on launch

Post by dudumomo » Wed Mar 14, 2012 14:48

It may be due to a setting problem. (A suggestion)

You can save the configuration and files by copying your .aMule folder and let aMule recreate a new one. (Then copy back what is needed)

Code: Select all

mv .aMule .aMule_back
than restart aMule.

Let us know if it helps or not.

bitERROR
Simple Hen
Posts: 43
Joined: Mon Jul 04, 2011 20:14

Re: aMule crashes on launch

Post by bitERROR » Wed Mar 14, 2012 15:02

Yes, it works now.

Thank you!

Post Reply